Журнал LinuxFormat - перейти на главную

LXF124:GIMP

Материал из Linuxformat
Перейти к: навигация, поиск
GIMP Свободный графический редактор, в который вы тоже можете вонзить зубы

Содержание

GIMP: Лето любви

GIMP 2.4
Кудесник GIMP Майкл Дж. Хэммел приглашает потусоваться в романтической ретро-атмосфере солнечных лучей и силуэтов.

Я родился на излете эпохи бэби-бума и был слишком юн, чтобы побывать на Вудстоке, а мои родители уже были для этого слишком взрослыми. Они отжигали с Джерри Ли Льюисом, а я предпочитал «мягкие» мелодии Pink Floyd или AC/DC. Никто из нас не принадлежал к «детям цветов».

LXF124 56 1.jpg Любовь в 60-х была черно-белой, лишь со всполохом цвета. А может, виноваты розовые очки...

Поэтому наш солнечный урок обязан рассказам о 60‑х других людей: солнце, лучи света, любовь и зеленые луга, в ретроспективе теплых чувств. Самому мне кажется, что все было гораздо сложнее. Но – не для нас. По крайней мере, не в этом месяце.

Данное руководство будет одним из самых простых за всю серию – здесь не нужно особых талантов, но потребуются дополнительные кисти. Я поясню, где найти их и как использовать. Также понадобится стоковое фото, и я укажу вам, где взял свое. Шагаем назад, в прошлое!

Создаем градиент

Начнем работу с заливки цветом заднего плана, в виде градиента. Простейший способ для этого – настроить цвета фона и переднего плана и использовать инструмент Градиент с панели инструментов, протащив линию сверху вниз. Но мы-то попробуем сделать свой градиент.

LXF124 56 2.jpg Градиенты создавать легко, а применять их можно для фона, шаблонов текстуры или 3D-эффектов.

Откроем новое изображение (Файл > Создать) размером 1600 × 1200 пикселей. Нажмем D в пределах окна изображения, чтобы установить значения по умолчанию для цветов фона и переднего плана – белый и черный соответственно. Внизу диалога градиентов (Окна > Панели > Градиенты) находятся значки иконок для работы с градиентами. Щелкнем по второй иконке слева, создающей новый градиент. В открывшемся окне редактора градиентов начальный градиент создан из цвета переднего плана на левом крае и цвета фона справа. Щелкнем по градиенту и придержим правую клавишу мыши. В открывшемся меню выберем Цвет крайней левой точки. В появившемся диалоге выставим значения для R, G и B в 219, 122 и 2 соответственно. Щелкнем OK, чтобы назначить левый цвет.

Создание нового градиента, собственно, и состоит в применении пунктов этого меню: добавления новых сегментов, настройки цветов для обоих сторон сегмента и настройки размеров этих сегментов. В Редакторе градиентов поменяем название с Untitled на «Любовь в стиле ретро». Щелкнем по кнопке Сохранить, закроем диалог редактора градиентов и выберем инструмент Градиент на панели инструментов. В параметрах инструмента щелкаем на кнопке Градиентов и выбираем градиент «Любовь в стиле ретро». В окне изображения протаскиваем линию сверху вниз.

Временно зеленые холмы

LXF124 57 1.jpgДва холма нужны для того, чтобы наше поросшее травой поле не выглядело плоским и унылым. Холмы придадут живости окончательному варианту рисунка.

Следующий шаг – не сложнее: создадим два холмика и раскрасим их разными оттенками зеленого. Но это временное окрашивание – вырастив на холмах траву, мы превратим их в силуэты.

Оба холма создадим с помощью овального выделения в раздельных слоях. Уменьшим масштаб изображения (Вид > Масштаб > Уменьшить масштаб). Создадим новый прозрачный слой (Слой > Создать слой) и назовем его «Передний холм». Инструментом овального выделения «протянем» овал поперек нижней части изображения. Щелкнем по квадратику цвета переднего плана на панели инструментов и изменим значения RGB на 60, 138 и 60 соответственно. Перетащим квадратик цвета переднего плана на выделение и уберем выделение (Выделение > Снять).

Второй холм делается по той же схеме, только имя слоя будет «Задний холм». Просто сместите выделение немного вправо и после окрашивания слегка затемните его через диалог Яркость-контраст (Цвет > Яркость-контраст). Переместим слой ниже слоя переднего холма в стопке слоев в диалоге Слои. Уменьшим масштаб, чтобы слои поместились в окне изображения.

Фоновое солнце

Перейдем к солнцу. Оно будет состоять из двух слоев: один – с самим светилом, окрашенным однородно, другой – с небольшой туманностью, чтобы образовать на нем дымку.

Создадим прозрачный слой и назовем его «Солнце». Передвинем слой под слой с фоновым холмом в стопке слоев в диалоге Слои. Снова выберем инструмент овального выделения. В параметрах инструмента отметим опцию Фикс. и назначим для нее Соотношение сторон. Создадим овальное выделение в окне изображения и расположим его над обоими холмами.

LXF124 57 2.jpgПоскольку этот слой расположен под слоями холмов, возникает впечатление, что солнце садится (или встает) за холмами.

Размер и положение выделения в GIMP 2.6 можно изменить, продвигая курсор по квадратикам, ограничивающим окружность. Срединный квадрат используется для перемещения выделения, а верхний, левый, правый и нижний изменяют высоту и ширину выделения. Угловые изменяют высоту и ширину одновременно. Выделение доступно для редактирования, пока вы не нажали клавишу Enter или не выбрали другой инструмент на панели инструментов.

Щелкнем на квадратике цвета переднего плана на панели инструментов для изменения цвета и выставим значения RGB в 248, 236 и 166 соответственно. Нажмем OK, чтобы закрыть диалог, и перетащим квадратик в окно изображения.

Скопируем слой «Солнце» (Слой > Продублировать слой) и назовем новый слой «Дымка». Откроем Гауссово размывание (Фильтры > Размывание > Гауссово размывание). Настроим предпросмотр так, чтобы был виден край солнца. Назначим радиус размывания как 150 для обоих направлений. В типах размывания выберем RLE. Нажмем OK, чтобы применить размывание к слою «Дымка» и выставим режим этого слоя в Добавление. В итоге получится яркое белое солнце, чуть тронутое желтым по краям.

LXF124 57 3.jpg Чтобы солнце стало желтее, используйте более темный оттенок цвета для начального слоя, затем уменьшите непрозрачность слоя с дымкой.

Ретро-оттенок: солнечные лучи

Следующий шаг: добавим лучи света, испускаемые солнцем. Проще будет, если мы сперва снова уменьшим рисунок. Начнем с горизонтального луча, протянувшегося от солнца к левому краю. Добавим прозрачный слой с именем «Луч» и поместим его поверх стопки слоев. Щелкнем по левой линейке и «вытянем» направляющую к центру солнца, затем – по верхней линейке, и протащим направляющую к той же точке. На панели инструментов выберем Контуры. В окне изображения щелкнем точно над и точно под пересечением направляющих. Затем щелкнем за левой границей слоя и точно под и над предыдущими двумя точками. Далее, нажмем «Контур в выделенную область» в диалоге параметров инструмента и зальем выделение белым.

Выделение должно быть еще активным. Скопируем (Ctrl+C) и вставим (Ctrl+V) его как новый слой (Слой > Создать слой). Инструментом зеркального отражения перевернем его горизонтально, затем с помощью Перемещения расположим слой так, чтобы его левая граница совпала с пересечением направляющих. Скопируем этот слой и повернем его по часовой стрелке на 90 градусов (Слой > Преобразования > Повернуть на 90 по часовой стрелке). Расположим его так, чтобы его нижняя граница совпала с пересечением направляющих.

LXF124 58 1.jpg Постарайтесь не делать начальный луч слишком широким; но если так не получится, размывание и настройка непрозрачности спасут ситуацию.

Скопируем этот слой и повернем его на 45 градусов (Слой > Преобразования > Произвольное вращение). После этого нижний левый угол слоя можно совместить с пересечением направляющих. Скопируем слой и зеркально отразим его по горизонтали, затем приставим его к месту. Дополнительные лучи можно сделать, копируя вертикальные или горизонтальные лучи и поворачивая их. В некоторых случаях луч не будет доставать до края изображения, потому применим инструмент Масштабирование, чтобы дотянуть луч до самого края.

Чтобы слить все слои с лучами воедино, отключим видимость всех слоев, кроме слоев с лучами, затем объединим видимые слои (Изображение > Объединить видимые слои...). Делаем из всего этого выделение (Слой > Прозрачность > Альфа-канал > Выделенная область). Создадим новый прозрачный слой с именем «Градиент света». Нажмем D и затем X в пределах окна изображения, чтобы задать белый цвет цветом переднего плана.

LXF124 58 2.jpg Если лучи тускловаты, скопируйте слой и отрегулируйте Режим и Непрозрачность по своему вкусу.

На панели инструментов выберем Градиент. В параметрах инструмента установим «Основной в прозрачный» и радиальную форму. Щелкнем в окне изображения на пересечении направляющих и протащим за верхний левый угол. Отключим видимость слоя «Луч» в диалоге слоев и включим видимость всех остальных слоев, затем передвинем «Градиент света» ниже слоя «Солнце». Откроем диалог Гауссово размывание и выставим радиус на 20. Нажмем OK, чтобы применить фильтр к слою «Градиент света».

Фигуры влюбленных

Находим стоковое фото

Это изображение можно найти на BigStockPhoto.com – сайте с недорогими стоковыми изображениями. Варианты на эту тему можно поискать с помощью ссылки “See Similar Photos” справа от предпросмотра изображения.

Следующая составная часть работы – стоковое фото для создания силуэта влюбленной пары. Ищите фотографию с однотонным фоном – так будет легче выделить их фигуры. Фото, которое я здесь использую, найдено на сайте BigStockPhoto.com (cм. врезку).

Данное конкретное фото очень хорошо подходит для работы с инструментом «Выделение переднего плана». Выберем его на панели инструментов (его иконка выглядит как голова и плечи рядом с белым призраком справа сзади). Активировав этот инструмент, очертим свободное выделение вокруг парочки, что даст нам первичное грубое выделение, подобное быстрой маске. Далее, в диалоге кистей выберем кисть (Окна > Кисти). Кисть должно быть видно при наведении мыши на окно изображения. Для этого фото кисть должна быть не толще самой узкой части руки девушки. Размер кисти настраивается ползунком в диалоге параметров инструмента.

LXF124 58 3.jpg Грубое выделение (слева) мы улучшили (справа) с помощью маленькой жесткой кисти, уменьшив ее масштаб в параметрах инструмента.

Рисуем кистью поверх юноши и девушки, захватывая все области с высококонтрастными перепадами, которые вы намерены включить в выделение. Особая точность здесь не нужна. Для завершения выделения нажмем Enter, чем превратим окрашивание в стиле Быстрой маски в выделение. Скопируем (Ctrl+C) и вставим (Ctrl+V) выделение в начальное окно изображения как новый слой и назовем его «Парочка». При необходимости подгоним масштаб или зеркально отразим слой.

Выделим парочку в новом слое (Слой > Прозрачность > Альфа-канал > Выделенная область). Расширим границу слоя на 10 пикселей (Слой > Границы слоя) в ширину и в высоту. Щелкнем на кнопке «Центр», чтобы поместить изображение по центру в пределах новых границ, а затем по кнопке Изменить размер, чтобы применить изменения. Затем увеличим выделение на один пиксель (Выделение > Увеличить...). В диалоге слоев запретим изменения для прозрачных областей слоя «Парочка», отметив галочкой опцию «запереть». Нажмем D в пределах окна изображения, чтобы установить цвета по умолчанию, и перетащим цвет переднего плана на слой. Благодаря опции Запереть, черным цветом будет залит только силуэт влюбленных. Уберите выделение (Выделение > Снять).

LXF124 59 1.jpg Чтобы оптимально разместить силуэт, может понадобится изменить масштаб и зеркально отразить силуэт влюбленной пары.

Завершим отделку холмов

Следующий шаг – превратим холмы в поросшие травой силуэты. На этом этапе можно скрыть направляющие (Вид > Показывать направляющие) или вовсе удалить их (Изображение > Направляющие > Удалить направляющие). Сначала изменим цвет холмов с зеленого на черный. Выделим каждый слой по очереди и отметим для каждого галочку «Запереть», затем перетащим квадратик с цветом переднего плана на слой, точно так же, как делали со слоем «Парочка».

В GIMP по умолчанию нет растительных кистей, подходящих для этой работы. Но в сети есть много доступных наборов кистей. После установки новых кистей GIMP придется перезапустить. Поэтому сохраним работу как Любовь-в-стиле-ретро.xcf и выйдем (Файл > Выйти). Снова запустим GIMP, откроем файл Любовь-в-стиле-ретро.xcf, и наши кисти будут готовы к бою.

LXF124 59 2.jpg Поросшее травой поле создано при помощи набора кистей Grass Brush Set и выглядит как холмистый силуэт.

Много разных наборов кистей, причем доступных для свободного скачивания, создано для Photoshop: они представляют собой один файл с расширением .abr, где находится несколько кистей. GIMP прекрасно читает эти файлы.

Создадим новый прозрачный слой и назовем его «Трава». Расположим его точно над слоем переднего холма в стопке слоев. Откроем диалог кистей (Окна > Кисти) и выберем подходящую кисть. Установим интервал в диапазоне между 50 и 150 (или меньше, если размер вашей работы меньше размера 1600 × 1200, выбранного мной). На панели инструментов выберем Кисть и в диалоге параметров инструмента настроим опцию Масштаб, чтобы подобрать подходящую толщину линии (для наглядности поместите мышь над окном изображения). Несколько раз применим кисть по краям холмов, затем переключимся на другую травяную кисть и будем повторять процесс до тех пор, пока холмы не покажутся вам достаточно травянистыми.

Птички на заднике

Последний шаг опционален, но разнообразит проект. Главное – найти в свободном доступе кисти-«птички». После их установки сохраним работу и перезапустим GIMP, затем снова откроем проект, создадим новый прозрачный слой и назовем его «Птицы». Выберем «птичью» кисть, установим масштаб и сделаем несколько мазков на просторах неба. Если птицы изображаются не силуэтами, выделите их (Слой > Прозрачность > Альфа-канал > Выделение) и залейте выделение черным. LXF

LXF124 59 3.jpg Стайка птиц придаст картинке летнее настроение, но при переборе с их количеством получится афиша к фильму Хичкока…

Персональные инструменты
купить
подписаться
Яндекс.Метрика