Журнал LinuxFormat - перейти на главную

LXF72:GIMP

Материал из Linuxformat
Перейти к: навигация, поиск
GIMP (Майкл Дж. Хэммел)

Содержание

создание металлической эмблемы в Gimp

Изучаем технику сглаживания и гравировки с Майклом Дж. Хэммелом (Michael J Hammel).

При разработке дизайна футболки, web-сайта или фирменного бланка для компании вы скорее всего воспользуетесь идентифицирующим символом. Графические символы – это важная часть продукта и корпоративного дизайна, это образ, значение которого мы чувствуем сердцем – например желтые арки, красная шляпа или пингвин.

Символ может быть плоским и ровно закрашенным, плоским, но имеющим текстуру или же трёхмерным с бликами и тенями. Для печати символы проще (и правильнее) рисовать ровным цветом, web позволяет использовать более сложные техники. цвет царствует во Всемирной паутине, экраны, способные отображать миллионы цветов, давно стали нормой, так что даже самая маленькая компания может себе позволить красивый разноцветный логотип.

логотипы обычно набираются каким-нибудь особенным шрифтом, часто с изменённой формой символов, чтобы представить компанию, группу или одного человека. логотипы часто сплетаются с другой символикой для создания эмблемы как части общего уникального образа компании.

одним из самых простых вариантов эмблемы является металлический или стеклянный вариант логотипа. При рисовании стеклянного логотипа используются мягкие цветовые переходы с малозаметными или вовсе отсутствующими шероховатостями. несколько слоёв с белыми овалами ( или частями овалов) помещают поверх изображения, что-бы показать блики на гладкой поверхности логотипа. часто овал обрамляют чёткими границами для того, чтобы стеклянный или пластиковый логотип казался вставленным в рамку.

Металлический логотип сгенерировать проще. Этот эффект основан на том, у блика на металлической поверхности образуются узкая высоко контрастная область между светом и тенью. Этот вариант можно использовать как для получения цельнометаллической эмблемы – например пряжки или значка, так и сделав металлические края вокруг неметаллических частей.

Добавление цветов и бликов не только внесёт особый шарм в ваш дизайн, его еще и очень легко добиться. В этой статье я буду работать с небольшой картинкой, чтобы было проще продемонстрировать суть применяемых техник. но помните, что растровые изображения, которые вы создаёте при помощи Gimp или Photoshop масштабируются не слишком хорошо. Поэтому я рекомендую сразу начинать с большой канвы, и масштабировать методы, а не картинку, если вам нужна эмблема побольше.

создание канвы

Img 72 85 1.jpg

Перед началом работы нажмите D в панели инструментов, для того чтобы установить цвета заднего и переднего плана в значения по умолчанию – белый и чёрный соответственно. При помощи меню File >New откройте диалог New Image, проверьте что в нём указан размер изображения по умолчанию 420 x 300 пикселей, затем переключитесь на Advanced Options и настройте значение опции Fill With как Foreground. Это приведёт к созданию изображения черного цвета. нажмите OK, чтобы открыть окно с новой канвой.

Центральный круг

Img 72 85 2.jpg

Выберите в панели инструментов выделение эллиптической области. Удерживая клавишу Shift, нажмите клавишу мыши и перетащите её, получив выделенный круг в центре канвы. Если он оказался не точно в центре, переместите его мышью, удерживая Alt (вместе с Shift, если нужно). Курсор при этом должен измениться, превратившись в сочетание символа инструмента выделения области и перекрестья из стрелочек, обозначающего перемещение. Теперь щелкните на инструменте создания цветовых переходов (градиентов), чтобы активировать его. В диалоге Options выберите градиент Crown Molding. Перетащите «мышь», удерживая левую кнопку из правой верхней части картинки в левую нижнюю.

Металлическая поверхность

Img 72 85 3.jpg

Добавьте новый слой (Layer > New). В диалоге Layers кликните на имя слоя и введите “Ring Colour”. затем щелкнув (один или два раза) на цвет переднего плана в панели инструментов, активируйте диалог Change Foreground Color и наберите 009F00 в поле HTML (цвет темного зелёного леса), и закройте диалог кнопкой OK. Выделение круга должно быть еще активно, так что перетащите цвет переднего плана в это выделение. настройте режим слоя на Soft Light и прозрачность на 50%.

Растушёвка нового слоя

Img 72 85 4.jpg

Добавьте новый слой и назовите его “Emblem Colour”. Сожмите выделенную область на 10 пикселей (Select > Shrink) и сделайте растушёвку (Select > Feather) на 2.5 пикселя. Снова откройте диалог Change Foreground Color и введите в поле HTML A90707 (это число даст вам красивый глубокий оттенок красного) и закройте это окно. Перетащите цвет переднего плана в выделенную область.

эффект крашеного металла

Img 72 86 1.jpg

на этом этапе у вас уже есть простая металлическая эмблема. остаток статьи покажет вам, что можно сотворить на её основе. Мы начнём с создания эффекта крашенного металла. Добавьте новый прозрачный слой с названием “Brushed Metal”. откройте фильтр Hurl (Filters >Blur >Noise). Установите Random Seed равным 10, Randomization в 35% и Repeat равным 2. нажмите OK, чтобы применить фильтр к новому уровню. настройте в диалоге Layers режим слоя на Multiply и прозрачность на 50%.

вырезание

Img 72 86 2.jpg

Добавьте новый слой и назовите его “Inner Ring”. Сожмите выделение на 25 пикселей (Select > Shrink). нажмите D в панели инструментов, чтобы сбросить цвета в значения по умолчанию. закрасьте выделенную область чёрным цветом, перетащив цвет фона в выделенную область. Сожмите выделение еще на 4 пикселя. нажмите Ctrl+X, чтобы вырезать содержимое выделенной области из текущего слоя. В результате у вас получится тонкое чёрное кольцо.

Добавление маски

Img 72 86 3.jpg

Теперь откройте фильтр размывания по Гауссу (Filters >Blur >Gaussian Blur). Установите радиус размывания по вертикали и горизонтали равным 3 пикселя и примените к текущему уровню. Создайте из уровня выделенную область (Layer >Transparency >Alpha To Selection), а затем добавьте маску (Layer >Masks >Add Layer Mask) к слою с цветом эмблемы. В диалоге Add Layer Mask выбе- рите опцию Selection и включите галочку Invert Mask. После закрытия диалога будет создана маска с чёрным кольцом.

ваши инициалы

Img 72 86 4.jpg

щелкните на слой “Inner Ring” и инвертируйте его цвета (Layer >Colours Invert). задайте в качестве режима для уровня “Grain Extract”. Теперь выделение можно снять. В панели инструментов найдите ввод текста и активируйте его. В диалоге Tools Options выберите большой, толстый шрифт. я воспользовался Utopia Bold размером 150 пикселей. щелкните мышью на картинке, чтобы открыть диалог Text Editor. наберите букву «M» и закройте диалог. Вручную сместите в нужное место текстовый слой при помощи инструмента Move.

трёхмерная буква

Img 72 87 1.jpg

чтобы сделать белый блик и тёмную тень вокруг буквы, продублируйте текстовый слой и инвертируйте его цвета, сделав белым. назовите дубликат “White Outline”. Сместите слой Layer >Transform >Offset) на -1 пиксель по координатам X и Y. Продублируйте оригинальный слой еще раз, назовите дубль “Black Outline” и сместите на +1 пиксель по обоим направлениям. Поднимите оригинальный слой так, чтобы он был над белой и чёрной обводками.

Улучшение трёхмерного эффекта

Img 72 87 2.jpg

Примените размытие по Гауссу размеров в 2.5 пикселя к слою “White Outline”. расширьте его до границ изображения (Layer >Layer To Image Size), затем щелкните на оригинальный текстовый уровень и создайте выделение на его основе (Layer >Transparency >Alpha To Selection). Сделайте текущим “White Outline”, и удалите из него выбранную область (Ctrl+X). Снова создайте выделение по основному текстовому слою, переключитесь на уровень “Black Outline” и удалите из него выбранную область аналогичным способом. настройте для уровня с оригинальным текстом режим Overlay и прозрачность 66.7%.

Последний штрих.

Img 72 87 3.jpg

Сделайте еще одно выделение оригинального текстового уровня и задайте цвет переднего плана равным ACACAC. Кликните на слое “Emblem Color”, чтобы активировать его. Перетащите цвет переднего плана в выделенную область и снимите выделение при помощи Ctrl+Shift+A. Всё, мы закончили. При желании вы можете воспользоваться советами из правой врезки, чтобы улучшить мой вариант.

что МоЖет сДеЛАть GIMP с вАШиМ ЛоготиПоМ
  • используйте свет и тени. Эффект трёхмерности создаётся всего лишь добавлением бликов и теней. Для начала определитесь с направлением на источник освещения, а затем добавьте светлые кромки к тем краям, которые смотрят в его сторону и тёмные кромки с противоположной стороны.
  • используйте текстуры. ни одна поверхность не является абсолютно гладкой, даже стекло. Волокна дерева, крашеный металл и даже царапины могут быть воссозданы при помощи шумовых фильтров с небольшим размыванием движением.
  • Смешивайте. режимы смешивания слоёв позволяют слить белые блики и текстуры. Попробуйте использовать режим Overlay, чтобы сделать темнее, а Soft Light или Grain Merge для осветления.
  • блики на градиенте. Панель свойств градиента не выглядит очень богатой, заполнив градиентной заливкой круг, рамку или другую форму вы можете получить эффект блика. Поиграйте с градиентами, входящими в состав Gimp. Многие из них могут оказаться похожими на игру света.
  • Придавайте рельеф проще. Существует два фильтра для придания рельефа (Filters >Distorts >Emboss и Filters >Map >Bump Map). оба работают прекрасно, но придать рельеф тексту так просто, что лучше сделать это вручную. Продублировать, сместить, размыть и вырезать. Причём размывание и вырезание необязательны.
  • используйте маски. обведённый черный круг может выглядеть как односторонняя тень при помощи соответственно применённой маски уровня. Продублируйте, инвертируйте цвета и переверните (горизонтально или вертикально), и вы получите освещенную сторону как бонус.
ПоДсКАзКА
Смотрите своими глазами

При разработке эмблем бывает очень полезно внимательно посмотреть на настоящие вещи, вроде стеклянных кнопок и серебряных ложек. Посмотрите, как свет отражается от них. Есть простой секрет, позволяющий увидеть освещение, а не текстуру. Для этого нужно всего лишь немного расфокусировать взгляд и обратить внимание на цвета и тени, а не на форму предмета. А теперь попробуйте воспроизвести этот эффект в Gimp.

Персональные инструменты
купить
подписаться
Яндекс.Метрика