Журнал LinuxFormat - перейти на главную

LXF71:GIMP

Материал из Linuxformat
Перейти к: навигация, поиск
GIMP (Майкл Дж. Хэммел)

Содержание

Gimp Cоздание эффекта геля

Текст вовсе не обязан быть плоским. Майкл Дж. Хэммел (Michael J Hammel) показывает, как использовать слои, фильтры, кривые и размытие в Gimp, чтобы превратить обычную картинку в нечто особенное. Раз уж это сработало для Apple...

Эффект геля – это просто сочетание мягких теней, округлых поверхностей и белых бликов. Представьте себе воду в стеклянной трубке – и вы поймёте, что такое гелевый эффект. В течение последних нескольких лет он активно продвигается Apple, поскольку созданный ими интерфейс Mac OS X под названием Aqua – это не более чем множество гелевых эффектов в синих тонах.

Сам по себе эффект очень прост для воспроизведения. В этой статье мы применим его к тексту, но ничего не мешает использовать его же для границ, кнопок, и вообще для практически любой поверхности, которой можно придать объёмность при помощи фильтра Emboss.

Не ожидайте, что вы получите рисунок в точности совпадающий с моим. Из-за различий в настройках кривых (Curves), эффекте Light Effect и, возможно, даже фильтре Bump Map вы получите что-то уникальное. Вы должны вынести из этого учебника основной процесс придания рельефа, освещения и использования режимов смешения.

В данном примере мы будем работать с маленькой картинкой, размеры которой устанавливаются по умолчанию. Это прекрасно работает, если рисунок предназначен для Web или рабочего стола (для него она, пожалуй, даже великовата). Но для печати такое изображение не годится. Если вам нужна версия для печати, убедитесь, что ваше изображение имеет соответствующее разрешение, увеличив его и размер текста в нужное число раз (Image > Scale). оптимальное разрешение зависит от того, как именно вы собираетесь печатать картинку, но 300dpi, как правило, бывает достаточно.

Выбор цвета

Img 71 81 1.jpg

Мы начинаем с пустого изображения размеров по умолчанию (420x300 пикселей). Нажмите D, чтобы сбросить цвета переднего и заднего планов (Foreground/Background). щелкните на квадратике с цветом переднего плана (Foreground), чтобы изменить его. Возможно, потребуется двойной щелчок. В диалоге Change Foreground Colour установите уровень красного = 0, уровень зелёного = 51 и уровень синего = 222. так вы получите очень красивый тёмно-синий тон.

Ввод текста

Img 71 81 2.jpg

щелкните на инструменте Text в панели инструментов, чтобы активировать его. В окне Text Options выберите шрифт Serif и размер 180. Поэкспериментируйте, если хотите, со шрифтами без засечек, но учтите, что округлые формы более старомодных шрифтов лучше продемонстрируют вам красоту эффекта геля. Цвет текста в окне Text Options должен совпадать с текущим цветом. щелкните на изображении и введите слово GEL в окне редактирования, после чего закройте его. Используйте инструмент Move, чтобы переместить текст в центр окна. Задайте размер слоя таким образом, чтобы он соответствовал размеру текста (Layer > Layer To Image Size).

Выбор текста

Img 71 81 3.jpg

Создайте выделение вокруг текста, используя инструмент Alpha To Selection (Layer > Transparency > Alpha To Selection). Уменьшите его на пару пикселей (Select > Shrink), а затем – размойте на два пикселя (Select > Feather).

Создание нового уровня

Img 71 81 4.jpg

Установите текущий цвет переднего плана: красный/зелёный/синий = 31/82/255, это слегка более яркий тон того же цвета, которым написан текст. Создайте новый слой (Layer > New Layer или кнопка New Layer в диалоге Layers) и измените его имя на Bump Map (щелкните на имя слоя и введите новое имя). Активировав новый слой, заполните его новым текущим цветом, перетащив иконку Foreground на выбранную область. отмените выбор (Select > None), продублируйте слой (Layer > Duplicate) и размойте дубликат по Гауссу на 10 пикселей (Filters > Blur > Gaussian Blur). Назовите этот слой Blur.

Представление карты выступов

Img 71 82 1.jpg

щелкните на слое Bump Map, чтобы активировать его. откройте фильтр Bump Map (Filters > Map > Bump Map). Установите параметр Azimuth равным 105, Elevation – 5.75 и Depth – 10. Задайте Map Type равным Linear и установите флажок Compensate For Darkening. осталось нажать кнопку OK, чтобы применить фильтр, а затем установить Blend Mode слоя Bump Map в значение Addition.

Осветление уровня

Img 71 82 2.jpg

Слой Bump Map нуждается в небольшой цветокоррекции. откройте диалог Curves (Layer > Colours > Curves) и измените кривую примерно так, как показано на рисунке. В результате мы получим более светлое изображение (чтобы увидеть это, отключите видимость слоя Blur, кликнув на пиктограмму «глаз» рядом с ним).

Выбор источника света

Img 71 82 3.jpg

Слой Bump Map нуждается в еще одном фильтре. откройте фильтр Lighting Effects (Filters > Light Effects > Lighting Effects). В этом окне много вкладок, но нас будут интересовать только две, в остальных нас устроят значения по умолчанию. На вкладке Options щелкните «мышью» в верхней левой части картинки предварительного просмотра. Синяя линия и точка показывают направление света и следуют за курсором мыши. Вы можете перетаскивать источник света куда вам угодно, но он может двигаться скачками из-за того, что не успевает плавно перемещаться со скоростью курсора, так что лучше перетаскивать его медленно. Правильное расположение синей точки в фильтре Lighting Effects – это самое сложное задание в этом материале. Если вы потеряли источник света, отключите его (на вкладке Light) и создайте новый.

Изменение интенсивности света

Img 71 82 4.jpg

На вкладке Light измените Type на Directional, установите интенсивность равной 1.45. Изменение интенсивности оказывает большое влияние на общий вид, примерно такое же, какое вы видели при изменении кривых Curves. Если картинка выглядит неправильно, вернитесь и попробуйте другие значения для одного, другого или обоих эффектов сразу.

Смещение и размытие

Img 71 83 1.jpg

После применения эффекта Lighting сдвиньте слой Bump Map (Layer > Transform > Offset). Установите значения X и Y равными «-2» пикселя. Затем откройте фильтр Gaussian Blur и установите Blur Radius для обоих полей Horizontal и Vertical значение «5» пикселей.

Форматирование слоя Blur

Img 71 83 2.jpg

Если вы выключали видимость слоя Blur, то теперь самое время его включить. Активируйте этот слой, щелкнув на его имени в диалоге Layers, затем продублируйте его (по умолчанию, дубль будет назван Blur Copy). Сдвиньте его (Offset) на два пикселя по вертикали и горизонтали. Затем вернитесь к слою Blur и сдвиньте его на два пикселя в противоположном направлении (X и Y = «-2» ).

Отбросим тень

Img 71 83 3.jpg

Измените Blend Mode слоя Blur на Addition. Для слоя Blur Copy сделайте Blend Mode равным Screen. Активируйте слой GEL и добавьте ему тень (Script-Fu > Shadows > Drop Shadow) смещением в два пикселя и размытием в три пикселя. Вот и всё!

мАГия КнопКи

Это простой эффект, но при правильном применении он кажется очень сложным и таинственным. Просто посмотрите на Mac OS X и вы увидите, как широко он там применяется. Люди платят большие деньги Apple за хороший дизайн и запоминающийся вид их приложений. теперь вы можете добиться почти того же самого с помощью Gimp.

подсКАЗКА
Методы работы с текстом
  • Правка. Текстовые уровни в Gimp можно редактировать после применения эффектов, но при этом эффекты будут потеряны. Поэтому стоит продумать содержание текста с самого начала, и вам не придётся повторять все эффекты после его изменения.
  • Хорошего понемножку. Gimp может сделать с параграфом текста не слишком много операций, так как у него нет типографских функций. Но он прекрасно работает с короткими фразами. Я думаю, что в любом случае вам редко придётся применять эффекты к длинным предложениям.
  • Добавление объёма. Фильтры Bump Map и Emboss творят чудеса со слегка размытым текстом, по сравнению с результатами их применения к тексту без изменений.
  • Больше объёма. Дублирование текстового уровня, его размытие, лёгкое смещение и модификация Blend Mode заметно улучшает 3D-вид текста с фильтрами Bump Map или Emboss.
  • Проверьте ваши шрифты. Многие бесплатные шрифты не очень тщательно проработаны и, поэтому, Gimp помещает их за границу уровня. Для этих шрифтов требуется добавить дополнительное пространство между текстом и границей изображения перед применением эффектов. Решение очень простое: Add a shadow Layer > Layer To Image Size. Всё, проблема решена.
Персональные инструменты
купить
подписаться
Яндекс.Метрика