Журнал LinuxFormat - перейти на главную

LXF77:Realsoft 3D

Материал из Linuxformat
Перейти к: навигация, поиск
3D-моделирование

Содержание

Realsoft 3D Первые шаги

Следуйте за Ником Вейтчем: нарисуем несложный 3D-объект.
Наша цель

LXF74 realsoft01.jpg

На заре развития 3D-приложений инструменты были попроще теперешних – в основном потому, что они не дотягивали и до половины современной мощности. за прошедшие годы различные приложения и фирмы упражнялись во множестве методов, чтобы достичь лучших результатов в 3D. В итоге, не считая функций, все 3D приложения весьма различны в использовании. Я уверен, что Realsoft 3D (http://www.realsoft.com/, доступна пробная 60-ти дневная версия) не покажется вам трудным в освоении, однако он, возможно, не похож на программу, к которой вы привыкли, поэтому этот краткий учебник призван вам помочь. также не помешает взглянуть на превосходное HTML- руководство, включенное в состав пакета; вы можете открыть его в любой момент, нажав последовательно пункты главного меню Help > User Manual (Подсказка > Руководство пользователя).

Используем Nurbs

Шаг 1

Для создания разных объектов существуют и разные инструменты. Бокал мы собираемся создать при помощи Nurbs. Это смешное слово означает «Неравномерный рациональный Би-Сплайн» (Non-Uniform, Rational B-Spline) – это вариант математического представления 3D-объектов. Для начала нам нужна прямая вертикальная линия. Щелкните на инструменте Curve (кривая) на панели инструментов, а затем щелкните внизу посередине главного окна. тут будет начало прямой. Щелкните вновь на точке строго над начальной для создания прямой линии – согласно Эвклиду, этого достаточно, поэтому вызовите контекстное меню правой кнопкой мыши и выберите пункт Accept (Принять).

Профиль

Шаг 2

Итак, мы создали ось, вокруг которой будем строить бокал. теперь создадим профиль бокала. Снова выберите Curve (кривую) и нарисуйте профиль, щелкая там, где нужна узловая точка (проще будет начать снизу и продвигаться вверх). Не забудьте создать подставку, а также внутреннюю емкость. Замкнутую форму создавать не обязательно, но прежде чем щелкнуть правой кнопкой и нажать на Accept (Принять), удостоверьтесь, что контур вернулся к оси.

Вращение

Шаг 3

теперь у нас есть две линии: прямая и кривая, которую мы будем вращать вокруг прямой. Щелкните слева в древе объектов, чтобы выбрать ось, которую вы нарисовали. затем, удерживая Shift, выберите профиль. многие операции моделирования используют один или более объектов – теперь вы знаете, как это делается! Далее выберите кнопку rotate (вращение) около правого края панели инструментов. Вы увидите проволочный каркас, получившийся из профиля. Щелкните на кнопке Accept (Принять) на панели инструментов для сохранения модели.

Правка узлов

Шаг 4

Одна из замечательных возможностей Realsoft 3D – редактирование объекта без отмены проделанной работы, если вы сочли, что ваш бокал выглядит не совсем хорошо. Слева на панели объектов в древе теперь появился сетчатый объект (Mesh object). Щелкните на ‘+’ рядом с ним, и увидите: две нарисованные вами кривые входят в него как дочерние объекты. Щелкните на объекте-профиле и выберите пункт edit (Редактировать) на панели инструментов – узлы объекта окрасятся в красный цвет. Щелкайте на узлах, перемещайте их – весь объект будет менять свою форму. Когда закончите, выберите Accept ('Принять).

Материалы

Шаг 5

Выберем материал для объекта. Сделаем наш бокал... из чего бы? Я думаю, из стекла. Realsoft 3D предоставляет изобилие готовых материалов, в том числе и стекло, поэтому на этом этапе мы не станем изобретать собственный. Удостоверьтесь, что весь сетчатый объект выбран в панели объектов, затем щелкните на иконке с бело-голубой шахматкой на верху этой панели. После этого выведется список предопределенных материалов. Найдите glass (стекло) и просто перенесите его на объект в главном окне.

Подсветка

Шаг 6

Чтобы показать наш материал в выгодном свете, потребуется... свет. Выберите Light Sources (источники света) на панели инструментов, для доступа к инструментам освещения. Выберите инструмент spotlight (софит), затем щелкните и нарисуйте линию, показывающую направление, а также внешний и внутренний конусы луча. Постарайтесь сфокусировать их на бокале! Возможно, вам захочется добавить фоновую подсветку сбоку, иначе сцена будет темноватой. Не забывайте щелкать на кнопке Accept (Принять) после создания каждого элемента освещения. Возможно, вы также захотите выбрать другую позицию камеры, справа в основном окне, чтобы убедиться в верном расположении источников света.

Трансформация

Шаг 7

Теперь поставим бокал на что-нибудь. Щелкните на вкладке Analitical (Аналитические) и выберите cube (куб). Перенесите его под бокал – это будет столик.

Переключитесь на вид сверху (иконка с камерой, направленной вниз, справа в основном окне). затем щелкните на пункте Transformation ('Преобразование), для перемещения и установки размера созданных объектов. Выберите кнопку масштабирования (scale button) и начертите небольшой прямоугольник. теперь подвигайте мышку в главном окне – размеры куба будут меняться. Используя комбинацию этих инструментов и положения камеры, вы сможете создать основание, где будет стоять бокал.

Снимите фото

Шаг 8

В конце этого краткого урока я покажу, как получить снимок готового изображения. Для этого надо будет установить камеру и использовать режим рендеринга. Выберите нужный ракурс в окне и щелкните на вкладке Creation (Создание). Щелкните на пункте Camera (камера), затем Accept (Принять), чтобы создать камеру текущего вида. Для вызова диалога render (Рендеринг), выберите в меню File > render (Файл > Отобразить) По умолчанию создается BMP-файл Microsoft Windows, который открывается в большинстве Linux-приложений. Выберите желаемое разрешение и нажмите кнопку render. Подождите около минуты – и готово. Добро пожаловать в мир 3D – ура! LXF

ИНТЕРФЕЙС REALSOFT 3D

LXF77 realsoft10.jpg

Персональные инструменты
купить
подписаться
Яндекс.Метрика