Журнал LinuxFormat - перейти на главную

LXF76:Первые шаги: Impress

Материал из Linuxformat
Перейти к: навигация, поиск

Содержание

OpenOffice.org Презентации

Энди Чэннел (Andy Channelle), трепеща, выходит на сцену. Между ним и публикой находится только его ноутбук. К счастью, на ноутбуке установлен OpenOffice.org Impress…

Многим из вас хотя бы раз в жизни приходилось слышать просьбу «сделать презентацию». После этого вы, наверное, чувствовали легкую тошноту, озабоченность, и в голову приходили нехорошие слова. Я не могу избавить вас от этого, но знайте, что сообщество разработчиков открытого ПО подарило всем инструмент, с помощью которого в нужный момент вы сможете привлечь внимание к большому экрану, а не собирать ожидающие взгляды на себе.

Этим инструментом является, конечно, великолепный мастер презентаций OpenOffice.org Impress. Наиболее важной особенностью этой программы является возможность сохранять файлы в формате Microsoft PowerPoint. Мы не рекомендуем использовать проприетарные форматы вместо открытых, и в данном случае советуем вам сперва сохранять работу в «родном» формате OOo, а потом экспортировать презентацию в PPT-файл.

Это нужно для того, чтобы уменьшить тревогу перед выступлением. Если вы доверяете свои материалы чужому оборудованию, есть шанс, что на нем не будет установлен OOo; а поскольку PowerPoint не особо жалует отличные от PPT форматы, вы должны располагать максимальным количеством запасных вариантов. Вы даже можете напечатать свою презентацию на прозрачных слайдах и выступить в ретро-стиле 1984 года.

При первом запуске Impress вы увидите мастер, который поможет вам задать параметры презентации. Вам предлагается ограниченный выбор тем оформления, способов вывода (бумага, экран и др.) и эффектов перехода между кадрами.

В этой обучающей статье мы приступим к работе с пустой презентацией и вставим в нее изображения и текст, а также настроим анимацию.

Сперва добавим фоновое изображение, которое будет служить подложкой для каждого кадра. В состав Impress входит коллекция текстур, которыми можно покрыть фон кадра, как плиткой. Эта опция доступна в меню Формат > Страница > Фон (Format > Page > Background…), где следует выбрать из списка Bitmap. Это хорошо, но совершенно не годится, если вам нужно разместить в качестве фона или колонтитула только один экземпляр изображения — например, логотип компании. В таком случае есть смысл создать мастер-страницу, которую в дальнейшем можно применить ко всем кадрам презентации. Преимущество этого метода в том, что при изменении мастер-страницы автоматически будут обновляться и кадры презентации, для которых задан этот шаблон.

Мастерское выступление

Использование мастер-страниц создает более целостное восприятие презентации у зрителей, а для вас означает меньшее время на создание этой презентации. На самом деле, это похоже на принцип верстки периодических изданий. Идея состоит в том, что в каждом слайде присутствуют повторяющиеся элементы — стандартные размеры шрифтов, фоновые изображения, верхние и нижние колонтитулы. Тот же способ помогает журналам быть узнаваемыми на любой странице. В Impress эти настройки прячутся в меню Вид > Фон > Мастер слайдов (View > Master > Slide Master). Рассмотрим их подробнее.

Часть 1. Создание мастер-страниц

Заводим мотор

Главное окно программы — то место, где делается основная часть работы. Посередине расположена рабочая область, по пропорциям соответствующая размерам типичного монитора. Слева к ней примыкает навигатор слайдов (пока в нем только один пустой слайд), а справа — панель задач. При запуске программы в панели задач отображается список доступных макетов, которые можно перетащить мышью на рабочую область, создав тем самым стандартные рамки для изображений и текста. В верхней части окна имеются привычные пункты меню и панель инструментов, а также переключатель режимов просмотра презентации. Большую часть времени мы будем находиться в стандартном режиме рисования, но также не будем забывать и про режим слайдов, который позволяет легко пересортировать кадры презентации между собой.

Создаем мастер-страницу

Вместо того, чтобы редактировать уже существующий шаблон, щелкните по самой левой кнопке на плавающей панели Режим фона, после чего будет сделана копия существующей стандартной мастер-страницы. Вы увидите все необходимые элементы для оформления типичной презентации. Переименуйте мастер-страницу (третья кнопка на плавающей панели). Перед вами находится набор шрифтов для оформления элементов различного уровня, специальные рамки для вставки номера слайда, даты/времени и нижнего колонтитула. Текст, введенный в область колонтитула появится на каждом слайде, а номер, дату и информацию о слайде можно задать через меню Вставить > Номер страницы (Insert > Page Number), в котором имеются дополнительные настройки.

Добавляем изображение

Определившись со шрифтами и задав колонтитул, вы готовы разместить фоновое изображение. Вызов диалога вставки в Impress точно такой же, как и в Writer (да и вообще во всем OOo). Просто перейдите в меню Вставить > Изображение > Из файла (Insert > Picture > From File) и найдите нужный файл в появившемся диалоге. Добавленную иллюстрацию можно масштабировать, потянув за одну из восьми зеленых опорных точек (помните, что для пропорционального масштабирования следует удерживать клавишу [Shift]), а также редактировать различными способами, описанными в предыдущей статье. Так как это фоновое изображение, мы установили степень прозрачности равной 70 % и переместили его на задний план, щелкнув по картинке правой кнопкой мыши и выбрав Расположить > На задний план (Alignment > Send to Back).

Используем вторую мастер-страницу

На мастер можно поместить любой объект, включая текст, графику и любые другие данные, с которыми работает OOo. Также имеется возможность работы с двумя и более мастерами в рамках одной презентации. Это может пригодиться, если вам нужно по-разному оформить различные разделы презентации, или выделить слайды с разным типом информации — например, цитаты, графики или маркированные списки.

Настроив все мастер-страницы, вы можете закрыть панель Режим фона, нажав на ней кнопку Close Master View. Так вы вернетесь в режим главного окна презентации. Так же, как и в Writer, здесь вы можете сохранить презентацию в качестве шаблона и воспользоваться ею позднее (Файл > Сохранить > Шаблон презентации OpenDocument или File > Save > OpenOffice Presentation Template).

Создаем серию слайдов

Чтобы использовать мастер-страницу, для начала добавьте новый слайд через меню Вставить > Слайд (Insert > Slide) или щелкнете правой кнопкой мыши на навигаторе слайдов и выберите Новый слайд (New Slide). Убедившись, что слайд выделен, щелкнете на нужной мастер-странице и посмотрите, как мгновенно изменится содержимое кадра. Щелкнув правой кнопкой мыши по мастер-странице, вы можете применить ее ко всем слайдам или только к выделенным. Чтобы выделить несколько слайдов, удерживайте клавишу [Shift] и щелкайте по нужным слайдам. Так вы выделите непрерывный диапазон, а удерживая [Ctrl] вместо [Shift] — сможете выделить любые несколько слайдов.

Простые исправления

Идея мастер-страниц очень проста: они экономят ваше время. Так что если вы старательно подготовили с помощью мастер-страниц 50 слайдов с колонтитулом «Возвращаем прошлое к жизни», а начальник решил изменить фразу на «Возвращаем к жизни прошлое», то вам всего лишь нужно исправить мастер-страницу, а не редактировать каждый из 50 слайдов. Разобравшись с этим, вы сможете приступить собственно к сортировке слайдов — превращение презентации в цельный доклад всегда приносит удовольствие!

Часть 2. Добавляем данные и анимацию

Помните о простоте

Простота идет на пользу презентации. Также, у вас будет гораздо меньше проблем с отображением файла при использовании PowerPoint. Имейте в виду следующие советы:

  • Маркированные списки и удачные рисунки работают лучше, чем огромные текстовые блоки.
  • Используйте немного эффектов из соображений стиля и разумной экономии.
  • Выберите 2 читабельных шрифта и ограничьтесь этим.
  • Избегайте фиксированных задержек между слайдами – всегда лучше контролировать этот момент самому.
  • Пользуйтесь цветом с умом. Светлый текст на темном фоне хорошо отображается проектором.
  • Превратите свои шпаргалки в заголовки слайдов. Так вы не собьетесь с плавного рассказа.
  • Не прячьте суть под слоями оберточной бумаги.

У нас теперь есть чистый холст, на котором можно создать блестящую презентацию. Сам факт наличия у вас презентации ничего блестящего не несет, а вот умение четко и кратко соединить тезисы и аргументы — да.

Программы для подготовки презентаций, такие как Impress, подвергаются активной критике за то, что они сбивают пользователей с толку и отвлекают их от основной темы доклада. Такое поведение я лично не одобряю.

Презентация состоит из ряда слайдов, которые сменяют друг друга последовательно, либо через определенные промежутки времени, либо (что гораздо чаще) после щелчка мыши или нажатия клавиши на клавиатуре. Каждый слайд может содержать текст, графику, звуки, анимацию и даже ссылки на web-страницы, а также, благодаря модульной структуре OOo, элементы текстовых документов и электронных таблиц. Мы оформим пару слайдов, добавим анимацию к объектам внутри слайда, а затем настроим простые эффекты смены слайдов, получив в итоге красивую презентацию без лишних усилий.

Не забывайте, что у нас для работы есть пара мастер-страниц, предоставляющих фон и некоторые общие элементы. Пора добавить и кое-какую информацию. Начнем с заголовка, который обычно помещают на первый слайд. Итак, нам нужен текстовый блок — найдите в нижней части окна значок с большой буквой Т, щелкните по нему и нарисуйте прямоугольник. Получившийся блок будет иметь ширину нарисованного прямоугольника, а высоту — равной кеглю текущего шрифта. Теперь вы можете набирать текст.

Так же, как и в настольных издательских системах, здесь есть линейки, располагающиеся по левую сторону слайда и сверху. С их помощью вы можете перетащить на слайд направляющие. Если вы их не видите, включите отображение направляющих через меню Вид > Направляющие линии > Показать направляющие (View > Guides > Display Guides). Также есть возможность использовать бледную сетку (Вид > Сетка > Показать сетку или View > Grid > Display Grid), помогающую более уверенно размещать объекты на слайде. Если все это кажется вам сложным и ненужным, будьте проще и используйте готовые макеты Impress, которые можно найти в одноименной панели справа.

Перед внесением данных не забудьте выделить сначала слайд или группу слайдов и, щелкнув по выбранному макету правой кнопкой мыши, выбрать Применить к выделенным слайдам. Также можно сделать по другому: щелкнуть правой кнопкой мыши по макету и выбрать Вставить слайд. Новый слайд будет добавлен непосредственно за тем, который был выделен до вставки.

Существует множество макетов презентаций, включая простые листы, иллюстрации, объекты и другое. Если вам ничего так и не подошло, вы можете подправить свойства объектов уже после применения макета. Исправленный слайд можно клонировать или сохранить в качестве шаблона для последующего использования.

Мы начинаем с простого макета: наверху заголовок, под ним - резюме презентации. Для этого идеально подходит макет Заголовок (второй по счету). Применив этот макет, мы можем выделить любой из появившихся текстовых блоков и набирать в него текст. Внешний вид текста соответствует стилям, определенным нами ранее на мастер-странице.

Наш следующий слайд будет также содержать заголовок, но под ним будет находиться текст, описывающий структуру самой презентации (представить слушателям план доклада считается хорошим тоном,- прим.ред.). Для этого подходит третий макет: «Заголовок, текст», который имеет основной блок с уже сделанной многоуровневой разметкой.

После добавления текста вы можете выделить его, щелкнуть по нему правой кнопкой мыши и выбрать в списке Текст…, после чего появится окно с настройками параметров текста. Мы не рекомендуем пользоваться этой возможностью. Эффекты включают в себя ненавистное всеми мигание, прокрутку. Вы можете настроить их скорость и длительность.

Воодушевите публику

Гораздо эффективнее выглядит анимация текстовых или визуальных элементов презентации. Опять же, здесь легко переборщить, однако умеренное использование эффектов только улучшит презентацию. На нашем слайде с описанием структуры имеется пять строк, и требуется, чтобы они появлялись одновременно при щелчке мыши. Обратитесь к панели в правой части экрана и выберите вкладку Эффекты. Теперь выделите первую строку текста — важно выделить всю строку, а не просто поместить в нее курсор. В последнем случае за активный анимируемый элемент будет принят весь текстовой блок, а не одна строка.

Теперь нажмите кнопку Добавить и выберите понравившийся эффект анимации. Удобная функция предварительного просмотра сразу же показывает, как будет выглядеть слайд с этим эффектом, так что вы можете нажать ОК или выбрать другой эффект. Нам сейчас нужен самый простой вариант — сделать так, чтобы при щелчке мышью эта строка появлялась на экране. Но вы видите, сколько здесь представлено способов выделения текста, и наоборот — отвлечения от него внимания, интересных превращений и различных настроек. Освоившись с анимацией, вы можете смело экспериментировать с ней, но помните о простоте, так что несмотря на богатые эффекты, предлагаемые Impress, используйте не все подряд, а только то, что действительно необходимо для придания презентации динамики.

Выделяйте и редактируйте

Когда к каждой строке будет применен эффект, они появятся в специальном списке на панели справа. Вы можете в любое время отредактировать любой эффект, выделив его и щелкнув по кнопке Изменить. Более серьезная правка, включающая добавление звука и настройку побуквенного появления текста, доступна по двойному щелчку на элементе в нижней части панели.

Проверить результат можно, выделив эффект из списка и нажав кнопку Воспроизвести (можно проиграть сразу несколько эффектов, выделив их с помощью клавиши [Shift]) или при помощи кнопки Демонстрация — тогда будут показаны все эффекты текущего слайда.

Теперь следует настроить варианты смены слайдов. По умолчанию, слайды сменяются без эффектов, и этого для многих случаев вполне достаточно. Тем не менее, несколько мягких, не раздражающих эффектов помогут придать вашей презентации дополнительный лоск.

Смена слайдов настраивается при помощи одноименной вкладки в панели задач. Важно помнить, что применяемый к слайду эффект влияет на появление его самого, а не следующего, так что едва ли есть смысл применять какой-либо эффект к самому первому кадру презентации. Поэтому мы выделяем второй слайд и начинаем экспериментировать с доступными эффектами смены. Если вам так больше нравится, выделите один эффект и примените его ко всей презентации, нажав кнопку «Применить ко всем слайдам». Здесь также есть возможность посмотреть эффект перед его применением — нажмите кнопку Воспроизвести. Точно так же, как и в случае с внутрислайдовыми эффектами, не увлекайтесь, а то публика будет раздражена.

Выберите одни или два эффекта, которые подчеркивают ход вашего рассказа, и остановитесь. Можно добавить звук, но только если он чем-то дополняет презентацию, в остальных случаях от него следует отказаться. Impress позволяет проигрывать звук однократно или до тех пор, пока его не остановит следующий звук. Последний вариант явно неудачен.

Наконец, можно настроить автоматическую смену кадра через определенный промежуток времени. На панели имеется переключатель Автоматически после и поле со значением (в секундах). В этом случае переход к следующему слайду осуществляется либо щелчком мыши, либо клавишами [Пробел] или [Enter].

Готовую презентацию можно сохранить в стандартном формате OpenDocument (расширение odp) или экспортировать в PPT-файл для последующего открытия в PowerPoint. Impress также умеет экспортировать в формат HTML для сетевой публикации, а также в PDF, JPEG, Macromedia Flash и другие графические (нередактируемые) форматы.

Несмотря на то, что обычно проблем с презентациями Impress, открытыми в PowerPoint, не возникает, всегда лучше подстраховаться и проверить (и при необходимости подправить) все перед тем, как вы предстанете перед публикой.

Персональные инструменты
купить
подписаться
Яндекс.Метрика