Журнал LinuxFormat - перейти на главную

LXF154:School1

Материал из Linuxformat
Перейти к: навигация, поиск

Школа LXF =Обмен опытом и передовые идеи по использованию свободного ПО в образовании LibreCad на уроках черчения=

Анна Трефилова и Светлана Демас рассматривают проект, имеющий все шансы понравиться школьникам – особенно тем, кто чертит как курица лапой...

Наши эксперты

Анна Трефилова Кандидат педагогических наук, до­цент кафедры ИТ­МОИ Глазовского государственного пединстута. Увле­кается компьютерным моделирова­нием и вопросами перехода на свободное ПО в образовательном процессе.

LibreCad – довольно молодой проект, однако весьма перспективный для изучения основ работы в САПР (системах автоматизированного проектирования) школьниками. От­вет на вопрос «А нужно ли изучать такие сложные системы в школе?» очевиден: современное образование уже на ранних стадиях развития личности призвано помочь ребенку определиться в своих интересах, наклонностях и способностях. Автоматизация работ в самых разных видах деятельности человека требует от выпускника школы свободного владения компьютером как рабочим инструментом. Необходимость автоматизации процесса построения технических чертежей достаточно обоснована и в ли­тературе, и самой практикой. CAD­системы, как один из видов САПР, предполагают наличие у пользователя компетенций, свя­занных с процессом построения чертежа и формируемых на уро­ах черчения. Эти компетенции также необходимы будущему инженеру любой отрасли. Итак, именно в аспекте изучения черчения наиболее целесообразно осваивать CAD­системы.

Наши эксперты

Светлана Демус Учитель изобра­зительного искус­ства и черчения I категории, руководитель районно­го методического объединения учи­телей ИЗО и чер чения, победитель районного конкур­са «Учитель года 2011». Любит компьютеры и шах­маты.

LibreCad –приложение с открытым исходным кодом, распро­страняемое на условиях лицензии GPL. Несмотря на молодость проекта, его включили в пакеты ПСПО: например, он поумолчанию входит в Edumandriva 2011. Но здесь имеются и минусы. Один из них – отсутствие, на данный момент, документации для этого продукта. Тем не менее, освоить LibreCad можно: эта систе­ма построена на базе Qcad, для которой документации достаточно. Конечно, в работе с LibreCad есть свои особенности, но все же это настоящая CAD­система, созданная согласно общим правилам.

Содержание

Тонкости работы в CAD­системах

(thumbnail)
Так выглядит LibreCad.
(thumbnail)
Дополнительные элементы панели инструментов.

Школьникам следует разъяснить, что CAD [англ. Computer Aided Design] – это программы для компьютерного дизайна или, други­ми словами, разработки новых технических и архитектурных объ­ ектов. В связи с этим чертеж в CAD­приложении должен строиться в реальных размерах, то есть в масштабе 1:1. Здесь есть определенное преимущество – пользователю уже не нужно вычислять масштаб и продумывать, в каких пропорциях чертеж спо­собен полностью разместиться на данном формате. Масштаб указывается при печати чертежа; сам файл чертежа при этом не изменится и сохранит реальные размеры. Для рассматривания разных частей большого чертежа в CAD предусмотрено так называемое панорамирование – «передвижение» по чертежу.

Важной особенностью работы в CAD является возможность и, вообще говоря, необходимость использования большого коли­ чества осевых и других вспомогательных линий. Цвет таких ли­ ний выбирается по соображениям личного удобства. Можно даже строить их в отдельном слое, а на готовом варианте чертежа сде­ лать этот слой невидимым или удалить. Начинающие пользователи CAD часто стараются построить чистовой вариант чертежа сразу. Это, как показывает опыт, значи­ тельно увеличивает временные затраты. Да и вычисления в таком случае придется производить в гораздо больших объемах.

Как уже упоминалось, чертеж в CAD строится послойно. Слои можно образно представить себе как стопку прозрачных пленок, каждая из которых содержит определенные детали чертежа, на­ зываемые в CAD примитивами. Пленка или слой может переме­ щаться в стопке. Ее можно заморозить (заблокировать), сделать невидимой или удалить совсем. Такой подход еще больше сокра­ щает время работы над чертежом и позволяет использовать гото­ вые части чертежа в других разработках.

Ярким примером может служить оформление формата A4, то есть построение рамки для углового штампа чертежа. Его можно сделать один раз в отдельном слое, сохранить в файл и постоянно пользовать­ ся, достраивая чертеж путем добавления новых слоев.

Как уже упоминалось, чертеж в CAD строится послойно. Слои можно образно представить себе как стопку прозрачных пленок, каждая из которых содержит определенные детали чертежа, называемые в CAD примитивами. Пленка или слой может перемещаться в стопке. Ее можно заморозить (заблокировать), сделать невидимой или удалить совсем. Такой подход еще больше сокращает время работы над чертежом и позволяет использовать готовые части чертежа в других разработках.

Ярким примером может служить оформление формата A4, то есть построение рамки для углового штампа чертежа. Его можно сделать один раз в отдельном слое, сохранить в файл и постоянно пользоваться, достраивая чертеж путем добавления новых слоев.

И последнее, о чем обязательно следует упомянуть – это стро­ка состояния, которая расположена в нижней части окна програм­мы. В строке состояния программа информирует пользователя о том, какое действие требуется от него на следующем этапе. Особенно это важно, когда операция многоэтапная. В LibreCad рядом со строкой состояния находится также командная строка, пользоваться которой тоже имеет смысл научиться. Всегда про­ще задать точные координаты в виде чисел, чем пытаться попасть в нужное место мышью. Хотя для этого тоже есть помощь – при­вязка к узлам сетки.

Тонкости CAD обусловлены целью этих приложений – создание точных чертежей, пригодных для изготовления по ним реальных деталей. Цель требует от пользователя скрупулезности, точности и систематичности. Нельзя получить качественный чертеж, если неаккуратно подойти к работе. Такой подход к построению чертежа формируется на уроках черчения. Очень важно, на наш взгляд, на начальном этапе школьникам научиться точно и аккуратно строить чертеж карандашом на бумаге. В процессе построения чертежей учащиеся запоминают основные требования к оформлению чертежа, усваивают основные нормы, касающиеся наименования, начертания, толщины линий и их основных назначений. Кроме того, формируется аккуратность, которая просто необходима для успешной работы в CAD.

Важные умения вырабатываются в процессе построения чертежей разных видов по данному наглядному изображению детали. В этом случае ученик должен помнить, что на видах деталь должна иметь все подробности, включая оформление невидимых линий. Без этого изготовить по чертежу деталь не получится. А ведь чертеж в CAD в конечном итоге строится именно для изготовления по нему детали на станке с ЧПУ.

Нужно понимать, что целью изучения приложений CAD в школе не является их профессиональное освоение. Важно дать обучающимся общее представление о таких системах и позволить им проверить свои возможности в их освоении. Хорошо было бы стимулировать интерес детей путем организации конкурсов на лучший чертеж.

Знакомимся с LibreCad

При первом запуске LibreCad следует установить русский язык интерфейса и команд (выбрать Russian в двух полях в первом окне запуска), а также определиться с единицами измерения по умолчанию. Для работы в соответствии с ГОСТ следует оставить миллиметры, то есть в строке Default Unit оставить Millimeter. Если же программа уже запускалась, а русский язык не был выбран, то в главном меню нужно найти пункт Edit, затем выбрать Application Preferences. В первой вкладке в разделе Language в обеих строках выбрать язык Russian.

Чтобы настройки вступили в силу, потребуется перезапустить программу. Дальше работа пойдет в русскоязычном интерфейсе.

(thumbnail)
Создаем вспомогательный слой.
(thumbnail)
Так можно постро­ить горизонталь­ную или вертикальную линии, прохо­дящие через заданную точку.

Окно программы состоит из меню, панели инструментов, панели работы со слоями, рабочего поля чертежа, на котором размещен абсолютный нуль, и других панелей. Интерфейс программы довольно дружелюбен. При наведении курсора мыши на иконку инструмента или команды появляется всплывающая подсказка, объясняющая назначение данной функции. Важно отметить, что в процессе работы вид панели инструментов может немного измениться. Появляется значок в виде двойной стрелки влево, позволяющий вернуться в главное меню панели инструментов. В некоторых случаях, когда выполняемая команда имеет несколько этапов выполнения, появляется значок в виде двойной стрелки вправо, обеспечивающий продолжение действия.

Настраиваем параметры чертежа

При изучении черчения в школе ученики усваивают, что чертеж должен выполняться в соответствии с определенными правилами, касающимися, среди прочего, начертания и толщины линий. Так как все чертежи в школе выполняются простым карандашом, то речи о цвете линий нет. В CAD можно изменить также и цвет линии. Можно использовать изменение цвета для нанесения вспомогательных линий, которые впоследствии будут удалены. Есть особенность и в том, что рабочее поле чертежа в LibreCad черное. Следовательно, основной цвет чертежа будет белым. При печати на белой бумаге он инвертируется.

Итак, прежде чем начать строить чертеж, следует определиться с линиями и размерами. Настройки чертежа доступны из меню Правка > Текущие настройки чертежа. Окно «Параметры чертежа» содержит несколько вкладок. На вкладке «Бумага» по умолчанию установлен размер бумаги А4 и альбомная ориентация листа. Так как чертежи в школе выполняются на формате А4, то менять здесь ничего не будем. Вкладка «Единицы измерения» позволяет настроить точность измерения длин в миллиметрах (их мы установили в начале работы). Установим для длины формат Десятичный, точность 0, то есть без отражения знаков после запятой. Создаем вспомогательный слой. Так можно построить горизонтальную или вертикальную линии, проходящие через заданную точку. Редактируем созданный примитив.

(thumbnail)
Редактируем созданный примитив.


LXF Для угла установим формат Десятичные градусы и точность 0. В нижней части окна в разделе «Просмотр» можно увидеть, как будет выглядеть на чертеже надпись в соответствии с заданными параметрами. Во вкладке «По сетке» установим галочку напротив пункта «Отображать сетку» и зададим промежутки по X и Y по 1 миллиметру. Вкладка «Размеры» содержит инструменты настройки размеров на чертеже. Установим параметры в соответствии со стандартом, которого придерживаются при построении чертежей на уроках черчения.

(thumbnail)
Построение параллельных линий относительно заданной.
(thumbnail)
Так строится окружность по ее центру и радиусу.

В первом пункте «Высота текста» установим 5 мм, так как это будет соответствовать привычному размеру шрифта для школьников. Выступ линии выноски должен быть от 1 до 5 мм. Можно оставить 1,25. Смещение линии выноски установим равным 10 мм. Расстояние от текста до размерной линии можно оставить таким же, как есть. Величина стрелки должна быть 5 мм. После установки всех параметров нажмем ОК.

Строим первый чертеж

Чтобы освоиться в программе, можно построить чертеж по сканированному и сохраненному в растровом формате выполненному на бумаге чертежу. Изображение можно открыть с помощью кнопки , находящейся в панели инструментов. В диалоговом окне нужно найти путь к нужному файлу и открыть его.

Возьмем для примера рисунок 43 из учебника Ботвинникова. После выбора нужного изображения на рабочем поле чертежа появится контур, отражающий размеры открываемого изображения. Нужно определить место расположения этого изображения щелчком левой кнопки мыши в какой-либо точке поля. Расположите изображение несколько правее абсолютного нуля. Оно нам потребуется только для того, чтобы быть перед глазами при необходимости. Хотя есть возможность измерять расстояние между точками (с помощью меню Инфо), если вдруг размеров не будет указано.

Проанализируем открытое изображение. Деталь построена на основе квадрата 20 × 20, имеет квадратную выемку и круглое отверстие. Для быстрого построения имеет смысл построить горизонтальную и вертикальную линии, пересекающиеся в абсолютном нуле, и провести параллельные им линии на определенных расстояниях. Реализуем это на нашем первом чертеже.

(thumbnail)
Строим контур очень быстро.

Создадим новый слой для вспомогательных линий. Для этого в поле «Список слоев» нажмем кнопку «+». В окне создания слоя введем его имя латиницей и зададим свойства линий для этого слоя: голубой цвет, толщину 0,13 мм и начертание – сплошная. Нажимаем ОК.

Построим горизонтальную линию, проходящую через абсолютный нуль. Для этого в панели инструментов нажимаем кнопку «Показать меню Линии», далее выбираем «Горизонтальные линии», вводим в командной строке возле слов «Укажите положение» координаты 0,0 и нажимаем Enter. Увеличим масштаб, прокручивая колесико мыши, и обнаружим появившуюся маленькую голубую горизонтальную линию, выходящую из центра координат. По умолчанию ее длина составляет 10 мм.

Теперь нужно увеличить размер этой линии. Для изменения примитивов предусмотрено меню «Изменение» или кнопка «Показать меню Редактирование» в панели инструментов. Для определенности будем работать с панелью инструментов. Итак, нажимаем кнопку редактирования, дальше нажимаем кнопку «Выровнять на величину», вводим значение величины в поле «Величина», которое появляется в верхней части окна. Можно оставить 200 мм, так как нам этого будет достаточно. Далее выбираем маленькую голубую линию, наведя на нее белое перекрестие и нажав левую кнопку мыши. Линия увеличится. Для прекращения работы с инструментом нажимаем правую кнопку мыши.

Теперь стоит провести горизонтальные линии, параллельные уже построенной на расстоянии 7, 15 и 10 мм от нее. Сделаем это следующим образом. В меню Линий панели инструментов нажимаем кнопку «Параллельные на расстоянии». Вводим расстояние в верхней части окна, устанавливаем количество 1 и подводим указатель мыши к линии так, чтобы он был чуть выше нее. Должна появиться параллельная линия, находящаяся на 7 мм выше исходной. Нажимаем левой кнопкой мыши для ее установки. Меняем расстояние на значение 15 и подводим указатель мыши к линии, проходящей через 0,0. Будьте внимательны: если указатель будет у вновь построенной линии, то и следующая линия будет размещена на 15 мм выше последней. Наконец, меняем значение расстояния на 20 мм и проделываем те же действия. Не забудьте щелкнуть правой кнопкой для отмены работы инструмента.

Построим теперь вертикальную линию, проходящую через абсолютный нуль. Для этого в меню Линий нажмем кнопку «Вертикальные линии». Попробуем теперь сразу задать длину линии в верхней части окна. Введем здесь для однозначности число 200. Привязку оставим к началу, введем координаты в командной строке и нажмем Enter. Как видим, линия получилась такой же длины, как горизонтальная. Постройте вертикальные линии, параллельные данной на расстояниях 10, 20, 10‑2,5 и 10+2,5. LibreCad умеет выполнять арифметические операции. Пользуйтесь умениями, полученными ранее.

Строим оси в новом слое. Для осей нужно задать толщину линий 0,18 мм, начертание – штрих-пунктирная (большая) линия. Для построения самих осей выбираем в меню Линий построение линии по двум точкам и привязку к сетке. Теперь постройте оси. Закончить построение линии можно, щелкнув правой кнопкой мыши. Построение параллельных линий относительно заданной. Так строится окружность по ее центру и радиусу. Строим контур очень быстро.

(thumbnail)
Выбираем тип размера и наносим его на чертеж.

Построив все вспомогательные линии и оси, создайте новый слой, в котором будет делаться окончательный чертеж. Параметры установите такие: цвет – черный/белый, толщина – 0,5 мм, начертание – сплошная. Для построения контура детали выберем в меню Линий кнопку «Линия по двум точкам». Дальше выберем инструмент «Привязка к точкам пересечения автоматически». Теперь достаточно навести курсор мыши на нужное пересечение линий и нажать левую кнопку мыши. Обведите таким образом весь контур. Должно получиться нечто похожее на наш рисунок.

Осталось построить окружность диаметром 8 мм, проходящую через пересечение оси симметрии чертежа и линии, находящейся на расстоянии 7 мм от оси абсцисс. Для этого в панели инструментов нужно выбрать меню Окружностей, найти кнопку для построения окружности по центру и радиусу, ввести значение радиуса в верхней части окна и задать привязку к точкам пересечения автоматически. Остается подвести курсор мыши к нужному пересечению и зафиксировать окружность щелчком левой кнопки мыши.

Важный этап – нанесение размеров. По требованиям стандарта их должно быть ровно столько, чтобы хватило для однозначного понимания чертежа: не приветствуется ни избыток, ни недостаток. Так как настройки для нанесения размеров мы задали ранее, то просто выполним необходимые действия, чтобы размеры появились на чертеже. Здесь нужно сказать, что все надписи на чертеже возможно выполнить только на латинице – на написание цифр этот факт, естественно, не влияет. Данный недостаток, как мы надеемся, будет в LibreCad со временем устранен.

Создадим новый слой для размеров – с тем, чтобы задать толщину и начертание размерных линий. По требованию, толщина размерной или выносной линии должна составлять от 1/3 до 1/2 величины основной линии. Так как толщину основной линии мы задали равной 0,5 мм, то здесь зададим 0,18 мм (по тем же соображениям была задана толщина осей ранее), цвет – черный/белый, начертание – сплошная линия. Выбираем в панели инструментов «Показать меню Размеры», далее нажимаем «Горизонтальный размер» и выбираем «Привязка к сетке». Далее выбираем нижнюю левую точку чертежа, затем правую нижнюю точку. Появится линия, соединяющая эти точки, стрелки и надпись. Размер пока не зафиксирован на чертеже. Опустите его вниз, перемещая мышью, и зафиксируйте на расстоянии 10 мм от контура.

Размер квадратной выемки можно построить следующим образом. Так как крайние точки имеют нецелую координату, то выбираем привязку к линиям пересечения автоматически. Отмечаем точки для размера щелчком левой кнопки мыши. Далее устанавливаем привязку к сетке, отодвигаем размерную линию на 10 мм выше контура и фиксируем ее щелчком левой кнопки мыши. Теперь выбираем вертикальный размер с привязкой к сетке и строим вертикальные размеры. Помним, что расстояние между параллельными размерными линиями должно быть от 7 до 10 мм. Для построения размера окружности нужно в верхней части окна выбрать метку диаметра, установить значение 8, а затем построить размер между точками окружности, диаметрально расположенными на центральной оси детали. Отключим вспомогательный слой, нажав значок глаза возле его названия. Таким же образом можно отключить слой 0, содержащий растровое изображение задания. Наш первый чертеж готов!

Перед печатью чертежа следует сначала настроить параметры размещения, масштаб и параметры печати. Для этого в меню Файл нужно выбрать Предварительный просмотр или нажать соответствующую иконку в панели. В режиме предварительного просмотра будет видно, что наш чертеж находится где-то далеко от бумаги. Это связано с тем, что мы открывали и размещали на рабочем поле растровое изображение. Подтяните лист бумаги под чертеж с помощью руки так, как это будет лучше на ваш взгляд. Задайте масштаб 2:1 и нажмите кнопку Сдвинуть. Теперь можно вывести файл в PDF-формате, который уже будет храниться неизменным. Можно и напечатать чертеж на принтере.
(thumbnail)
Замечательный чертеж для первого раза, не правда ли?

Полученных при выполнении первого чертежа умений достаточно для того, чтобы самостоятельно построить рамку формата A4. Можно дать такое задание школьникам на дом. Только писать текст придется вручную на уже распечатанном чертеже, так как кириллица не поддерживается. Можно, конечно, начертить и свой шрифт, но это уже отдельная, довольно сложная и кропотливая работа. Кроме того, важно дать задания для самостоятельной работы на занятии в присутствии учителя. В процессе освоения основных принципов и методов работы в CAD-системе важно не спешить на первых этапах.

Стоит сначала анализировать чертеж детали или ее наглядное изображение, если это задание на построение проекций или недостающих элементов чертежа, продумывать технологию своей работы по построению чертежа, определяться с количеством и назначением слоев и только потом начинать чертить. Все раздаточные материалы, используемые учителем черчения для обычных заданий, вполне подойдут и для выполнения в CAD-системе. Выбираем тип размера и наносим его на чертеж. Замечательный чертеж для первого раза, не правда ли?

«Стоит сначала анализировать изображение, а потом чертить.»

Персональные инструменты
купить
подписаться
Яндекс.Метрика