LXF148:Ответы
|
|
|
- Есть вопрос по открытому ПО? Пишите нам по адресу answers@linuxformat.ru
- Установку Linux
- Полноэкранный режим
- Флоппи-дисководы
- Драйверы ATI
- Клиенты BitTorrent
- Обновление систем
- Проблемы с VirtualBox
- Опознавание ID пользователей
Содержание |
1 Горести установки
- Мы подыщем эксперта на любой ваш вопрос. От установки и проблем с модемом до администрирования сети — ответ найдется! Просто напишите нам бумажное или электронное письмо, и о нем позаботятся.
- Нейл Ботвик
- Владелец ISP и экс-редактор дисков для нашего журнала, Нейл считает, что в Linux он от скуки на все руки.
- Джонатан Робертс
- Джонатан столько отлынивал от занятий из-за установки, настройки и взлома серверов, что теперь он эксперт.
- Майк Сондерс
- Майк был одним из создателей прототипа LXF – Linux Answers. Его специальности – программирование, оконные менеджеры, скрипты инициализации и SNES.
- Грэм Моррисон
- Когда Грэм не обозревает кучи программного обеспечения и не халтурит с MythTV, он готов к ответам насчет любого оборудования и проблем виртуализации.
- Валентин Синицын
- В редкие свободные минуты Валентин обычно запускает mcedit, чтобы отшлифовать какое-нибудь открытое приложение. Его любимая тема – настольный Linux.
- Юлия Дронова
- Если компьютер у Юлии не занят выполнением команды emerge, она спешит применить его для модерирования www.unixforum.org.
В Не могу установить Linux с привода Blu-ray. Пробовал Mint 10 и Ubuntu 10.04, оба в 64-битной версии. После появления меню Mint или заставки Ubuntu выводится следующее сообщение:
Busybox v1.15.3 (Ubuntu 1:1:15.3-1Ubuntu5) built- in shell (ash) (Initrampfs) unable to find a medium containing a live file system.
BIOS явно поддерживает привод и диск загружается, иначе я бы сообщения не увидел. Диски с дистрибутивом исправны — я устанавливал систему на ноутбук. Windows XP тоже установилось безо всяких проблем, значит, диск и привод исправны.
FranBlakes
О Приводы Blu-ray обладают полной обратной совместимостью с DVD и CD, поэтому для привода BD-ROM не должно быть никакой разницы – он должен загружаться с CD точно так же, как CD-ROM или DVD-ROM.
Я загрузил 64-битную версию Ubuntu 10.10 с компакт-диска через привод BD-ROM, и все прошло отлично. Мы знаем, что диск с дистрибутивом работает на другом компьютере, и знаем, что привод работает с другими дисками; остается предположить несовместимость диска и привода. Возможно, дело в том, как диск записан. Если Вы пользуетесь CD-RW, попробуйте CD-R или в самом крайнем случае новый CD-RW. CD-RW читаются сложнее, а когда диски стареют и на них появляется больше царапин, все становится еще хуже.
Если это не помогло, можно отключить экран-заставку Ubuntu, чтобы увидеть полный текст сообщения об ошибке, который должен дать лучшее представление о том, в чем дело. Текст также может содержать некоторые дополнительные подробности, которые можно вбить в любимую поисковую систему. Для отключения заставки нажмите Esc при первом появлении логотипа Ubuntu для входа в меню загрузки, затем нажмите F6 для просмотра опций загрузки в нижней части экрана и снова Esc – чтобы убрать всплывающее меню. Теперь можно редактировать параметры загрузки напрямую. Удалите “quiet splash” и нажмите Enter для загрузки с измененными параметрами. Это не сможет волшебным образом заставить диск работать, но позволит наблюдать за процессом загрузки и даст больше информации о том, почему он не завершается.
Вы пишете, что пользуетесь Windows; не пытаетесь ли Вы часом устанавливать систему с Wubi в Windows? В Wubi иногда возникает такая проблема; решение – загрузиться с диска и воспользоваться стандартным установщиком. МС
- Печать
- Что такое CUPS?
- CUPS (Common Unix Printing System – Общая система печати Unix) – набор драйверов и утилит для полной поддержки, управления и работы с принтерами в Linux и других ОС на основе UNIX.
- Так это драйвер принтера?
- Ну да, но не только. CUPS предоставляет «портативный уровень печати» между приложениями и принтером. Обычно он включает драйверы, но также предоставляет все необходимое для того, чтобы программы могли печатать.
- То есть, чтобы принтер заработал, мне придется лезть в командную строку и редактировать файлы настройки?
- Вовсе нет. В CUPS есть собственные графические утилиты настройки, работающие через web-браузер. Откройте в своем любимом браузере http://localhost:631 (может потребоваться ввод своего пароля или пароля root), и вы окажетесь на домашней странице CUPS. Там можно просматривать список принтеров, добавлять и удалять принтеры, а также работать с очередями печати (заданиями, ожидающими печати); есть и документация.
- Почему браузер, а не более привычная графическая программа?
- Благодаря web-интерфейсу вам не придется ставить никаких добавочных графических пакетов: не нужен даже X-сервер. С интерфейсом можно работать и в текстовом браузере вроде Elinks или в браузере, запущенном на другом компьютере.
- А это не опасно?
- Возможно, но с настройками CUPS по умолчанию подключения разрешаются только с localhost. Настройку можно изменить, разрешив подключения с локальной сети (открывать доступ через Интернет в общем случае не рекомендуется). Также можно управлять тем, какие пользователи имеют доступ к каким частям конфигурации – пользователям можно разрешить работать со своими заданиями на печать и запретить удалять свои принтеры.
- Какую роль здесь играет Gimp-print и что общего у GIMP с печатью?
- Gimp-print – набор драйверов, изначально предназначенный для GIMP. Хотя GIMP хорошо работает с CUPS, некоторые принтеры лучше ладят с драйверами Gimp-print. Эти драйверы сейчас работают и с CUPS, и Gimp-print можно считать расширенным набором драйверов, способных работать со всеми программами, использующими для печати CUPS, а не только с GIMP. Во избежание путаницы, проект переименовали в Gutenprint, но в некоторых дистрибутивах все еще есть пакеты Gimp-print.
- А что такое Gutenprint?
- Это новое название Gimp-print. В зависимости от того, насколько «передовой» дистрибутив вы используете, у вас будет Gimp-print 4.x или Gutenprint 5.x. Поскольку у Gimp-print гораздо больше общего с печатью, чем с GIMP, новое имя более внятно, хотя любое переименование вызывает кратковременную путаницу, само по себе сбивая с толку.
- Как узнать, поддерживается ли мой принтер?
- Первым делом справьтесь на сайте www.linuxprinting.org, где есть исчерпывающая база данных с информацией, насколько хороша (или плоха) поддержка каждого принтера, и с советами по драйверам. Лучше зайти сюда до покупки принтера, чем потом узнать, что ваша новинка годится только на пресс-папье.
2 Экран не полный
В Пользуюсь Linux Mint 10 LXDE с Firefox 3.6. Согласно меню «Вид [View]» в Firefox, для перехода в полноэкранный режим нужно нажать F11 или выбрать данный пункт в этом меню. При нажатии F11 заголовок окна исчезает, высвобождая немного экранной площади. Однако при выборе полноэкранного режима мышью в меню «Вид [View]» открывается полноценный полноэкранный режим, исчезают все вкладки, меню и индикатор статуса. Почему нажатие F11 делает только половину работы? Это проблема файлового менеджера или с этим не справляется Firefox?
Крис Сэндлз [Chris Sandles]
О Это конфликт комбинаций клавиш. Хотя F11 – клавиша включения полного экрана в Firefox, она также включает полноэкранный режим в LXDE, и LXDE «ловит» ее первой. Поэтому при нажатии F11 Firefox не меняется совсем – он даже не знает, что была нажата клавиша. То, что мы видим – это результат растягивания окна Firefox на полный экран средой LXDE.
Естественное решение проблемы – изменить привязку клавиши F11 либо в LXDE, либо в Firefox. Я бы советовал сделать это в LXDE, по двум причинам: во-первых, так Firefox останется прежним и в других системах, которыми Вы можете пользоваться, и во-вторых, что важнее, официального способа изменить привязки клавиш в Firefox нет. Чтобы изменить их в LXDE, нужно напрямую изменить файл config – нарядного графического интерфейса для этого нет. Откройте файл ~/.config/openbox/lxde-rc.xml и найдите раздел:
<keybind key=”F11”> <action name=”ToggleFullscreen”/> </keybind>
Можно либо изменить клавишу на другую, либо добавить Ctrl, Alt или Shift (C-F11, A-F11 или S-F11), либо полностью закомментировать раздел таким образом:
Чтобы обновить конфигурацию в текущем сеансе, выполните в терминале команду
openbox --reconfigure
Мы часто предлагаем решение в виде команд, вводимых в терминале. Хотя обычно то же самое можно выполнить и через графические инструменты, входящие в состав дистрибутива, отличия между этими инструментами означают, что такие решения будут узко специфичными. Команды терминала гораздо более гибкие и работают во всех дистрибутивах.
Команды настройки системы часто должны запускаться от имени суперпользователя (superuser или root). В зависимости от вашего дистрибутива, есть два способа сделать это. Многие дистрибутивы – в частности, Ubuntu и его производные – требуют предварять такие команды префиксом sudo. После этого пользователю предлагается ввести пароль, и система выдает ему полномочия root, действующие на время выполнения команды. Другие дистрибутивы используют префикс su, применение которого требует ввода пароля root и дает полные права root до тех пор, пока пользователь не введет команду logout. Если ваш дистрибутив использует su, выполните эту команду один раз, и потом сможете выполнять любую команду, не предваряя ее префиксом sudo.
3 Флоппи-дисководы
В Я дал двум друзьям Linux Mint 9, но они говорят, что дисковод не работает. Я знаю, что смонтировать дисковод из графического интерфейса нельзя, но я нашел способ включить дисковод, закомментировав следующую строку в /etc/fstab:
/dev/fd0 /mnt/floppy auto rw,user,noauto,exec,utf8 0 0
Вставив дискету в дисковод, я выполняю следующую команду в терминале:
sudo mount /dev/fd0 /media/floppy0
После окончания работы с дискетой я размонтирую ее следующей командой, опять же в терминале:
sudo umount /dev/fd0
Я попробовал Ubuntu 11.04 на другом компьютере с теми же результатами, только строка в etc/fstab там такова:
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
Друзьям нравится система, но они говорят, что неудобно иметь на рабочем столе все кроме дисковода. Могу только согласиться с ними — если он есть, то должен работать; если нет, выкиньте его совсем.
В чем логика различий между строками в /etc/fstab? Можно ли заставить дисковод работать из графического интерфейса в иконке «Компьютер [Computer]» на рабочем столе Linux Mint 9 и в «Местах [Places]» в Ubuntu 11.04 с Gnome?
Джон Йейтс [John Yates]
О Строка в /etc/fstab говорит системе, что монтировать (/dev/fd0) и куда монтировать (/mnt/floppy), поэтому единственное различие между двумя дистрибутивами в том, что Ubuntu монтирует его в /media/floppy0. Параметр noauto означает, что устройство не монтируется автоматически при загрузке, а параметр user означает, что монтировать его могут обычные пользователи без помощи sudo. Раскомментируйте строку, и Вы сможете смонтировать диск командой
mount /dev/fd0
без необходимости указывать точку монтирования или пользоваться sudo. Однако в Mint это лучше делать командой udisks:
udisks --mount /dev/fd0
Команда все же запускается в терминале, но ее можно добавить в меню, кликнув правой кнопкой мыши на меню, выбрав Edit Menu [Редактировать меню] и добавив новый пункт меню типа Application [Приложение], который будет запускать эту команду. Так как она запускается от имени обычного пользователя, без sudo, диск будет смонтирован этим пользователем, а значит, у Вас будет право на запись для этого диска. Если диск монтируется пользователем root, право на запись обычно есть только у него. Это поведение можно изменить, добавив в строку в /etc/fstab параметр umask=000:
/dev/fd0 /mnt/floppy auto rw,user,noauto,exec,utf8,umask=000 0 0
Эта строка делает диск доступным для чтения и записи всем. Вы также можете удалить параметр exec, который разрешает запускать с диска скрипты и программы. НБ
- Расход ОЗУ
Индикатор объема ОЗУ на рабочем столе показывает, что через несколько часов работы системы осталось всего несколько килобайт? Вы можете подумать, что следует добавить еще памяти, но независимо от количества физической памяти, она будет полностью израсходована через несколько часов после загрузки Linux, а то и раньше.
Хотя бесполезное использование памяти – это трата ресурсов, ее неиспользование – еще большая трата, поэтому ядро Linux выделяет неиспользуемую память на такие вещи, как кэши файловой системы, чтобы повысить производительность. Это можно увидеть в настройках буферов в выводе команды top, например:
Mem: 1028092k total, 1018704k used, 9388k free, 49760k buffers
Эта строка показывает, что из 1 ГБ ОЗУ на этом компьютере свободно менее 10 МБ. Примерно половина памяти используется в качестве буферов. Они значительно ускоряют доступ к диску, кэшируя записанные данные в память и считывая больше, чем вам необходимо, в упреждение следующей операции чтения. Если эта память необходима для чего-то более важного, например, данных программы, она незамедлительно освобождается.
В памяти остаются не только данные файловой системы – попробуйте проверить объем свободной памяти, затем запустить и закрыть большую программу, такую как Firefox, и вы увидите, что объем свободной памяти уменьшился. Теперь снова запустите Firefox и посмотрите, насколько он ускорился! Дело в том, что ядро хранит данные в памяти готовыми для следующего использования. То же касается разделяемых библиотек, поэтому с программами одного рабочего стола работается быстрее, чем со смесью из разных рабочих столов, особенно при малом ОЗУ.
4 ATI, Nvidia, что угодно
В Недавно я установила последнюю версию драйвера ATI в Fedora 14. Проблема только в том, что в моем Toshiba Satellite Pro A300 стоит видеокарта Nvidia. Теперь я могу работать только в командной строке. Как заменить драйвер ATI на Nvidia с командной строки? При установке Fedora я разбивала на разделы по умолчанию, поэтому не думаю, что просто смогу переустановить ее?
Синдра Флетленд [Sindre Flatland]
О Как Вы устанавливали драйвер? Если через менеджер пакетов, то удалите его таким же образом. Эквивалент в командной строке с yum таков:
yum remove packagename
Если Вы не уверены в имени пакета, выведите список всех установленных пакетов командой:
yum list installed
или сузьте список, введя часть имени:
yum list installed ati
Если Вы устанавливали двоичный пакет, загруженный с ATI, чего при наличии пакета для Вашего дистрибутива они делать не советуют, в программе ati-config есть параметр для его удаления:
ati-config --uninstall
Альтернатива – еще раз запустить двоичный пакет (файл .run), из которого Вы устанавливали драйвер, с параметром --uninstall. В обоих случаях команда запускается от имени root. Если удаление не удастся, есть несколько вариантов действий. Первый – применить force:
sh ati-driver-installer-X-Y-x86.x86_64.run --uninstall=force
Также можно загрузиться в однопользовательский режим. Если в меню загрузки нет такого пункта, дважды нажмите e в меню загрузки, чтобы изменить строку конфигурации ядра: добавьте в ее конец слово single. Система загрузится в режиме с одним пользователем root и практически без запущенных сервисов. Это базовая среда Linux, которую можно загрузить в большинстве дистрибутивов, и она должна позволить Вам удалить драйверы без препятствий со стороны X-сервера или любых загруженных модулей.
Затем перезагрузите систему, и появится простой двумерный дисплей, реализованный с помощью драйвера nv с X.org, и с ним вы сможете установить драйверы Nvidia, желательно через менеджер пакетов дистрибутива. ГМ
Ежемесячно мы получаем несколько писем, на которые не можем ответить, так как проблема описана в них недостаточно полно. Чтобы дать вам наилучший ответ, нам нужно знать как можно больше. Если у вас появляется сообщение об ошибке, сообщите нам его точный текст и конкретные условия, при которых оно появляется. Если у вас проблема с устройствами, сообщите нам об установленных устройствах. Если Linux уже запущен, можете воспользоваться превосходной программой Hardinfo (http://hardinfo.berlios.de/), которая сохранит подробную информацию об устройствах и о системе в HTML-файл, и вы сможете приложить его к письму. Альтернативный и не менее удобный вариант – lshw (http://ezix.org/project/wiki/HardwareLiSter). Одна из них или обе должны быть в вашем дистрибутиве.
Если вы не хотите или не можете их установить, выполните следующие команды в терминале от имени root и приложите файл system.txt к письму. Это здорово поможет диагностике.
uname -a >system.txt lspci >>system.txt lspci -vv >>system.txt
5 Затор трафика
В У меня серьезные проблемы с торрент- клиентом Transmission. Запуская его для загрузки торрент-файлов, я получаю сообщения об ошибках таймаута при попытке загрузки web-страниц, обычно с сообщением о невозможности получения адреса из DNS.
Пытался снизить скорость выгрузки и загрузки — разницы никакой. Где-то я прочел о том, что нужно уменьшить скорость выгрузки ниже скорости моего подключения, не знаю почему, но это не сработало.
Недавно я перешел на сервис ADSL-соединения со скоростью «до 20 Мбайт/с», но даже это не помогло. Я пробовал другие клиенты BitTorrent — в них проблема проявляется не так сильно, но Transmission мне нравится больше.
Брайан Донован [Brian Donovan]
О На самом деле проблема в «железе» – Вы перегружаете маршрутизатор. Дело не в ширине канала, а в числе соединений, которые создает Transmission или любой другой клиент BitTorrent.
Широкополосные маршрутизаторы используют NAT (Network Address Translation – Преобразование сетевых адресов) для сопоставления адресов отдельных компьютеров дома или в офисе с единственным публичным IP-адресом, который есть у вас в Интернете.
Чтобы это работало, маршрутизатор должен отслеживать каждое исходящее соединение для перенаправления ответов обратно на корректный локальный адрес – это соответствие называется таблицей NAT и хранится в памяти маршрутизатора. Таким образом, число одновременных соединений, которые можно поддерживать, ограничено объемом памяти маршрутизатора. Когда таблица заполнится, последующие соединения могут завершиться неудачно, и на все DNS-запросы, отправляемые в сеть при попытке загрузить web-страницу, ответа не последует.
Причина данной конкретной проблемы с BitTorrent – большое количество отдельных соединений, устанавливающихся при загрузке или сидировании нескольких торрентов.
Каждое соединение может использовать лишь небольшую часть полосы пропускания, особенно если ограничить скорость, но все они используют тот же объем таблицы NAT.
Решение на самом деле очень простое. Зайдите в настройки Transmission и на вкладке Network [Сеть] уменьшите максимальное количество пользователей на торрент [Maximum Peers Per Torrent] и общее максимальное количество пользователей [Maximum Peers Overall]. Для начала неплохо установить их в 10 и 100 соответственно; позже можно изменить их на оптимальные значения для Вашей системы. Если задать их слишком маленькими, это уменьшит объем, который вы сможете сидировать или загружать, и на все потребуется больше времени, чем необходимо.
Снижая исходящую скорость, не забывайте, что исходящий трафик необходим даже при загрузке данных. Прием каждого пакета требует подтверждения, поэтому при перенасыщении исходящего трафика загрузки начнут блокироваться – не только торренты, но и вообще любые.
В большинстве рекомендаций предлагается ограничить исходящую скорость BitTorrent до 60 – 75 % исходящей скорости канала, но определяется эта величина по фактическому каналу, а не теоретическому максимуму провайдера. Воспользуйтесь несколькими оценочными сайтами, вроде www.broadbandspeedchecker.co.uk или www.speedtest.net, для оценки реальной скорости канала и ограничьте его использование в Transmission до не более 75 % в обоих направлениях. ГМ
В У меня много учетных записей в Интернете, и у многих одинаковый пароль. Ситуация с Sony заставила меня пересмотреть свой подход, и теперь пароли разные, но запомнить, где какой, трудно.
Дома мне помогает «Бумажник» KDE, но он бесполезен на нетбуке и на компьютере в офисе. Если я куплю смартфон, ситуация еще ухудшится. Нет ли безопасного способа хранения паролей, чтобы они всегда были мне доступны?
Джон Уотсон [John Watson]
О Упомнить множество паролей – нарастающий кошмар; все больше и больше сайтов требуют пароль, и возрастает потребность в более сложных паролях.
Помнить несколько десятков сложных буквенно-цифровых паролей большинству из нас не под силу. В KDE и Gnome есть менеджеры паролей, но они непереносимы. KeePassX (www.keepassx.org) – портативная и простая кроссплатформенная программа, которая распределяет имена пользователей, пароли и URL-адреса по категориям и хранит все в одном зашифрованном файле. Есть версии под Linux, Mac OS, Windows, Android, а также клиент для iPhone.
Установите программу обычным образом через менеджер пакетов и запустите ее. При первом запуске вам предложат создать пароль. Придумайте сложный буквенно-цифровой пароль в смешанном регистре длиной не менее 12 символов, так как это – ключ ко всему остальному. Потом добавляйте пароли. Программа умеет не только сохранять, но и создавать их. Так как пароли запоминает машина, они могут быть длинными и сложными; вставить пароль из 20 символов в поле так же быстро, как и из шести, поэтому воспользуйтесь генератором паролей, чтобы сделать их максимально стойкими к взлому.
Кроме имени пользователя, KeePassX сохраняет URL сайта, и им можно пользоваться как менеджером закладок. Кликните на URL, чтобы открыть его в своем браузере, с помощью Ctrl-B и Ctrl-C скопируйте имя пользователя и пароль в буфер обмена и с помощью Ctrl-V вставьте их в браузер. Выбрать браузер, который будет открываться по щелчку на URL-адресе, можно в разделе Дополнительно [Advanced] окна Настройки [Settings].
Теперь осталось позаботиться, чтобы соответствующие данные стали доступны всем устройствам, для чего идеально подходит Dropbox. Сохраните свою базу данных в своей папке Dropbox, по умолчанию ~/Dropbox, и она синхронизируется с вашей учетной записью; потом установите Dropbox и KeePassX на все свои компьютеры и телефоны.
На сайте http://portableapps.com/apps/utilities/keepass_portable имеется портируемая версия для Windows. Вставив в компьютер USB-брелок с файлом базы данных, вы сможете пользоваться своими паролями в большинстве компьютеров с Windows, не оставляя от пароля никаких следов. Для истинных хакеров существует клиент командной строки Kpcli (http://sourceforge.net/projects/kpcli). Это скрипт Perl. Загрузите его, сделайте исполняемым и запустите. При первом запуске он может пожаловаться на отсутствующие модули, но любой хакер в курсе, что справиться с этим поможет CPAN. НБ
6 Со старого на новый
В Я настраиваю новый компьютер, который станет у меня основным, и хочу перенести на него все рабочие файлы, электронные письма, контакты и возможные файлы конфигурации пакетов.
Два компьютера подключены к одной сети, и я буду устанавливать те же пакеты, которыми пользуюсь обычно. Для копирования я планирую взять rsync. Переместятся ли все скрытые файлы для отдельных пакетов вместе со всеми рабочими файлами? Повлияет ли это на настройки пакетов в новой системе?
Я перехожу с Mandriva на OpenSUSE, главным образом потому, что там есть пакет Quanta, которым я регулярно пользуюсь при web-дизайне.
mikejd
О Rsync – и правда лучший способ это сделать. Вам могут предложить альтернативы, такие как tar, но если два компьютера соединены друг с другом, воспользуйтесь rsync.
Простейший способ это сделать – установить новую систему, создать пользователя с таким же именем и убедиться, что его числовой UID точно такой же, затем перезагрузиться в него, но не входить в систему под этим пользователем. Затем запустите rsync от имени root на старом компьютере, командой
rsync --archive /home/ root@newbox:/home/
Обязательно укажите завершающие слэши в путях: если их опустить, rsync скопирует каталоги иначе, и содержимое /home может оказаться в /home/home на новом компьютере. Параметр --archive (или -a) включает целый набор опций для сохранения владельцев файлов и временных меток, а также рекурсивное копирование и все, что может потребоваться при клонировании каталога. Можно добавить параметр --verbose (-v) для вывода подробной информации о копировании, но это способно замедлить процесс.
Копирование целого каталога /home повлияет на пакеты на новом компьютере: а именно, их настройки станут точно такими же, как на старом. Однако системные файлы конфигурации не скопируются. Если вы будете пользоваться теми же или более новыми версиями программ, это будет работать прекрасно. А вот при установке более старой версии программы по сравнению с имеющейся версией файла конфигурации могут возникать странные проблемы. Обычно это жалобы программы на неизвестные параметры в файле конфигурации, если только формат файла не был полностью изменен и программа совсем не может прочесть его, но это уже маловероятно.
Если Вы намерены перенести настройки системы, можете скопировать содержимое /etc, но при непосредственном копировании скорее всего возникнут проблемы. Я бы предпочел скопировать файлы в безопасное место, чтобы сверяться с ними при настройке нового компьютера. Команда
scp -pr /etc root@newbox:/etc/.oldsettings
запущенная в старой системе, скопирует настройки в каталог /etc/.oldsettings в новой. Нечто похожее можно сделать с /var/lib, если Вы пользуетесь программами, которые хранят данные там. Так как вы используете систему для web-дизайна, возможно, стоит скопировать и содержимое /var/www.
Наконец, список установленных пакетов можно получить командой:
rpm -ql
Перенаправьте ее в файл и скопируйте в новую систему, чтобы иметь под рукой удобный список того, что уже установлено, но учтите, что в разных дистрибутивах пакеты могут называться по-разному. Пользуйтесь списком только для справки, а не для установки вслепую. НБ
- Выберите пароль
- Пароль KeePassX – ключ ко всем остальным паролям, поэтому выберите сложный пароль, который трудно угадать и еще труднее забыть.
- Добавьте записи
- Добавьте запись для каждого сайта с любой другой необходимой информацией. Также можно импортировать XML-файл, экспортированный из KWallet в KDE.
- Сложные пароли
- Раз вам больше не нужно запоминать или набирать пароли, позвольте KeePassX создать сложные, длинные и случайные пароли, ради укрепления безопасности.
- Носите их с собой
- KeePassDroid означает, что пароли можно носить в кармане. Это гораздо безопаснее записки, приклеенной к монитору.
- Платформонезависим
- Портативная версия KeePass, PortableApps, запущенная с USB-брелка на компьютере с Windows. База данных тоже на брелке.
- Вариант для умников
- Kpcli дает возможность доступа к базе данных с паролями из командной строки, который пригодится при неработающем X-сервере или для повышения вашего статуса умника.
7 Виртуальная поломка
В У меня проблема с VirtualBox (версия 3.2.6 r63112), установленным с одного из ваших замечательных DVD. Прошлой осенью в Mint 9 я настроил четыре виртуальных машины, в том числе две с Сами Знаете Какой операционной системой (увы, она нужна мне для работы), и все было прекрасно.
Зимой я отставил ноутбук и снова включил его на прошлой неделе, но теперь не могу запустить VirtualBox под обычным пользователем — только под root через sudo с терминала. У меня появляется ошибка, приведенная ниже.
VirtualBox: supR3HardenedMainGetTrustedMain : dlopen(“/opt/VirtualBox/VirtualBox.so”,) failed: VBoxVMM.so: cannot open shared object file: No such file or directory
Проверяю наличие двух упомянутых файлов — они на месте. Оставшаяся часть сообщения мне ни о чем не говорит, но я догадываюсь, что это насчет прав доступа? Заглянув в справку VirtualBox, я ничего полезного не нашел.
Я проверил группы и пользователей: есть группа vboxusers, и оба моих пользователя в нее входят; насколько я понимаю, эта группа создана во время установки. Доступ к Интернет у меня ограничен и появляется лишь изредка, и я не могу тратить все это время на поиск решений. VirtualBox не распознается как установленный ни Dpkg, ни Synaptic. Как мне удалить/переустановить его, если это единственное решение проблемы?
Редж [Reg]
О Единственный способ, которым я сумел бы воспроизвести эту ошибку – перенести файл /opt/VirtualBox/VirtualBox.so в другое место или сделать его нечитаемым для обычных пользователей. Вы подтвердили, что файл существует (а если бы его не было, никаких привилегий root не хватило бы на то, чтобы его вернуть), поэтому убедитесь, что этот файл доступен для чтения всем пользователям, командой:
ls -l /opt/VirtualBox/VirtualBox.so
которая должна вывести нечто вроде
-rw-r--r-- 1 root root 6342480 May 19 13:36 /opt/VirtualBox/VirtualBox.so
Дата и размер не имеют значения – моя версия другая; но наличие трех r в правах доступа обязательно. Если это не так, права доступа можно поправить командой:
sudo chmod +r /opt/VirtualBox/VirtualBox.so
Простейшая из возможных альтернатив – переустановка, так как за истекшие месяцы что-то было повреждено. Вы устанавливали VirtualBox из его собственного установщика, а не из менеджера пакетов дистрибутива, поэтому он и не появился в менеджере пакетов для удаления или переустановки. Установщик имеет скрипт для удаления, и Вы подчистую удалите VirtualBox командами
cd /opt/VirtualBox sudo sh uninstall.sh
Теперь можно переустановить его либо снова из пакета на DVD, либо через Synaptic. При удалении будут убраны файлы программы вместе с сопутствующими библиотеками и документацией. Никакие файлы конфигурации или виртуальные машины в домашнем каталоге затронуты не будут, и Вам не придется настраивать их снова после переустановки. ГМ
8 Невидимый и неизвестный ID
В Я изменил размер раздела PCLinuxOS и установил Ubuntu 10.10, а затем обнаружил, что моя установка PCLinuxOS не работает. После вывода информации о загрузке ядра у меня начинают мигать светодиоды Caps Lock и курсор. Все, что я могу сделать на этом этапе — выполнить «холодную загрузку», зайти в Grub и загрузить Ubuntu. У меня есть доступ к разделу PCLinuxOS из Maverick, но я не могу ничего сделать, потому что получаю сообщения об ошибках вроде «Ошибка открытия файла: нет доступа [Error opening file: Permission denied]».
Я также попробовал изменить запись для PCLinuxOS в Grub, выбрав ее и нажав e. После этого я увидел вот что:
GNU GRUB version 1.98+20100804-5ubuntu3 insmod part_msdos insmod ext2 set root = ‘(hd0,msdos1)’ search --no-floppy --fs-uuid --set dbc36cf7- 870d-41f9-9ef5-b9bc8773d974 linux /boot/vmlinuz BOOT_IMAGE=linux root=UUID=dbc36cf7-870d-41f9-9ef5-b9bc8773d974 resume=UUID=8837d99b-56aa-4de5-bf64-85ef577a4c6c splash=silent vga=788
Стэнли Боб-Карл Озоемена [Stanley Bob-Carl Ozoemena]
О Мигание светодиода Caps Lock – сигнал паники ядра. В данном случае ошибка находится в выводе, который Вы предоставили:
Unable to mount root fs on unknown-block(0,0)”
Ядро не может найти корневой раздел, а поэтому не может и запустить процесс init, запускающий все остальное. Причина этого такова:
Cannot open root device “UUID=dbc36c7-870d-41f9-9ef5-b9bc8773d974”
а в Вашей конфигурации Grub
root=UUID=dbc36cf7-870d-41f9-9ef5-b9bc8773d974”.
В Ubuntu вместо номеров разделов используются универсальные идентификаторы файловой системы (UUID). Простое решение – изменить этот идентификатор на блочное устройство, содержащее корневой раздел PCLinuxOS:
root=/dev/sda2
Сделайте то же самое с параметром resume, указав в нем устройство с разделом подкачки PCLinuxOS. Заставив это работать путем изменения опций Grub во время загрузки, сделайте изменения постоянными. Загрузитесь в Ubuntu, и там это можно изменить двумя способами. Чтобы изменить это только для PCLinuxOS, вставьте фрагмент файла /boot/grub/grub.cfg в конец /etc/grub.d/40_custom, измените root= и resume= на используемые имена устройств и выполните команду:
sudo update-grub
Она создаст новую запись для PCLinuxOS, но старая все еще на месте. Альтернативный вариант – полностью отключить использование UUID Grub. От имени суперпользователя-root откройте /etc/defaults/grub, найдите строку
#GRUB_DISABLE_LINUX_UUID=true
и удалите начальный #, чтобы раскомментировать ее. Эта строка предлагает Grub использовать имена устройств. После этого снова запустите update-grub аналогичным образом для создания нового grub.cfg. Данная команда создаст более читаемое и в общем более надежное меню, с одним только недостатком: если добавить, удалить или как-то иначе изменить порядок дисков или разделов в компьютере, имена устройств в grub.cfg станут неправильными, тогда как их универсальные идентификаторы UUID не изменятся (поэтому идентификаторы и используются здесь и в /etc/fstab). Коль скоро вы знаете об этом и помните, что после выполнения любых подобных изменений нужно запускать update-grub, все будет прекрасно.
Ошибки прав доступа, которые Вы видите, возникают потому, что вы заходите в Ubuntu с другим идентификатором пользователя (так как сравниваются числовые идентификаторы, а не имя пользователя). Значение идентификатора можно посмотреть с помощью команды id. Измените /etc/passwd на одном компьютере так, чтобы идентификатор пользователя был точно таким же, как и на другом, после чего выполните команду
sudo chown -R username: ~username
в этой системе, чтобы у всех файлов пользователя появился правильный владелец. ДжР