Журнал LinuxFormat - перейти на главную

LXF138:Shotwell

Материал из Linuxformat
Перейти к: навигация, поиск
Shotwell Рас­чис­тим пап­ки со сним­ка­ми при по­мо­щи но­вой удоб­ной про­грам­мы

Содержание

Shotwell: Фо­то в по­ряд­ке

Ес­ли пап­ка фо­то­гра­фий у вас ло­мит­ся от порт­ре­тов ва­ше­го ко­та, то этот учебник как раз для вас. Алек­сандр Тол­стой по­мо­жет вам от­де­лить мух от кот­лет.
Где взять Shotwell

Shotwell пре­дус­та­нов­лен в Fedora 13 и 14 и так­же яв­ля­ет­ся ме­нед­же­ром фо­то­гра­фий по умол­ча­нию в Ubuntu 10.10. По­лу­чить по­след­нюю Shotwell для Ubuntu и его про­из­вод­ных мож­но че­рез PPA: ppa:yorba/ppa. Про­ект на http://www.yorba.org /shotwell так­же пре­дос­тав­ля­ет би­нар­ник Windows и, ко­неч­но, ар­хив с ис­ход­ны­ми ко­да­ми, ес­ли вы хо­ти­те со­брать Shotwell свои­ми ру­ка­ми.

Вы за­ме­ти­ли, что от­кры­тые при­ло­жения ста­но­вят­ся все дру­же­любнее? Ес­ли нет, то вспомните вре­ме­на, когда все за­пуска­лось из команд­ной стро­ки: у вас бы­ли лишь жут­кий чер­ный эк­ран, мер­цаю­щий кур­сор и пол­ное от­сут­ствие гра­фи­ки.

Хо­тя сей­час вас, воз­мож­но, про­бра­ла дрожь, несколь­ко де­ся­ти­ле­тий на­зад никто и не ду­мал жа­ло­вать­ся. Да, в на­ши дни поль­зо­ва­те­ли тре­бо­ва­тельнее, чем рань­ше. Ра­бо­чей про­грам­мы им те­перь ма­ло – по­да­вай ее лег­кой в ис­поль­зо­вании, да чтоб все жизнен­но важ­ные функ­ции бы­ли в пре­де­лах па­ры щелч­ков мы­ши. К сча­стью, есть до­воль­но но­вое ин­те­рес­ное при­ло­жение, ко­то­рое по­мо­жет вам про­из­во­дить необ­хо­ди­мые дей­ствия с циф­ро­вы­ми фо­то­гра­фия­ми. Оно на­зы­ва­ет­ся Shotwell, и наш урок рас­ска­жет вам о вы­го­дах его при­менения как основ­но­го ПО для ра­бо­ты со сним­ка­ми. Для это­го мы вы­полним про­стой про­ект по управ­лению фо­то­гра­фия­ми. Мы так­же рас­смот­рим, как вы­пол­нять стан­дарт­ные по­все­днев­ные за­да­чи.

Как вы уже до­га­да­лись, в осно­ве это­го про­ек­та ле­жит об­ра­бот­ка циф­ро­вых изо­бра­жений. Спер­ва мы ско­пи­ру­ем фо­то­гра­фии с циф­ро­вой ка­ме­ры в биб­лио­те­ку Shotwell. За­тем вы­полним ряд ор­ганиза­ци­он­ных за­дач, в том чис­ле мар­ки­ров­ку и сор­ти­ров­ку фо­то­гра­фий. Мы так­же ис­пра­вим оп­ре­де­лен­ные недостат­ки, та­кие как недо­держ­ки и туск­лые цве­та. На­конец, мы по­де­лим­ся луч­ши­ми сним­ка­ми с друзь­я­ми и семь­ей.

Вам ведь зна­ком этот про­цесс? Но с Shotwell все бу­дет ина­че, по­это­му уста­но­ви­те его пря­мо сей­час. Им осо­бен­но сто­ит за­нять­ся, по­то­му что он уже за­менил F-Spot в неко­то­рых Gnome-ди­ст­ри­бу­ти­вах, вро­де Ubuntu 10.10 и Fedora 14. В све­те это­го, F-Spot уже вы­гля­дит немно­го про­шло­годним – по­ра уже ра­бо­тать в чем-то по­све­жее.

По­лу­чим изо­бра­жения

LXF138 58 1.jpg Вам пред­ло­жат от­крыть Shotwell, ес­ли вы вста­ви­те лю­бой ме­диа-ис­точ­ник с циф­ро­вы­ми фо­то­гра­фия­ми.

LXF138 59 1.jpg Най­ди­те свое уст­рой­ст­во в спи­ске сле­ва.

Все на­чи­на­ет­ся с биб­лио­те­ки, где хра­нят­ся изо­бра­жения. Что­бы на­полнить ее сним­ка­ми, да­вай­те под­клю­чим циф­ро­вую ка­ме­ру к ва­шей Linux-ма­шине. Для это­го под­сое­дините сам ап­па­рат к пор­ту USB че­рез спе­ци­аль­ный ка­бель, по­став­ляе­мый вме­сте с уст­рой­ством; ли­бо из­вле­ки­те кар­ту па­мя­ти из фо­то­ка­ме­ры и вставь­те ее в слот кард-ри­де­ра.

В пер­вом слу­чае необ­хо­ди­мо за­дать ре­жим под­клю­чения до фи­зи­че­ско­го со­единения Linux-ма­ши­ны и уст­рой­ства. Вклю­чи­те ка­ме­ру, пе­рей­ди­те в эк­ран­ное ме­ню и най­ди­те пункт, уста­нав­ли­ваю­щий ре­жим под­клю­чения. Обыч­но есть два ва­ри­ан­та: циф­ро­вая ка­ме­ра или USB Mass Storage. До­пусти­мы оба, но учти­те, что в за­ви­си­мо­сти от ва­ше­го вы­бо­ра систе­ма Linux от­реа­ги­ру­ет на под­клю­чение ка­ме­ры по-раз­но­му. В ре­жи­ме ка­ме­ры, Shotwell рас­по­зна­ет ее как уст­рой­ство вво­да и бу­дет ис­поль­зо­вать дви­жок GPhoto. Ре­жим Mass Storage про­ще: тогда ка­ме­ра бу­дет дей­ство­вать как съем­ный диск. Это раз­ли­чие мо­жет быть важ­но, ес­ли вы вруч­ную ско­пи­ро­ва­ли изо­бра­жения на кар­ту па­мя­ти, то есть на ней си­дят и сним­ки из ка­ме­ры, и ва­ши соб­ствен­ные фай­лы. В та­ком слу­чае, вы­би­рай­те ре­жим USB Mass Storage.

Итак, ре­жим вы­бран. Те­перь под­сое­дините ка­ме­ру и вклю­чи­те ее. Вы уви­ди­те за­прос о том, как по­сту­пить с толь­ко что об­на­ру­жен­ным уст­рой­ством. Как ва­ри­ант, вставь­те кар­ту па­мя­ти в кард-ри­дер.

Ес­ли ва­ша кар­та па­мя­ти ав­то­ма­ти­че­ски от­кры­та в фай­ло­вом менед­же­ре, по­ка за­крой­те его или про­сто сверните. За­тем от­крой­те Shotwell (При­ло­жения > Гра­фи­ка > Shotwell [Applications > Graphics > Shotwell]) и по­смот­ри­те на ле­вую ко­лон­ку ин­тер­фей­са про­грам­мы. Най­ди­те свое уст­рой­ство в спи­ске и два­ж­ды щелк­ните по нему.

По на­жа­тии ОК, в глав­ном окне Shotwell поя­вят­ся ва­ши фо­то­гра­фии. По умол­чанию они сгруп­пи­ро­ва­ны по да­те, из­вле­кае­мой из ме­та­дан­ных Exif (ко­то­рые со­про­во­ж­да­ют ка­ж­дое изо­бра­жение). Вер­тикаль­но ори­ен­ти­ро­ван­ные изо­бра­жения долж­ны быть по­вер­ну­ты с по­мо­щью функ­ции по­во­ро­та, бо­лее под­роб­но опи­сан­ной ниже.

Вы­хо­дит, ско­пи­ро­вать изо­бра­жения с ка­ме­ры на же­ст­кий диск со­всем не слож­но. А ес­ли у вас уже есть кол­лек­ция ва­ших фо­то­гра­фий в F-Spot, и вы хо­ти­те пе­рей­ти на Shotwell? На­чи­ная с вер­сии 0.7 этой про­грам­мы, вы мо­же­те им­пор­ти­ро­вать ба­зы дан­ных F-Spot в Shotwell, вклю­чая пап­ки, тэ­ги и ранее сде­лан­ные ком­мен­та­рии. Для это­го пе­рей­ди­те в ме­ню Файл > Им­порт из F-Spot [File > Import from F-spot] и ука­жи­те, где хра­нят­ся ва­ши на­строй­ки F-Spot. По умол­чанию, это стан­дарт­ный путь в ва­шем до­машнем ка­та­ло­ге, но мож­но ука­зать и точ­ное ме­сто, что удоб­но, ес­ли вы соз­да­ли ре­зерв­ную ко­пию на­стро­ек.

Те фо­то­гра­фии, что на локаль­ном ком­пь­ю­те­ре, мож­но пе­ре­та­щить в фай­ло­вом менед­же­ре. Shotwell – ум­ный ин­ст­ру­мент, и, ре­шив им­пор­ти­ро­вать фо­то­гра­фии, вы мо­же­те ли­бо ско­пи­ро­вать фо­то­гра­фии се­бе в ка­та­лог биб­лио­те­ки, ли­бо про­сто соз­дать ссыл­ки на них, остав­ляя фай­лы на месте. По­следний ва­ри­ант по­ле­зен, ес­ли, на­при­мер, вы про­сто хо­ти­те до­ба­вить су­ще­ствую­щие фо­то­гра­фии из пап­ки Pictures в ба­зу дан­ных Shotwell.

Мет­ки и сор­ти­ров­ка

LXF138 59 2.jpg По­сле им­пор­та фо­тографий в Shotwell им по­тре­бу­ет­ся хо­ро­шая сор­ти­ров­ка. К сча­стью, ва­ри­ан­тов для это­го пол­но.

Те­перь ва­ши изо­бра­жения го­то­вы для дальней­шей об­ра­бот­ки. Во-пер­вых, на­зна­чим им несколь­ко тэ­гов (ме­ток), что оз­на­ча­ет соз­дание неко­то­рых ка­те­го­рий для ва­ших фо­то­гра­фий. Луч­ше ис­поль­зо­вать несколь­ко об­щих, опи­са­тель­ных тэ­гов, ко­то­рые по­зво­лят от­сор­ти­ро­вать фо­то­гра­фии по лю­дям, местам, со­бы­ти­ям или со­пут­ствую­щим об­стоя­тель­ствам и до­пуска­ют по­втор­ное ис­поль­зо­вание: ска­жем, Ма­ма, Лон­дон, День ро­ж­дения, Праздник – для фо­то со дня ро­ж­дения ма­мы во вре­мя по­езд­ки в Лон­дон. Что­бы до­ба­вить тэ­ги, щелкните пра­вой кноп­кой мы­ши на нуж­ной фо­то­гра­фии и вы­бе­ри­те До­ба­вить тэ­ги [Add Tags] или про­сто на­жми­те Ctrl+Т. Вве­ди­те свои ка­те­го­рии, раз­де­ляя их за­пя­ты­ми, а за­кон­чив, на­жми­те ОК.

По­том вы все­гда смо­же­те из­менить эти тэ­ги, щелк­нув пра­вой кноп­кой мы­ши на сним­ке и вы­брав Из­менить тэ­ги [Modify Tags]. Что­бы из­менить тэ­ги, свя­зан­ные с кон­крет­ной фо­то­гра­фи­ей, вы­бе­ри­те ее, за­тем Тэ­ги > Из­менить тэ­ги [Tags > Modify Tags], и от­ре­дак­ти­руй­те спи­сок, раз­де­лен­ный за­пя­ты­ми. Что­бы уда­лить тэг с од­ной или несколь­ких фо­то­гра­фий, сна­ча­ла вы­бе­ри­те его в бо­ко­вой панели, а за­тем ука­жи­те сним­ки, у ко­то­рых вы хо­ти­те его уда­лить, и на­жми­те Тэ­ги > Уда­лить тэг <имя> из фо­то­гра­фий [Tags > Remove Tag … From Photo].

Скорая помощь

Не­боль­шой трюк: за­пус­ти­те Shotwell ко­ман­дой shotwell -d /путь/к/пап­ке для на­зна­че­ния дру­го­го ме­сто­по­ло­же­ния биб­лио­те­ки. Кста­ти, бла­го­да­ря этой функ­ции вы мо­же­те иметь не­сколь­ко биб­лио­тек!

Ме­ню пра­вой кноп­ки мы­ши так­же по­зво­ля­ет вы­пол­нять неко­то­рые по­лез­ные дей­ствия, в том чис­ле соз­дание рей­тин­га фо­то­гра­фий, спе­ци­аль­ное на­звание фо­то и уве­ли­чение или от­кры­тие фо­то в фай­ло­вом менед­же­ре или ре­дак­то­ре.

В ме­ню Вид [View] вы най­де­те несколь­ко по­лез­ных ин­ст­ру­мен­тов, ко­то­рые от­ве­ча­ют за сор­ти­ров­ку фо­то­гра­фий и со­бы­тий. Мож­но сор­ти­ро­вать по на­званию, рей­тин­гу или вы­держ­ке, и да­же от­фильт­ро­вать фо­то­гра­фии с оп­ре­де­лен­ным рей­тин­гом. До­пустим, у вас дю­жи­на фо­то­гра­фий со дня ро­ж­дения, и лишь немно­гие из них дей­стви­тель­но вам нра­вят­ся, но осталь­ные вы­ки­ды­вать жал­ко. Тогда мож­но пре­доста­вить луч­шим фо­то пя­ти­звез­доч­ные рей­тин­ги – все про­чие оста­нут­ся в ва­шей биб­лио­те­ке, а с эк­ра­на вы их убе­ре­те че­рез Вид > Фильтр фо­то­гра­фии > Пять звезд [View > Filter Photos > Five Stars]. Ес­ли вы лю­би­те снаб­жать фо­то подпи­ся­ми, мож­но бу­дет от­сор­ти­ро­вать их в ал­фа­вит­ном по­ряд­ке. За­ме­тим, что это нико­им об­ра­зом не влия­ет на ре­аль­ные име­на фай­лов. Все, что вы вво­ди­те, не вы­хо­дит за рам­ки на­стро­ек Shotwell.

Ме­ж­ду раз­лич­ны­ми ва­ри­ан­та­ми про­смот­ра мож­но лег­ко пе­ре­клю­чать­ся, ис­поль­зуя ле­вую панель ин­тер­фей­са Shotwell. Кро­ме спи­ска под­клю­чен­ных ка­мер и дру­гих съем­ных уст­ройств, это де­ре­во име­ет ссыл­ки на все со­бы­тия, мет­ки и уда­лен­ные фо­то­гра­фии. Ес­ли вы ре­гу­ляр­но им­пор­ти­руе­те фо­то­гра­фии, вам, ве­ро­ят­но, по­ка­жет­ся по­лез­ной и ка­те­го­рия По­следние до­бав­лен­ные [Last Imported], по­сколь­ку это по­зво­ля­ет от­сле­жи­вать пре­ды­ду­щие им­пор­ти­ро­вания и уст­ра­нять дуб­ли­ро­ван­ные сним­ки.

Уст­ранение эф­фек­та крас­ных глаз

LXF138 60 1.jpg Ак­ку­рат­но при­ставь­те этот кру­жо­чек к мес­ту, и он лю­без­но уда­лит крас­ные гла­за.

Итак, ва­ши фо­то­гра­фии им­пор­ти­ро­ва­ны и систе­ма­ти­зи­ро­ва­ны, но пол­но­мо­чия Shotwell на этом не за­кан­чи­ва­ют­ся – он мо­жет так­же ре­шить ряд об­щих про­блем со сним­ка­ми. На­при­мер, на фо­то неред­ко по­лу­ча­ют­ся крас­ные гла­за, из-за от­ра­жения вспыш­ки от сет­чат­ки гла­за. И ко­му охо­та об­ра­щать­ся к сто­ронним при­ло­жениям для уст­ранения столь мел­ко­го де­фек­та? Да­вай­те-ка луч­ше ис­пра­вим его пря­мо в Shotwell!

Начните с двой­но­го щелч­ка на изо­бра­жении, а за­тем взгляни­те на ниж­нюю панель ин­ст­ру­мен­тов. Здесь есть несколь­ко кно­пок; най­ди­те сре­ди них Крас­ные гла­за [Red Eye] и щелкните по ней. На изо­бра­жении поя­вит­ся круг. Пе­ре­та­щи­те его на «крас­ные глаза» и на­строй­те ра­диус ок­руж­но­сти, по­ка он не рас­по­ло­жит­ся точ­но на крас­ной сет­чат­ке. На­жми­те кноп­ку При­менить [Apply], что­бы уб­рать урод­ли­вые крас­ные цве­та. По­вто­ри­те ту же по­сле­до­ва­тель­ность со вто­рым гла­зом.

Кор­рек­ция цве­тов

LXF138 60 2.jpg Экс­пе­ри­мен­ти­руй­те с бе­гун­ка­ми цве­тов, что­бы при­дать фо­то­гра­фии жи­вость.

Иногда тре­бу­ет­ся «по­иг­рать» с цве­та­ми ва­ше­го сним­ка или вы­держ­кой. Пусть у вас есть недо­дер­жан­ный и мут­ный снимок, ко­то­рый вы хо­ти­те улуч­шить в Shotwell. Опять же, два­ж­ды щелкните на изо­бра­жении, ко­то­рое ре­ши­ли из­менить, а за­тем на­жми­те кноп­ку ре­гу­ли­ров­ки на нижней панели. Вы уви­ди­те пла­ваю­щую панель в ком­плек­те с гисто­грам­мой и пол­зун­ка­ми. Пе­ре­та­щи­те пол­зу­нок Вы­держ­ка [Exposure], на­при­мер, впра­во, и из тем­но­ты нач­нут по­яв­лять­ся свет­лые об­ласти изо­бра­жения. Пе­ре­таски­вание пол­зун­ка На­сы­щен­ность [Saturation] впра­во сде­ла­ет цве­та изо­бра­жения яр­че. Не бой­тесь экс­пе­ри­мен­ти­ро­вать с От­тен­ком [Tint] и на­строй­ка­ми Тем­пе­ра­ту­ры [Temperature]. Пер­вый до­бав­ля­ет уси­ли­ваю­щие цвет эф­фек­ты, вно­ся фио­ле­то­вый от­те­нок при пе­ре­таски­вании впра­во и зе­ле­но­ва­тый – при пе­ре­таски­вании вле­во. Тем­пе­ра­ту­ра из­ме­ря­ет­ся в гра­ду­сах Кель­ви­на и по­зво­ля­ет сде­лать изо­бра­жение хо­лоднее (бо­лее го­лу­бо­ва­тым) или те­п­лее (жел­то­ва­тым), дви­гая пол­зун­ок вле­во или впра­во со­от­вет­ствен­но. У боль­шин­ства ка­мер есть оп­ции на­строй­ки цве­то­вой тем­пе­ра­ту­ры во вре­мя съем­ки, но всё рав­но бывает, что ва­ши сним­ки слиш­ком хо­лод­ны или те­п­лы – ком­пен­си­руй­те это, пе­ре­та­щив пол­зу­нок. Впро­чем, луч­шие ре­зуль­та­ты обычно да­ет уме­рен­ное ре­гу­ли­ро­вание, так что ста­рай­тесь из­бе­гать крайних по­зи­ций пол­зун­ка.

Об­ра­ти­те внимание, что в Shotwell мож­но так­же из­ме­нять Уровни изо­бра­жения [Levels]. Гисто­грам­ма в верхней части панели пред­став­ля­ет ре­гу­ли­ров­ки цве­то­во­го ох­ва­та ва­ше­го изо­бра­жения. Ес­ли вы счи­тае­те, что изо­бра­жение слиш­ком мут­ное или дым­ное, и на гисто­грам­ме есть бес­цвет­ные об­ласти по кра­ям, по­про­буй­те под­ви­гать сколь­зя­щие ог­раничи­те­ли, по­ме­щен­ные чуть ниже гисто­грам­мы. Сбли­жение их друг с дру­гом умень­ша­ет цве­то­вой ох­ват, а так­же помо­жет вам по­бо­роть этот дым­ный эф­фект.

Конеч­но, вы все­гда мо­же­те пе­рей­ти на бо­лее мощ­ный ре­дак­тор GIMP, ес­ли вы чув­ствуе­те та­кую необ­хо­ди­мость. GIMP – внешний ре­дак­тор для Shotwell по умол­чанию, и, та­ким об­ра­зом, вы мо­же­те щелк­нуть пра­вой кноп­кой мы­ши на фо­то­гра­фии, ко­то­рую ре­ши­ли из­менить, и вы­брать оп­цию От­крыть во внешнем ре­дак­то­ре [Open with external editor] для досту­па к пол­но­му функ­цио­на­лу об­ра­бот­ки изо­бра­жений. Ка­ж­дое из­менение, вно­си­мое в изо­бра­жение в GIMP (или лю­бом по­доб­ном при­ло­жении, так как в ме­ню Ре­дак­ти­ро­вать > На­строй­ки [Edit > Preferences] мож­но ука­зать и дру­гой ва­ри­ант) ав­то­ма­ти­че­ски от­ра­зит­ся в ва­шей биб­лио­те­ке Shotwell.

Кад­ри­ро­вание

LXF138 61 1.jpg Ис­поль­зуй­те пре­дус­та­нов­ки кад­ри­ро­ва­ния, что­бы иде­аль­но вме­стить ком­по­зи­цию в один из стан­дарт­ных раз­ме­ров фо­то­гра­фий.

Те­перь по­ра за­нять­ся ком­по­зи­ци­ей изо­бра­жения. Взгляните на снимок. Здесь основ­ной эле­мент – де­вуш­ка, а окру­жаю­щий ее ин­терь­ер не столь ва­жен. Мы мо­жем при­влечь вни­мание зри­те­ля к де­вуш­ке, кад­ри­ро­вав это изо­бра­жение. Для это­го сна­ча­ла на­жми­те кноп­ку Кад­ри­ро­вать [Crop] на панели ин­ст­ру­мен­тов под изо­бра­жением. Вы за­ме­ти­те, что по­верх изо­бра­жения поя­вил­ся по­лу­про­зрач­ный пря­мо­угольник. Пе­ре­та­щи­те его за края, что­бы по­лу­чить нуж­ную ком­по­зи­цию, ре­гу­ли­руя его раз­мер. Раз­мер и со­от­но­шение сто­рон пря­мо­угольника лег­ко из­менить пу­тем пе­ре­таски­вания его уг­лов. От­ме­тим, что, когда вы что-то сде­лае­те с этим пря­мо­угольником, он вир­ту­аль­но по­де­лит­ся на квад­ра­ты 3 × 3. Это де­ла­ет­ся не ра­ди кра­со­ты, а для по­мо­щи в бо­лее точ­ном соз­дании ком­по­зи­ции. На­при­мер, для при­вле­чения внимания к гла­зам де­вуш­ки мы долж­ны по­за­бо­тить­ся, что­бы они на­хо­ди­лись в верхней тре­ти изо­бра­жения.

Ес­ли вы хо­ти­те по­том на­пе­ча­тать фо­то­гра­фии на бу­ма­ге стан­дарт­но­го раз­ме­ра, вы мо­же­те убе­дить­ся, что кадр вы­шел удач­ным, пре­ж­де чем на­жи­мать Пе­чать [Print]. Панель ин­ст­ру­мен­тов кад­ри­ро­вания со­дер­жит вы­па­даю­щий спи­сок с ши­ро­ким диа­па­зо­ном пре­се­тов раз­ме­ра, и мож­но вы­би­рать из ва­ри­ан­тов от от­крыт­ки до стан­дарт­но­го пла­ка­та. Здесь мы взя­ли пре­сет 13 × 18.

Из­ба­вим­ся от теней

LXF138 61 2.jpg Слай­дер Тень вол­шеб­но улуч­шит ва­ши не в ме­ру су­мрач­ные сним­ки.

Снимать про­тив све­та – идея не очень хо­ро­шая. Иногда, од­на­ко, по­па­да­ют­ся сним­ки, где лю­ди сто­ят у ок­на, так что их ли­ца не вид­ны. Уве­ли­чение вы­держ­ки тут не по­мо­жет, но в Shotwell все же есть спо­соб ре­шить эту про­бле­му. Внут­ри пла­ваю­щей па­нели Ре­гу­ли­ров­ка [Adjust], ис­поль­зуй­те по­следний слай­дер – Тени [Shadows]. При пе­ре­таски­вании его впра­во изо­бра­жение посвет­леет, а кон­тра­ст­ность и свет­лые об­ласти оста­нут­ся на прежнем уровне. Дви­гай­те пол­зу­нок, по­ка ре­зуль­тат вас не уст­роит.

Вы мо­же­те сде­лать так мно­го кор­рек­ти­ро­вок изо­бра­жений, что на ка­ком-то эта­пе за­хо­чет­ся на­чать за­но­во. Пер­вое, что нуж­но знать – Shotwell под­дер­жи­ва­ет несколь­ко ша­гов функ­ции От­менить [Undo] и По­вто­рить [Redo]. Жми­те Ctrl+Z, что­бы от­менить по­следнее дей­ствие, и Ctrl+Shift+Z, что­бы вер­нуть его об­рат­но. Ес­ли вы хо­ти­те вер­нуть­ся к ис­ход­но­му изо­бра­жению, это то­же не про­бле­ма. Shotwell со­хра­ня­ет ис­ход­ные ва­ри­ан­ты фай­лов нетро­ну­ты­ми, и вы мо­же­те щелк­нуть пра­вой кноп­кой мы­ши на изо­бра­жении и вы­брать Вер­нуть­ся к ори­ги­на­лу [Revert to Original] для от­ка­та от­ре­дак­ти­ро­ван­ной вер­сии в ис­ход­ное со­стояние. Будь­те осто­рож­ны с этим, по­сколь­ку ника­ко­го пре­ду­пре­ж­дения не по­яв­ля­ет­ся, и все про­де­лан­ные до это­го из­менения бу­дут по­те­ря­ны без уве­дом­ления.

Со­циа­ли­зи­руй­тесь с Shotwell

Как толь­ко ва­ши сним­ки про­шли ре­дак­ти­ро­вание, по­че­му бы не по­де­лить­ся свои­ми дости­жения­ми с друзь­я­ми, кол­ле­га­ми или семь­ей? Ес­ли у вас есть учет­ная запись на Facebook, Flickr или Google, то за­гру­зить изо­бра­жения на эти сай­ты мож­но пря­мо из Shotwell. Ес­ли у вас есть учет­ная запись Google, но вы еще не поль­зо­ва­лись web-аль­бо­ма­ми Picasa, необ­хо­ди­мо по крайней ме­ре один раз вой­ти в Picasa из брау­зе­ра, и по­том мож­но бу­дет пуб­ли­ко­вать сним­ки и че­рез этот сер­вис. Од­на­ко для web-аль­бо­мов Picasa не го­дят­ся учет­ные запи­си с хостин­гом на Google, по той причине, что они обыч­но за­кан­чи­ва­ют­ся не на @gmail.com.

Кро­ме этих ого­во­рок, вам неза­чем под­клю­чать web-брау­зер и пе­ре­би­рать­ся в он­лайн-га­ле­рею или со­ци­аль­ные се­ти – все это де­ла­ет­ся из­нут­ри Shotwell. Вы­бе­ри­те од­но или несколь­ко изо­бра­жений, ко­то­рые вы хо­ти­те за­гру­зить, и пе­рей­ди­те в ме­ню Файл > Опуб­ли­ко­вать [File > Publish]. Поя­вит­ся диа­ло­го­вое ок­но с за­про­сом на вы­бор пунк­та на­зна­чения и ввод имени поль­зо­ва­те­ля и па­ро­ля. Вы­бе­ри­те сайт из вы­па­даю­ще­го спи­ска, на­жми­те кноп­ку Вой­ти [Login] – и вско­ре уви­ди­те, как страницы сай­та за­гру­жа­ют­ся пря­мо в те­ку­щем окне. Когда вы вой­де­те в систе­му, ва­ши изо­бра­жения бу­дут за­гру­же­ны, и вы мо­же­те сра­зу по­де­лить­ся ими – так, как вы хо­ти­те. По­ка Shotwell ра­бо­та­ет с тре­мя вышепе­ре­чис­лен­ны­ми сай­та­ми, но в бли­жай­шем бу­ду­щем ожи­да­ют­ся и другие ва­риан­ты.

Нуж­но от­ме­тить, что по­ка пи­са­лась эта ста­тья, в Shotwell бы­ла до­бав­ле­на функ­ция экс­пор­та изо­бра­жений в оте­че­ствен­ный фо­то­хостинг Ян­декс.Фот­ки. Ок­но экс­пор­та Shotwell по­зво­ля­ет ав­то­ри­зо­вать­ся на Ян­дек­се, соз­да­вать и из­ме­нять аль­бо­мы и за­гру­жать в них вы­бран­ные фо­то­гра­фии.

Ну вот, те­перь вы знае­те, как им­пор­ти­ро­вать ваши фо­то­гра­фии с циф­ро­вой ка­ме­ры, с кар­ты па­мя­ти или из пап­ки, кад­ри­ро­вать их, уст­ра­нять эф­фект крас­ных глаз, до­бав­лять тэ­ги и ис­поль­зо­вать их для сор­ти­ров­ки, управ­лять рей­тин­га­ми и при­ме­нять фильт­ры. Мы так­же об­су­ди­ли ре­шение об­щих про­блем цве­та и вы­яснили, что в Shotwell для улуч­шения фо­то тре­бу­ет­ся все­го несколь­ко щелч­ков мы­ши, но есть и бо­лее мощ­ные ин­ст­ру­мен­ты. Бо­лее то­го, Shotwell име­ет про­стой и ин­туи­тив­но по­нят­ный ин­ст­ру­мен­та­рий пуб­ли­ка­ции, ко­то­рый по­зво­лит ва­шим друзь­ям на­сла­дить­ся ва­ши­ми сним­ка­ми че­рез счи­тан­ные ми­ну­ты.

Не те­ряй­те фо­то!

По­сле ка­ж­до­го за­пус­ка Shotwell ска­ни­ру­ет биб­лио­те­ки фо­то­гра­фий для про­вер­ки, что все фо­то­фай­лы все еще су­ще­ст­ву­ют на же­ст­ком дис­ке. Ес­ли Shotwell об­на­ру­жит, что ка­кие-ли­бо фо­то­гра­фии от­сут­ст­ву­ют, он не бу­дет по­ка­зы­вать их в обыч­ных ви­дах Фо­то­гра­фий, Со­бы­тий и Ме­ток, а вы­не­сет в от­дель­ное ок­но Не­дос­таю­щие Фай­лы [Missing Files] в бо­ко­вой па­не­ли. Ес­ли вы боль­ше не хо­ти­те счи­тать от­сут­ст­вую­щие фай­лы ча­стью ва­шей кол­лек­ции Shotwell, про­сто пе­рей­ди­те к Не­дос­таю­щим фай­лам, вы­бе­ри­те фо­то­гра­фии, а за­тем на­жми­те кноп­ку Уда­лить из биб­лио­те­ки [Remove From Library]. Ес­ли от­сут­ст­вую­щие фай­лы сно­ва ста­нут дос­туп­ны, Shotwell за­ме­тит это при оче­ред­ном за­пус­ке – они опять поя­вят­ся в Фо­то­гра­фи­ях, Со­бы­ти­ях и Мет­ках.

Персональные инструменты
купить
подписаться
Яндекс.Метрика