Журнал LinuxFormat - перейти на главную

LXF137:VideoDVD

Материал из Linuxformat
Перейти к: навигация, поиск
QDVDAuthor При­ме­ним мощь Linux к соз­да­нию эле­гант­ных ме­ню для ви­део-DVD

Содержание

QDVDAuthor: Про­жжем фильм!

Ша­шанк Шар­ма ис­поль­зу­ет QDVDAuthor для про­фес­сио­наль­ной за­пи­си на DVD ви­део­кли­пов с ме­ню и дру­ги­ми при­бам­ба­са­ми.

По­шарь­те на сво­ем же­ст­ком диске, и вы тут же об­на­ру­жи­те ви­део­запи­си с недавней ве­че­рин­ки или от­пуска, до ко­то­рых ру­ки у вас по­ка не дош­ли. Что вы обыч­но де­лае­те с та­ки­ми ве­ща­ми? Ско­рее все­го, пи­ше­те их на обыч­ный диск, что­бы по­де­лить­ся с друзь­я­ми. Но не кру­че ли из­го­то­вить из них хо­ро­ший фильм на DVD? С QDVDAuthor вы мо­же­те соз­да­вать ме­ню и под­ме­ню, че­рез ко­то­рые ваш DVD по­зво­лит вы­брать ви­део для про­смот­ра.

Как и мно­гие дру­гие про­грам­мы та­ко­го ро­да, QDVDAuthor по­ла­га­ет­ся на мно­же­ство раз­лич­ных ин­ст­ру­мен­тов для вы­полнения сво­его ог­ром­но­го на­бо­ра функ­ций. К сча­стью, боль­шин­ство из них най­дут­ся в ре­по­зи­то­ри­ях боль­шин­ства ди­ст­ри­бу­ти­вов.

Уста­нов­ка QDVDAuthor

LXF137 63 1.jpg Ко­ман­да ./configure -c вы­зы­ва­ет гра­фи­че­ский ин­стал­ля­тор. Что, ко­неч­но, ко­щун­ст­во для фа­на­тов ./configure.

Из-за мно­же­ства тре­бо­ваний, луч­ше все­го, ве­ро­ят­но, уста­но­вить QDVDAuthor че­рез ваш менед­жер па­ке­тов. Поль­зо­ва­те­ли Ubuntu мо­гут за­пустить коман­ду

sudo apt-get install qdvdauthor

и смот­реть, как apt-get ли­хо за­гру­жа­ет и уста­нав­ли­ва­ет все необ­хо­ди­мые за­ви­си­мо­сти: DVDAuthor, FFmpeg, Transcode, MPlayer и мно­гие дру­гие. Из них DVDAuthor, ве­ро­ят­но, са­мый важ­ный, по­то­му что QDVDAuthor – гра­фи­че­ский ин­тер­фейс к нему. Поль­зо­ва­те­лям Fedora, рас­счи­ты­ваю­щим на го­то­вые дво­ич­ные фай­лы, при­дет­ся по­ла­гать­ся на сто­ронние ре­по­зи­то­рии для Fedora, та­кие как RPMFind. Од­на­ко по­следние RPM-па­ке­ты, ка­кие мне уда­лось най­ти, бы­ли для Fedora 12.

Ес­ли вы пред­по­чи­тае­те ком­пи­ли­ро­вать QDVDAuthor са­мо­стоя­тель­но, пе­рей­ди­те на сайт про­ек­та и ска­чай­те по­следний ар­хив. Про­чи­тай­те фай­лы README и INSTALL, что­бы вы­явить его за­ви­си­мо­сти. Уста­но­вив все эти за­ви­си­мо­сти, за­пусти­те про­грам­му уста­нов­ки из тер­ми­на­ла с по­мо­щью коман­ды

./configure -c

На­строй­ка QDVDAuthor

LXF137 60 1.jpg Диа­ло­го­вое ок­но Resize пред­ла­га­ет мно­го ва­ри­ан­тов для фор­ма­тов PAL и NTSC. Мож­но так­же до­ба­вить чер­ные рам­ки.

По­сле уста­нов­ки вы най­де­те QDVDAuthor в ме­ню При­ло­жения > Звук и ви­део в Gnome. При пер­вом за­пуске QDVDAuthor вы­бе­ри­те До­полнитель­но > На­строй­ка [Tools > Setup]. QDVDAuthor со­об­щит вам о фай­лах пе­ре­хо­дов и пред­ло­жит вам ска­чать их сей­час, ес­ли вы это­го еще не сде­ла­ли. Вы мо­же­те иг­но­ри­ро­вать это со­об­щение или ска­чать фай­лы, как пред­ла­га­ет­ся. На­жми­те кноп­ку ОК в ниж-ней части пре­ду­пре­ж­дения и пе­рей­ди­те на вклад­ку Пу­ти [Paths] в верхней части ок­на на­стро­ек.

Здесь вы уви­ди­те спи­сок ин­ст­ру­мен­тов, необ­хо­ди­мых QDVDAuthor. Ес­ли у вас не уста­нов­лен ка­кой-ли­бо из тре­буе­мых ин­ст­ру­мен­тов, мож­но сде­лать это пря­мо сей­час. Вы мо­же­те на­жать на кноп­ку Ин­фо [Info] спра­ва от на­звания и уз­нать, что де­ла­ет ин­ст­ру­мент и яв­ля­ет­ся ли он обя­за­тель­ным.

Щелкните на вклад­ке Глав­ное [General], что­бы за­полнить кри­ти­че­ские све­дения о кон­фи­гу­ра­ции: где рас­по­ло­жить вре­мен­ный ка­та­лог, когда уда­лять вре­мен­ные фай­лы и т. д. По умол­чанию вре­мен­ные фай­лы хра­нят­ся 30 дней, но вы мо­же­те за­хо­теть со­кра­тить этот срок до неде­ли или мень­ше, осо­бен­но ес­ли до­ро­жи­те диско­вым про­стран­ством. Оп­ре­де­ляя раз­лич­ные ка­та­ло­ги, имей­те в ви­ду, что соз­дание DVD весь­ма ре­сур­со­ем­ко – и с точ­ки зрения про­цес­со­ра и па­мя­ти, и с точ­ки зрения сво­бод­но­го места на диске.

Для на­ча­ла вы­бе­ри­те в ме­ню Файл > Но­вый про­ект [File > New Project]. Мастер соз­дания но­во­го про­ек­та про­ве­дет вас че­рез сле­дую­щие несколь­ко ша­гов, по­про­сив ука­зать вре­мен­ный ка­та­лог и имя ди­рек­то­рии, где бу­дут со­хранены окон­ча­тель­ные фай­лы DVD. Это по­лез­но, ес­ли вы хо­ти­те ис­поль­зо­вать для про­ек­та не тот ка­та­лог, ко­то­рый ука­зан в гло­баль­ных на­строй­ках. Пре­ж­де чем про­дол­жить, вы­бе­ри­те Файл > Со­хранить про­ект [File > Save Project] и вы­пол­няй­те это дей­ствие че­рез ре­гу­ляр­ные про­ме­жут­ки вре­мени, в идеа­ле – по­сле ка­ж­до­го ша­га.

Начнем с до­бав­ления фо­но­во­го изо­бра­жения для на­ше­го ме­ню. На­жми­те на кноп­ку До­ба­вить фон [Add Background] на панели ин­ст­ру­мен­тов. Пе­рей­ди­те в ка­та­лог, со­дер­жа­щий изо­бра­жение, ко­то­рое вы хо­ти­те ис­поль­зо­вать, и вы­бе­ри­те его. Ес­ли фор­мат изо­бра­жения не под­дер­жи­ва­ет­ся или оно слиш­ком ве­ли­ко, QDVDAuthor со­об­щит вам об этом и от­кро­ет диа­лог Из­менить раз­мер [Resize]. Ва­ри­ант по умол­чанию – NTSC 720 × 480, он уст­ро­ит мно­гих. Ес­ли у вас ши­ро­ко­эк­ран­ный те­ле­ви­зор или монитор, мож­но так­же из­менить про­пор­ции кад­ра с 4:3 по умол­чанию на 16:9, ис­поль­зуя вы­па­даю­щее ме­ню Со­от­ношение сто­рон [Aspect] в пра­вом верхнем уг­лу диа­ло­го­во­го ок­на Из­менить раз­мер. За­кон­чив, на­жми­те кноп­ку ОК в нижней части, и ва­ше изо­бра­жение бу­дет из­менено.

Ин­тер­фейс QDVDAuthor раз­де­лен на две об­ласти. Сле­ва на­хо­дит­ся бо­ко­вая панель, и в ней, на вклад­ке Струк­ту­ра [Structure], вы за­ме­ти­те но­вый эле­мент: Фон под глав­ным ме­ню [Background Under Main Menu].

Ме­ню DVD не бу­дет пол­ным без со­про­во­ж­даю­щей фо­но­вой му­зы­ки. На­жми­те на кноп­ку До­ба­вить ау­дио [Add Audio] ря­дом с кноп­кой До­ба­вить фон на панели ин­ст­ру­мен­тов, что­бы до­ба­вить свои лю­би­мые ком­по­зи­ции для воспро­из­ве­дения вме­сте с ме­ню. Ес­ли дли­тель­ность вы­бран­ной для фо­на песни боль­ше, чем ука­зан­ный пе­ри­од вре­мени вы­во­да ме­ню, QDVDAuthor немед­лен­но пре­ду­пре­дит вас, а так­же спро­сит, не хо­ти­те ли вы из­менить дли­тель­ность. Пе­рей­ди­те на вклад­ку Гео­мет­рия [Geometry] в диа­ло­го­вом окне и из­мените зна­чение За­кон­чить в [Ending At] со­глас­но длине тре­ка. По за­вер­шении на­жми­те кноп­ку При­менить [Accept] в нижнем пра­вом уг­лу диа­ло­го­во­го ок­на.

До­бав­ление кно­пок в ме­ню

LXF137 61 1.jpg Мы лю­бим VLC. Функ­ция сним­ка пре­вос­ход­на — она из­ба­вит вас от за­трат вре­ме­ни на ко­вы­ря­ние с GIMP.

Те­перь на вклад­ке Струк­ту­ра в ле­вой бо­ко­вой панели глав­но­го ин­тер­фей­са QDVDAuthor, кро­ме фо­но­во­го изо­бра­жения, бу­дет так­же ото­бра­жать­ся зву­ко­вой файл. Сле­дую­щий шаг – соз­дание кноп­ки в ме­ню. Кноп­ки мо­гут быть тек­сто­вы­ми объ­ек­та­ми, или мож­но ис­поль­зо­вать изо­бра­жения. При при­ня­тии ре­шения о ти­пе кноп­ки сле­ду­ет так­же иметь в ви­ду, бу­дет ли кноп­ка глав­но­го ме­ню бу­дет ука­зы­вать на ви­део­клип или под­ме­ню. На­при­мер, ес­ли у вас есть че­ты­ре кли­па с дня ро­ж­дения дру­га и два ви­део в тре­на­жер­ном за­ле, вы мо­же­те соз­дать две кноп­ки в глав­ном ме­ню, на­звав их День Ро­ж­дения и Тре­на­жер­ный зал, со­от­вет­ствен­но, и на­жа­тие на лю­бую из них от­кро­ет пра­виль­ное под­ме­ню, в ко­то­ром бу­дут пе­ре­чис­ле­ны все кли­пы. Да­лее мы по­го­во­рим об этом под­робнее.

Что­бы до­ба­вить к ме­ню тек­сто­вую кноп­ку, щелкните пра­вой кноп­кой мы­ши на фо­но­вом изо­бра­жении в основ­ной части ин­тер­фей­са QDVDAuthor и вы­бе­ри­те До­ба­вить текст [Add Text]. Те­перь на­ри­суй­те пря­мо­угольник раз­ме­ром с пред­по­ла­гае­мую кноп­ку на фо­но­вом изо­бра­жении. Поя­вит­ся диа­ло­го­вое ок­но Текст и Шрифт [Text and Font], где мож­но вве­сти текст для кноп­ки, а так­же ука­зать шрифт, цвет, раз­мер, вы­равнивание тек­ста и так да­лее. За­кон­чив, на­жми­те кноп­ку ОК внизу. По­вто­ри­те эти дей­ствия для тре­буе­мо­го ко­ли­че­ства кно­пок ва­ше­го ме­ню, тща­тель­но вы­би­рая по­ло­жение кноп­ки на фоне.

Вознамерившись соз­дать под­ме­ню, на­жми­те DVDAuthor > До­ба­вить Ме­ню [Add Menu]. Вы уви­ди­те пустое ме­ню, на­зы­вае­мое Под­ме­ню1 [Submenu1], по­хо­жее на на­чаль­ное ме­ню. Для это­го под­ме­ню по­вто­ри­те все пре­ды­ду­щие ша­ги – до­ба­вить фон, звук и кноп­ки.

При же­лании ис­поль­зо­вать вме­сто тек­сто­вых кно­пок ри­сун­ки, щелкните пра­вой кноп­кой мы­ши на фоне и на­жми­те кноп­ку До­ба­вить кар­тин­ку [Add Image]. На­ри­суй­те на фоне пря­мо­угольник, а за­тем вы­бе­ри­те файл изо­бра­жения. По ме­ре ва­ше­го ри­со­вания пря­мо­угольника мы­шью, QDVDAuthor бу­дет ото­бра­жать его раз­ме­ры, и вы смо­же­те по­дог­нать их точ­но по сво­ему вку­су. Когда вы ука­же­те изо­бра­жение, оно бу­дет ав­то­ма­ти­че­ски по­дог­на­но к пря­мо­угольнику.

Ес­ли у вас уста­нов­лен VLC, с его по­мо­щью мож­но за­хва­ты­вать кад­ры из ви­део­фай­ла и ис­поль­зо­вать их в ка­че­стве кно­пок. На­жми­те Ви­део > Снимок на VLC [Video > Snapshot on VLC], и кадр бу­дет со­хранен в фай­ле под на­званием snapshot.png в ка­та­ло­ге ~/.local/share.

До­ба­вим ис­точ­ни­ки ви­део

LXF137 61 2.jpg При до­бав­ле­нии ви­део че­рез диа­ло­го­вое ок­но Фай­лы дан­ных мож­но ука­зать раз­мер ми­ниа­тю­ры..

Мы, на­конец, го­то­вы по­ве­дать QDVDAuthor о на­ших ви­део­кли­пах. Щелкните вклад­ку Все ис­ходники [All Sources] на ле­вой бо­ко­вой панели, а за­тем на­жми­те кноп­ку До­ба­вить несколь­ко ви­део [Add/Organise Videos] внизу. Восполь­зуй­тесь ле­вой бо­ко­вой панелью диа­ло­го­во­го ок­на Вы­брать/сор­ти­ро­вать/груп­пи­ро­вать фай­лы ма­те­риа­ла [Select/Sort/Group Source Files] для пе­ре­хо­да в ка­та­лог кли­пов. Те­перь на­жми­те на вклад­ке Груп­пы [Groups] ввер­ху на ле­вой бо­ко­вой панели в диа­ло­го­вом окне Фай­лы дан­ных [Source Files] и пе­ре­та­щи­те ви­део из пра­вой в ле­вую бо­ко­вую панель. По­вто­ри­те эти дей­ствия для всех кли­пов, ко­то­рые вы хо­ти­те до­ба­вить. Ре­ко­мен­ду­ем со­хра­нять про­ект по­сле до­бав­ления ка­ж­до­го ви­део­кли­па.

Скорая помощь

Да­же ес­ли QDVDAuthor за­вис­нет, не впа­дай­те в па­ни­ку. У не­го до­воль­но боль­шой опыт по час­ти вос­ста­нов­ле­ния фай­лов.

Хо­ро­шим то­ном бу­дет пре­ду­смот­реть в под­ме­ню кноп­ку воз­вра­та в глав­ное ме­ню.

До­ба­вив все ви­део­кли­пы, на­жми­те на кноп­ку Пе­ре­име­но­вать [Rename] на ле­вой бо­ко­вой панели и вве­ди­те имя. Мы ис­поль­зу­ем ви­део­кли­пы лек­ций по ав­тор­ско­му пра­ву, часть кур­са OpenCourseWare Мас­са­чу­сет­ско­го тех­но­ло­ги­че­ско­го ин­сти­ту­та, по­это­му на­зва­ли груп­пу Copyright Videos. По это­му на­званию груп­пы мы бу­дем вы­бирать ви­део­фай­лы для при­вя­зы­вания их к кноп­кам на­ше­го ме­ню. За­кон­чив, на­жми­те кноп­ку ОК в пра­вом нижнем уг­лу.

Че­рез глав­ный ин­тер­фейс QDVDAuthor мож­но так­же до­ба­вить ви­део, на­жав вклад­ку Ви­део [Video] на бо­ко­вой панели сле­ва и вы­брав пункт До­ба­вить несколь­ко ви­део. При этом то­же от­кро­ет­ся диа­ло­го­вое ок­но Фай­лы дан­ных, но в на­ших тестах все по­пыт­ки до­ба­вить ви­део при­ве­ли к сбою QDVDAuthor. Ес­ли де­лать те же опе­ра­ции из вклад­ки Все ис­ходники, про­блем они не вы­зо­вут.

LXF137 62 2.jpg Про­кру­ти­те по го­ри­зон­та­ли вклад­ку Все ис­точ­ни­ки, и QDVDAuthor вы­даст вам та­кие де­та­ли, как раз­мер/дли­на фай­ла.

Пре­ж­де чем до­ба­вить ви­део на DVD, его мож­но про­ве­рить. Вы­бе­ри­те ви­део из спи­ска и на­жми­те кноп­ку Воспр. [Play]. QDVDAuthor при­менит для воспро­из­ве­дения фай­лов ас­со­ции­ро­ван­ный плей­ер (по умол­чанию – Qplayer). Это га­ран­ти­ру­ет, что вы слу­чай­но не до­ба­ви­те в груп­пу файл, ко­то­рый не со­би­ра­лись по­ме­щать на DVD.

Кноп­ки > Ви­део

Нам оста­лось свя­зать на­ши кноп­ки с ви­део. Для это­го щелкните пра­вой кноп­кой мы­ши по кноп­ке на фо­но­вом изо­бра­жении и на­жми­те Оп­ре­де­лить кноп­ку [Define Button]. В диа­ло­го­вом окне Кноп­ка [Button Dialog] при­вя­жем кноп­ки к ви­део­кли­пу.

Оп­ре­де­ли­те дей­ствие как Пе­ре­ход [Jump]. Вы най­де­те на­звание груп­пы, ку­да вы до­ба­ви­ли ви­део, во вто­ром раскры­ваю­щем­ся спи­ске. Вы­бе­ри­те Copyright Videos или лю­бое дру­гое имя, ко­то­рое вы да­ли ви­део груп­пы, и поя­вит­ся тре­тий раскры­ваю­щий­ся спи­сок, из ко­то­ро­го мож­но вы­брать ви­део­файл, ко­то­рый вы хо­ти­те ас­со­ции­ро­вать с кноп­кой. Ес­ли вы соз­да­ли под­ме­ню, вы долж­ны про­де­лать опи­сан­ные вы­ше ша­ги, что­бы свя­зать кноп­ки в глав­ном ме­ню с под­ме­ню, а за­тем кноп­ки под­ме­ню – с ви­део.

Об­ра­ти­те внимание на кноп­ку Несколь­ко фай­лов [Multiple Files] диа­ло­го­во­го ок­на Кноп­ка. На­жми­те на нее, ес­ли вы хо­ти­те, что­бы од­на кноп­ка про­иг­ры­ва­ла несколь­ко фай­лов в цик­ле (вспомните Воспро­из­ве­сти все на боль­шин­стве DVD-ви­део). На­жа­тие на кноп­ку Несколь­ко фай­лов вы­зо­вет диа­ло­го­вое ок­но Вы­брать ви­део фай­лы [Select Video Sources]. Сле­ва поя­вит­ся спи­сок доступ­ныхви­део­фай­лов. Вы­бе­ри­те те, что вы хо­ти­те до­ба­вить, и на­жми­те на кноп­ку До­ба­вить [Add] в се­ре­дине. По­ря­док фай­лов, по­ка­зан­ных спра­ва, мож­но из­менить, на­жав на файл, а за­тем на кноп­ки со стрел­ка­ми вверх или вниз, что­бы пе­ре­местить его. И, на­конец, в нижней части диа­ло­го­во­го ок­на вы­бе­ри­те пункт Глав­ное ме­ню [Main Menu] в раскры­ваю­щем­ся спи­ске Конеч­ное ме­сто на­зна­чения [Final Destination]. Это вернет вас в глав­ное ме­ню, когда все фай­лы в спи­ске бу­дут про­иг­ра­ны. За­кон­чив, на­жми­те кноп­ку ОК.

Эф­фек­ты пе­ре­хо­да

Помните пре­ду­пре­ж­дение об эф­фек­тах пе­ре­хо­да, когда вы про­смат­ри­ва­ли диа­лог До­полнитель­но > На­строй­ка в на­ча­ле? А те­перь вы мо­же­те до­ба­вить к кноп­кам эф­фек­ты, оп­ре­де­ляю­щие, что про­ис­хо­дит в про­ме­жут­ке ме­ж­ду на­жа­ти­ем кноп­ки и на­ча­лом воспро­из­ве­дения ви­део.

На диа­ло­го­вом окне кноп­ки, по­сле при­вяз­ки ее к ви­део, на­жми­те кноп­ку До­ба­вить пе­ре­ход [Add Transition]. QDVDAuthor вы­даст ошиб­ку, ес­ли эф­фек­ты пе­ре­хо­да не уста­нов­ле­ны. Что­бы уста­но­вить пе­ре­хо­ды, от­крой­те ок­но тер­ми­на­ла и вве­ди­те:

wget http://qdvdauthor.sourceforge.net/data/alpha_trans.tar.bz2

Эта ко­ман­да ска­ча­ет фай­лы пе­ре­хо­дов в ваш в ра­бо­чий ка­та­лог. Нуж­но ус­та­но­вить их в /usr/share/qdvdauthor, по­это­му на­бе­ри­те

cd /usr/share/qdvdauthor;sudo tar xjf /home/linuxlala/Downloads/alpha_trans.tar.bz2

Пред­по­ла­га­ет­ся, что вы ска­ча­ли файл пе­ре­хо­дов в стан­дарт­ную ди­рек­то­рию За­груз­ки в ва­шем до­машнем ка­та­ло­ге. Ес­ли вы сде­ла­ли это в дру­гом месте, со­от­вет­ствен­но из­мените путь в коман­де.

Те­перь вернитесь в диа­ло­го­вое ок­но кно­пок в QDVDAuthor и на­жми­те на До­ба­вить пе­ре­хо­ды [Add Transitions]. Вы уви­ди­те две ка­те­го­рии пе­ре­хо­дов – яр­кость и аль­фа. Пе­ре­клю­чать­ся ме­ж­ду ними мож­но при по­мо­щи вклад­ки в верхней части ок­на Кноп­ка пе­ре­хо­да [Button Transition Dialog]. Вы­бе­ри­те эф­фект, ко­то­рый хо­ти­те при­менить, а за­тем на­жми­те кноп­ку Анима­ция [Anim] в крайней пра­вой части диа­ло­го­во­го ок­на для его пред­про­смот­ра. В диа­ло­го­вом окне кноп­ки бу­дет ото­бра­жать­ся те­ку­щая кон­фи­гу­ра­ция кноп­ки, ря­дом с кноп­кой Несколь­ко фай­лов. В на­шем слу­чае ото­бра­жа­ют­ся Пе­ре­ход, 1 сек, Про­иг­рать 3, в ме­ню. Это оз­на­ча­ет, что эф­фект пе­ре­хо­да у этой кноп­ки есть, про­иг­ры­ва­ют­ся три фай­ла, и по окон­чании по­следнего фай­ла мы воз­вра­ща­ем­ся в глав­ное ме­ню.

Соз­да­дим DVD

LXF137 62 1.jpg На­жми­те кноп­ку спра­ва от пе­ре­чис­лен­ных ко­манд, что­бы уз­нать боль­ше об ис­поль­зуе­мых ин­ст­ру­мен­тах.

По­следний шаг про­цес­са – соз­дание DVD. Вы мо­же­те сде­лать это сей­час, на­жав на кноп­ку Соз­дать DVD [Create DVD] на панели ин­ст­ру­мен­тов. Возникнет при­чуд­ли­во раскра­шен­ное диа­ло­го­вое ок­но со мно­же­ством раз­де­лов, под­раз­де­лов и команд. Не вол­нуй­тесь, это не со­об­щение об ошиб­ке.

Вгля­дев­шись, вы уви­ди­те, что раз­лич­ные раз­де­лы в диа­ло­го­вом окне по­свя­ще­ны раз­лич­ным эта­пам про­цес­са соз­дания DVD, та­ким как пре­об­ра­зо­вание ви­део- и ау­дио­фай­лов. Это про­сто да­ет вам ин­фор­ма­цию о транско­ди­ро­вании, ко­то­рое сей­час начнет­ся для кон­вер­ти­ро­вания ау­дио- и ви­део­фай­лов в фор­мат DVD. По­следний ва­ри­ант в спи­ске – запись DVD. Эта воз­мож­ность по­ка еще экс­пе­ри­мен­таль­ная, по­это­му она не ак­ти­ви­ро­ва­на по умол­чанию. Для про­жи­га DVD луч­ше все­го ис­поль­зо­вать стан­дарт­ный ин­ст­ру­мент, на­при­мер, K3b.

Оставь­те все осталь­ные оп­ции в спи­ске как есть, за­тем на­жми­те на кноп­ку ОК в пра­вом нижнем уг­лу диа­ло­го­во­го ок­на Оче­ре­ди команд [Command Queue]. QDVDAuthor начнет соз­да­вать диск. На боль­шин­стве систем (да­же доста­точ­но бы­ст­рых) этот шаг по­тре­бу­ет вре­мени, по­сколь­ку пре­об­ра­зо­вание ви­део яв­ля­ет­ся мед­лен­ным про­цес­сом.

В диа­ло­го­вом окне Вы­полнение [Execution Dialog] на­жми­те фла­жок Дер­жать от­кры­тым [Keep Open] сле­ва внизу, ес­ли не хо­ти­те, что­бы ок­но за­кры­лось ав­то­ма­ти­че­ски. Когда QDVDAuthor соз­даст диск, мож­но на­жать Ана­лиз ло­га [Analyze log], что­бы уви­деть, не бы­ло ли оши­бок в хо­де про­цес­са.

Про­иг­рать пе­ред запи­сью

Луч­ше, на­вер­ное, про­ве­рить толь­ко что соз­дан­ный DVD, пре­ж­де чем запи­сы­вать его на диск, так что от­крой­те менед­жер фай­лов и пе­рей­ди­те в ка­та­лог, ука­зан­ный в ка­че­стве конеч­но­го пунк­та на­зна­чения для DVD. Вы уви­ди­те, что он те­перь со­дер­жит две вло­жен­ных ди­рек­то­рии – AUDIO_TS и VIDEO_TS. От­крой­те VLC или ваш лю­би­мый ме­диа-плей­ер, пе­ре­та­щи­те в него VIDEO_TS ка­та­лог и на­сла­ж­дай­тесь.

Это труд­но под­да­ет­ся объ­яснению, но ме­ню без фо­но­вой му­зы­ки по­хо­же на пиц­цу без на­чин­ки – ниче­го хо­ро­ше­го. Но про­сто до­ба­вить му­зыкаль­ный файл в ме­ню нель­зя – как пра­ви­ло, вы про­во­ди­те в ме­ню не бо­лее несколь­ких се­кунд. И ка­кой смысл до­бав­лять че­ты­рех­ми­нут­ный трек?

Об­ра­ти­тесь к Sox (LXF121): этот ин­ст­ру­мент команд­ной стро­ки – пря­мо-та­ки швей­цар­ский ар­мей­ский нож по ра­бо­те со зву­ком. Он вы­ре­жет части зву­ко­вой до­рож­ки и вста­вит их как фон. В по­став­ке боль­шин­ства ди­ст­ри­бу­ти­вов Sox уже уста­нов­лен, но его с той же лег­ко­стью мож­но до­ба­вить из ре­по­зи­то­ри­ев. В неко­то­рых ди­ст­ри­бу­ти­вах Sox не под­дер­жи­ва­ет MP3 «из ко­роб­ки».

Ес­ли вам нуж­на под­держ­ка MP3, Sox луч­ше со­брать вруч­ную. Ар­хив возь­ми­те с до­машней страницы про­ек­та; но пре­ж­де чем со­брать и уста­но­вить его, уста­но­ви­те libmad и Lame и их па­ке­ты для раз­ра­бот­чи­ков. Они долж­ны быть доступ­ны в ре­по­зи­то­рии ва­ше­го ди­ст­ри­бу­ти­ва. Те­перь, со­брав и уста­но­вив Sox с по­мо­щью ./configure, make и make install, вы так­же по­лу­чи­те под­держ­ку MP3.

Ес­ли Sox у вас уже уста­нов­лен, уда­ли­те его и уста­но­ви­те вруч­ную. Для уда­ления лю­бой части ау­дио­фай­ла ис­поль­зуй­те функ­цию trim коман­ды sox. Она по­лез­на, когда нуж­но уда­лить уча­ст­ки ау­дио без зву­ка в на­ча­ле или кон­це тре­ка, а на­ша цель сей­час – вы­ре­зать ку­сок из лю­би­мой песни, что­бы ис­поль­зо­вать его для на­ше­го ме­ню. Функ­ция trim принима­ет два зна­чения – start и length. Start, по­нят­ное де­ло, оз­на­ча­ет на­чаль­ную точ­ку, а length – дли­тель­ность фай­ла (не по­зи­цию в тре­ке!). Оба зна­чения да­ют­ся в се­кун­дах. Пред­по­ло­жим, вы хо­ти­те соз­дать но­вый файл толь­ко из пер­вых 20 се­кунд. sox musicfile.wav new.wav trim 0 20 соз­даст файл new.wav – 20‑се­кунд­ный от­ры­вок из musicfile.wav. Ноль – это на­ча­ло, а 20 – дли­тель­ность. Ана­ло­гич­но, ес­ли вы хо­ти­те уда­лить пер­вые 20 се­кунд фай­ла и со­хранить осталь­ное, ис­поль­зуй­те ко­ман­ду sox musicfile.wav newfile.wav 20 140. Здесь 20 яв­ля­ет­ся на­чаль­ной точ­кой, а 140 – ис­ход­ной дли­ной ми­нус пер­вые 20 се­кунд. По­доб­ным об­ра­зом соз­да­ет­ся и файл, со­дер­жа­щий 25 се­кунд где-то по­сре­ди тре­ка.

Персональные инструменты
купить
подписаться
Яндекс.Метрика