Журнал LinuxFormat - перейти на главную

LXF133:School1

Материал из Linuxformat
Перейти к: навигация, поиск
Школа LXF Обмен опытом и передовые идеи по использованию свободного ПО в образовании
Спонсор рубрики PingWin Software!

Содержание

Linux + Литература = Любовь?

Физики и лирики – союз возможен! Александр Бикмеев покажет, что можно взять из мира свободного ПО в мир высокого искусства.

Уверен, большинство читателей журнала хорошо представляет себе, что такое компьютер и как использовать его для решения своих задач. Но задумывались ли вы, чем видится компьютер с точки зрения людей, профессионально занимающихся, например, литературой? А именно, с точки зрения среднестатистического учителя литературы?

Мой опыт общения показывает, что ситуация такова: подавляющее большинство гуманитариев прекрасно понимает, что такое компьютер, и отлично работает в текстовых редакторах/процессорах, а также в средах подготовки презентаций; однако мало кто из них знает о наличии других инструментов и тем более другой операционной системы. Стандартный ответ на во прос об используемых приложениях звучит примерно так: «Нам вполне хватает Word и Powerpoint, но если вы что-то покажете, то мы с удовольствием посмотрим». В данной статье я постараюсь описать те инструменты, которые могут помочь преподавателям и их ученикам/студентам на занятиях в рамках дисциплины «литература».

Сочинение по карте

Рис. 1 Рис. 1. Freemind с интеллект-картой плана сочинения.

Первое, что приходит в голову, когда вспоминаешь об уроках литературы – это сочинения. А как же написать сочинение, не имея его плана?! Если подумать, то план сочинения весьма напоминает интеллект-карту, для создания и редактирования которой можно использовать свободный кросс-платформенный инструмент Freemind (http://freemind.sf.net). Окно приложения показано на рис. 1.

Сразу после запуска или при создании новой карты, в рабочей области присутствует всего один элемент – центральный узел, выражающий основную идею. В нашем случае это может быть просто тема сочинения. Чтобы ввести текст, достаточно щелкнуть на узле левой кнопкой мыши и начать ввод. Определившись с темой, можно переходить к проработке структуры сочинения, другими словами, к созданию дочерних узлов.

Для создания дочернего узла необходимо либо нажать на клавиатуре клавишу Insert, либо щелкнуть на родительском узле правой кнопкой мыши и в появившемся меню выбрать пункт Новый подчиненный узел. Далее необходимо просто определить текст узла.

Скорая помощь

Для создания текста в несколько строк, щелкните правой кнопкой мыши на узле и выберите пункт Изменить текст в редакторе. Согласитесь использовать форматирование. Далее работайте с текстом как обычно.

По умолчанию второй дочерний узел добавляется справа. Чтобы добавить узел рядом с имеющимся, просто выделите его и нажмите Enter. Новый дочерний узел будет вставлен ниже существующего.

В нашем примере мы определили три дочерних узла, соответствующие трем основным частям сочинения. Кроме того, чтобы хоть как-то отличать их друг от друга, мы добавили к каждому узлу пиктограмму. Для этого достаточно выбрать узел, щелкнув по нему левой кнопкой мыши, а затем в колонке у левого края окна приложения выбрать понравившуюся пиктограмму. Количество добавляемых пиктограмм не ограничено. Если же вы захотели убрать какую-то из добавленных пиктограмм (или даже все пиктограммы), то можно щелкнуть по узлу правой кнопкой мыши, а затем выбрать Пиктограммы > Удалить последнюю пиктограмму в появившемся контекстном меню. Те же операции представлены в разделе Вставка > Пиктограммы главного текстового меню.

Редко когда тема или заголовки частей остаются без пояснения, поэтому у нижней кромки приложения присутствует специальное окно с двумя вкладками Текст и HTML. Здесь для каждого узла можно вводить поясняющий текст (примечание). Это окно представляет собой полноценный текстовый редактор с возможностью изменения типа, размера и начертания шрифта, вставки списков и таблиц, а также поиском. В приведенном примере добавлено примечание для центрального узла карты – об этом сигнализирует как текст внизу, так и новая пиктограмма в виде планшета с карандашом, появляющаяся справа от текста узла.

Примечания можно использовать для записи основного текста сочинения, то есть писать сочинение можно не только в текстовом редакторе, но и прямо во Freemind. Причем в последнем случае перед глазами явно видна структура создаваемого произведения.

Внимательные читатели могли заметить, что на приведенном рисунке узел второй части сочинения несколько отличается от остальных: а именно, справа у него присутствует небольшой кругляшок. Он показывает, что у этого узла также есть дочерние. Для раскрытия списка дочерних узлов, достаточно выделить родительский, щелкнув по нему левой кнопкой мыши. Полный вид плана сочинения приведен на рис. 2.

Рис. 2 Рис. 2. Полный план сочинения. Позаимствован с «Сайта о русском языке и литературе» (http://literus.net).

Таким образом можно создать практически любую структуру сочинения, а также наполнять каждый раздел текстовым содержимым. Более того, поскольку блоки можно менять местами, то можно также легко перестраивать расположение материала в тексте – то есть, изменив структуру, тут же получить измененный текст.

Но и это еще не все. Freemind поддерживает экспорт интеллект-карт в различные форматы для размещения в сети Интернет. Однако в данном случае наиболее интересным является тот факт, что весь созданный план сочинения можно сохранить в виде текстового ODF-документа, а затем открыть в текстовом процессоре OOo Writer. Если при создании карты текст сочинения вводился в виде примечаний, то после экспорта можно получить текстовый документ, готовый к отправке на печать. Осталось только пожелать, чтобы Freemind мог импортировать ODF-файлы для удобства проверки структуры сочинения.

Следующий уровень

В последнее время на уроках литературы стали задавать творческие сочинения, то есть от школьников требуется написать небольшой рассказ или, чаще всего, сказку. Это уже «сочинение более высокого порядка» – так сказать, следующий уровень изучения литературы. На этом уровне также необходим план, но его может быть уже недостаточно. По своему опыту юношеской графомании могу сказать, что следовать выбранной сюжетной линии при одновременном выдумывании персонажей и их действий довольно трудно. Весьма сложно также держать в голове всех персонажей вместе с их характеристиками и вариантами их проявления. Мне приходилось использовать блокноты, в которых содержались описания персонажей, а также краткие описания придуманных мною сюжетов. Теперь в этом нет необходимости – познакомьтесь с кросс-платформенным помощником литератора StoryBook (http://storybook.intertec.ch).

Рис. 3 Рис. 3. Внешний вид приложения StoryBook в режиме Хронологический вид.

Приложение написано на Java и использует встроенную базу данных. Все выполняемые изменения тут же сохраняются в ней, и даже если приложение «вылетит» – чего за неделю эксплуатации у меня не случилось ни разу – вся введенная информация и все изменения не пострадают. Минусом такого подхода является отсутствие операции отмены выполненных действий.

После запуска перед вами открывается пустое окно с текстовым меню вверху. По умолчанию используется английский язык, однако это легко поправить, выбрав File > Preferences [Файл > Настройки] и установив для опций Language [Язык] и Spell check [Проверка правописания] значение Russian [Русский]. После сделанных изменений нажмите кнопку OK, и язык интерфейса автоматически изменится. К сожалению, не все пункты меню русифицированы, но это не мешает работать с приложением; кроме того, используя встроенный инструмент перевода [Translator Tool], можно самостоятельно дополнить и/или изменить перевод.

Для создания нового проекта выберите Файл > New, а затем введите имя нового проекта. В нашем случае мы решили создать проект для сказки «Красная Шапочка».

По умолчанию новый проект открывается в режиме Хронологический вид (см. рис. 3). В этом режиме слева располагается шкала времени, на которой отображаются все даты произведения, затем область, в которой размещаются сцены, отсортированные по датам и сюжетным линиям. У правого края окна располагается панель, содержащая два окна: навигатор проекта (вверху) и комментарии к выбранному объекту (внизу).

Кроме этого, в приложении имеются еще два режима: Управление главами и сценами и Вид книги. Однако в самом начале они бесполезны, поскольку заполняются только после создания глав и сцен произведения.

Предлагаю начать с создания персонажей. Для этого щелкните в навигаторе правой кнопкой мыши на пункте Персонажи и выберите единственный пункт всплывающего меню Создать персонаж. Можно также щелкнуть на соответствующей кнопке панели инструментов.

Появляющееся окно содержит три вкладки. На первой из них (Общие) можно определить такие параметры персонажа, как имя, фамилия, пол, род занятий, даты рождения и смерти, центральный он или второстепенный, а также выбрать, каким цветом будут отображаться данные этого персонажа на диаграммах и в элементах интерфейса. Две последние вкладки (Описание и Заметки) непосредственно связаны с текстом произведения. С их помощью можно вести описание персонажа, а также оставить пометки, где и как его следует использовать в произведении.

Далее определим основные локации, где будет происходить действие. В случае создания локаций выбор опций невелик: можно определить название локации, адрес и страну расположения, а также ввести описание и заметки. Для нашей сказки я определил всего три локации: Дом, Лес и Дом бабушки.

Далее можно переходить к созданию структуры произведения. По мнению авторов приложения, литературное произведение должно содержать хотя бы одну Часть, разбитую на главы. Эту единственную часть я так и озаглавил – «Единственная».

Далее создадим главы этой части при помощи кнопки на панели инструментов или правого щелчка на пункте Главы. В диалоге создания глав опций еще меньше: номер, название, описание и заметки. При помощи выпадающего списка вверху окна также можно указать, к какой части принадлежит глава, но в нашем случае выбирать, собственно, и нечего. Создадим четыре главы и двинемся дальше к созданию и описанию сцен.

Для создания сцены необходимо нажать соответствующую кнопку на панели инструментов. Появится окно с тремя вкладками. На первой из них следует обязательно определить опции, помеченные звездочкой, а именно: выбрать сюжетную линию (стандартная сюжетная линия создается вместе с проектом) и главу, к которым относится сцена, и определить дату происходящих действий, а также номер сцены и ее текущее состояние.

Последнее показывает проработанность сцены и изменяется от Наброска до Готовой сцены. На второй вкладке (Персонажи и локации) можно указать, где происходит данная сцена и кто в ней участвует. Причем, если идея персонажа или локации пришла в голову именно при разработке сцены, то их тут же можно добавить, нажав соответствующие кнопки.

Определив сцены, можно создать дополнительные сюжетные линии. Если в произведении есть несколько сюжетных линий, то в режиме Хронологический вид все сцены будут отображаться в столбцах, заголовком каждого из которых будет являться название сюжетной линии. К сожалению, каждая сцена может принадлежать только одной сюжетной линии, однако в настройках сцены можно установить галочку рядом с обозначением другой сюжетной линии: это покажет, что данная сцена также относится и к ней.

Таким образом можно создать подробный план-описание будущего или уже существующего литературного произведения. В последнем случае составление такого плана будет весьма полезно выполнить перед тем, как приступать к полному анализу текста.

Однако возможности приложения не ограничиваются перечисленными. Пункт меню Инструменты содержит команды для построения диаграмм, позволяющих наглядно увидеть частоту использования персонажей и локаций, сопоставить время существования персонажей, увидеть, что и где происходит в произведении, время жизни сюжетных линий и так далее. Построенные диаграммы можно легко сохранить в формате PNG.

И последнее, о чем мы поговорим – это отчеты, которые можно сформировать на основе введенных данных. К сожалению, их не так много – а именно, всего три:

  • Аннотация книги
  • Список персонажей
  • Список локаций

Зато выгрузить эти отчеты можно в нескольких различных форматах: от простого текста до PDF и ODT-файлов.

Если с последними двумя пунктами все понятно, то отчет «Аннотация книги» требует пояснения. Он представляет собой просто перечень глав с описанием входящих в них сцен и указанием, где происходят действия и кто в них участвует. Получаемый отчет достаточно информативен, но трудноват для восприятия «с листа».

Если столь краткий обзор возможностей StoryBook вас хоть сколько-нибудь заинтересовал, то загрузите это приложение (или возьмите его с LXFDVD) и попытайтесь поработать с ним. Возможно, оно пропишется на вашем компьютере на постоянной основе.

Крестословицы

Рис. 4 Рис. 4. Внешний вид конструктора кроссвордов CrosswordMaster.

Рис. 5 Рис. 5. Результат составления кроссворда, получаемый после распечатки.


Кроме сочинений, преподаватели также должны проводить проверку знаний текстов произведений традиционными методами. Одним из увлекательных способов это сделать является кроссворд; однако при его создании достаточно сложно корректно расставить ключевые слова или создать из клеток особый рисунок. В этом нам также помогут приложения Linux.

Несмотря на то, что программ для составления кроссвордов есть великое множество, мы предлагаем вам ознакомиться с достаточно простым и умным CrossWordMaster (http://sourceforge.net/projects/crosswordmaster/). Хотя интерфейс и не русифицирован, приложение вполне может работать с кириллицей и даже проверять орфографию – достаточно просто подключить любой dic-словарь в меню Edit > Select Dictionary [Правка > Выбрать словарь]. В нашем случае мы взяли словарь /usr/share/dict/ooo/ru_RU.dic.

Интерфейс весьма прост (см. рис. 4): слева большую часть занимает рабочее поле, справа находятся две колонки: Words [Слова] – здесь размещаются ключевые слова, расположенные на сетке кроссворда; Clues [Подсказки] – в этом столбце напротив каждого ключевого слова присутствует его описание-загадка.

Кроссворд можно создавать путем ручного ввода слов в рабочей области, располагая их в необходимом порядке. Затем можно нажать кнопку Update [Обновить], и все введенные вами слова окажутся в столбце Words, а все слова на сетке будут пронумерованы. Останется только ввести к ним подсказки, и кроссворд готов.

Можно пойти другим путем – а именно, сначала определить ключевые слова и подсказки к ним, а затем нажать кнопку Arrange [Расставить]; приложение постарается самостоятельно создать кроссворд из ключевых слов. Если результат вам не понравился, то можете нажать клавишу Arrange еще раз, а затем еще раз, и так до тех пор, пока результат вас не устроит.

Следует отметить, что кнопки Update и Arrange работают постоянно. То есть, можно самостоятельно расставить слова, нажать Update, затем добавить новые слова в строке Words и нажать кнопку Arrange, затем вновь ввести слово в рабочей области и перенести его в список ключевых нажатием Update. И делать все это можно в любом порядке.

К сожалению, данное приложение не предусматривает использование результатов непосредственного на компьютере. Чтобы разгадывать кроссворд, его необходимо распечатать вместе со списком подсказок. Для этого выберите пункты меню Crossword > Print [Кроссворд > Печать]. В появившемся окне есть две группы опций, позволяющие выбрать, что должно выводится на печать:

  • Crosswrod grid [Сетка кроссворда]:
    • Empty grid – пустая сетка,
    • Accross solution – слова по горизонтали,
    • Down solution – слова по вертикали,
    • Full solution – все слова.
  • Lists [Списки]:
    • Word list – список слов,
    • Clues – подсказки.

Сетка и каждый набор слов при распечатке занимают отдельный лист. Для экономии места мы объединили их в одном рисунке (см. рис. 5).

Вот и все, что я хотел рассказать сегодня. Надеюсь, описанные в этой статье приложения окажутся полезными для учителей русского языка и литературы, а также для будущих критиков и писателей. В дальнейшем мы планируем регулярно обращаться к программам, которые будут полезны с точки зрения преподавателей дисциплин гуманитарного профиля. Если эта тема вам интересна – пожалуйста, дайте нам знать.

Персональные инструменты
купить
подписаться
Яндекс.Метрика