Журнал LinuxFormat - перейти на главную

LXF133:Gnome Planner

Материал из Linuxformat
Перейти к: навигация, поиск
Gnome Planner Следим за любым проектом – и большим, и маленьким

Содержание

Gnome planner: Рулим проектами

Марк Нессел демонстрирует, как свободное ПО помогает сбалансировать три составляющих любого проекта: стоимость, время и задачи.

Управляют проектами не только профессионалы: менеджеры проектов – мы все. Вы, может, и не задумывались над этим, но организация вечеринки, ремонт квартиры, планирование отпуска, субботник во дворе или настройка домашнего театра – всё это задачи, требующие управления проектами. Свод правил по управлению проектами (Project Management Body Of Knowledge, PMBOK) определяет проект как временное предприятие, у которого есть начало и конец. В ходе проекта образуется уникальное изделие, услуга или результат, а сам проект разрабатывается поэтапно. В простейшем случае это отдельное мероприятие, выполняемое в два (или более) этапа. К примеру, проведение вечеринки требует многоэтапных усилий: нужно определить место проведения, организатора, оформление, составить список приглашённых, развлекательную программу, наладить учёт ответов на приглашения, а при необходимости организовать доставку гостей. Эти пункты можно назвать вехами [milestones], каждая из которых может содержать несколько задач. И ведь всеми этими вехами и задачами необходимо управлять!

Ну, можно просто составить список задач, но как обеспечить их своевременное выполнение? Как быть в случае задержек выполнения задач? Как задержки повлияют на выполнение остальных задач? Да и как определить общую продолжительность всех задач? Проекты разваливаются что ни день – из-за того, что управляющие ими люди не умеют правильно составить график работ. Сорванный план вечеринки – неприятное событие, но если провалится план массового выпуска продукции, последствия могут быть катастрофическими.

До недавних пор средства управления проектами были вне досягаемости индивидуальных предпринимателей или малых предприятий из-за высокой цены. ПО для управления проектами типа Microsoft Project требует изрядных вложений. Но увы, затевать некоторые проекты без такого ПО смерти подобно.

Gnome Planner – это приложение с открытым исходным кодом, по функциям схожее с Microsoft Project. В отличие от последнего, Gnome Planner бесплатен и обеспечивает кросс-платформенную совместимость между Linux, Windows и Mac OS X. Эти отличия весьма важны, поскольку значительно упрощают процесс коллективной разработки. Участники проекта не привязаны к единственной ОС, а цена не является запретительным фактором. Миновали времена, когда менеджер проекта имел единоличный доступ к плану работы. Ключ к успеху – коллективизация, и самоуправляемых команд становится всё больше.

Пакет Gnome Planner идёт в составе дистрибутивов Red Hat и Ubuntu. Под Ubuntu с рабочим столом Gnome приложение можно добавить через меню System > Administration > Synaptic Package Manager [Система > Администрирование > Менеджер пакетов Synaptic]. Просто поищите слово ‘Planner’, выберите пакет и примените изменения. Под Red Hat с Gnome выберите команду System > Add Remove Software [Система > Установка и удаление программ]. Вновь найдите ‘Planner’ и примените изменения.

Терминология Planner

  • Finish-to-start (FS) [От конца до начала] Наиболее распро странённая зависимость. «Предыдущее» действие должно закончиться до начала зависимой задачи.
  • Start-to-finish (SF) [От начала до конца] «Предыдущее» действие должно начаться до окончания зависимой задачи.
  • Finish-to-finish (FF) [От конца до конца] При таком типе зависимости «предыдущее» действие должно закончиться до окончания зависимой задачи.
  • Start-to-start (SS) [От начала до начала] «Предыдущее» действие должно начаться до начала зависимой задачи.

Представления проекта

LXF133 63 1.jpg Соберите команду и разделите её на группы.

Впервые открыв Planner, вы увидите нечто вроде пустой электронной таблицы и палитру значков слева от неё. Значки соответствуют четырём функциональным представлениям проекта: Tasks [Задачи], Gantt [Диаграмма Ганта], Resources [Ресурсы] и Resource Usage [Использование ресурсов]. В разделе Tasks формируются пакеты работ, а в разделе Lists [Перечни] отображаются вехи и конкретные действия. Многие менеджеры проектов начинают планировать работу именно здесь, вводя основные вехи в сопровождении подзадач, которые пользователь продолжает разрабатывать «вглубь». Переключившись на диаграммы Ганта, вы увидите проект в графическом или схематическом формате.

В этом представлении вехи и задачи отображаются слева, а справа выводится визуальная временная шкала. Графическое представление очень удобно для уяснения взаимозависимости различных задач. Задачи соединяются линиями или стрелками наподобие блок-схемы. Каждой задаче на левой панели соответствует прямоугольник на правой. Прямоугольник растянут по временной шкале до завершения задачи. По мере выполнения задач прямоугольники заполняются соответственно процентам завершённости. Поскольку вехи не имеют продолжительности, они обозначаются сплошными треугольниками. Группы задач можно определить по сплошным линиям, объединяющим подзадачи. Щелчок на задаче в графике вызывает всплывающее окно ее свойств, где их можно редактировать или просто просматривать. Название ресурса – короткое имя владельца задачи – отображается на графике справа от прямоугольника.

Чтобы создать или отредактировать перечень ресурсов, переключитесь в представление Resource. В этом разделе задачи закрепляются за владельцами. Доступные поля – Name [Имя], Short Name [Короткое имя], Type [Тип], Group [Группа], Email [Электронная почта] и Cost [Стоимость]. Информацию следует ввести для всех участников проектной группы, включая заказчика. Ресурсы могут быть двух типов: Work [Работа] или Material [Материал]. Людские ресурсы относятся к первому типу, а конференц-залы, оборудование и инструменты – ко второму. Стоимость исчисляется по часовому или дневному тарифу, в зависимости от детализации перечня задач. В любом случае, выбранный вариант детализации должен сохраняться во всём проекте. Используя часы при определении задач, необходимо применять часовую ставку и для определения стоимости ресурсов.

Последнее представление – Resource Usage. Именно здесь ресурсы, приписанные к проекту, распределяются по временной шкале. Задачи, обозначенные зелёным, находятся в стадии выполнения; синие – завершены, а красным обозначаются тревожные участки. Тревожным сигналом выделяются ресурсы, перегруженные работой в какой-либо момент времени. Если замечен красный цвет, следует перераспределить ресурсы внутри проекта, добавить их или скорректировать график. Как и в представлении Ганта, прямоугольники задач заполняются пропорционально выполненной работе.

Итак, начнем

LXF133 63 2.jpg Начните проект с расчленения высокоуровневых задач на более мелкие.

Прежде чем добавлять задачи и отслеживать ресурсы, надо создать проект. В меню Project [Проект] выберите команду Edit Project Properties [Редактирование свойств проекта]. Данные проекта вводятся на вкладке General [Общие] в шесть этапов. Сначала введите название проекта в поле Name. В следующем поле укажите дату начала проекта. Дата может равняться дате создания, а может и нет: бывает, что к моменту составления проекта некоторые шаги по его выполнению уже начаты. Тогда проект стартовал раньше даты создания. Затем укажите имя и организацию (если применимо) менеджера проекта. Для вашей первой работы выберите здесь None для этапа. В случае усложнения проекта этот параметр можно добавить позже. На первый раз выберите стандартный календарь. Завершив ввод сведений, нажмите кнопку Close [Закрыть].

Теперь всё готово для добавления задач. Чтобы приступить к работе, нажмите кнопку представления задач [Tasks] на левой панели. Для добавления первой задачи нажмите кнопку New Task [Создать задачу] на верхней панели. В сетке появится строка со стандартными сведениями о задаче. Задачи можно редактировать прямо в сетке или во всплывающем окне, вызываемом двойным щелчком на WBS-номере задачи – окно позволяет добраться до более мелких деталей вроде задач-предшественников и зависимостей, распределения ресурсов и примечаний. Для начала просто укажите названия и процент завершённости задач: для деталировки можно вернуться к задачам позже. Нередко детали добавляются в проекты слоями, начиная с базового. Этот процесс известен как поэтапная разработка.

Чтобы получить более подробные сведения об управлении проектами, посетите сайт Института управления проектами (PMI) – http://pmi.org. Институт PMI управляет процессом аттестации менеджеров проектов.

В нашем примере мы будем редактировать свойства задачи во всплывающем окне. В нём четыре вкладки: General [Общие], Resources [Ресурсы], Predecessors [Предшественники] и Notes [Примечания].

Во вкладке General содержатся базовые сведения о задаче. В первом поле – название. Оно должно четко описывать задачу и быть коротким – чтобы не загромождать сетку. Если это веха (задача без рабочего периода или длительности), отметьте флажок Milestone. Вы увидите, что поля Work [Работа] и Duration [Длительность]) станут неактивными. Для задач с заданной длительностью установите флажок Fixed Duration, после чего можно будет ввести количество часов или дней в поле, которое прежде было неактивным. По умолчанию для начала задач установлен параметр «как можно раньше». Если же для задачи нужно установить фиксированную дату, в Gnome Planner следует нажать кнопку Change [Изменить]. По мере выполнения задач не забывайте обновлять поле Completed [Завершённость]. Объём работы, выполненной по задаче, отображается в процентах. Последнее поле этой вкладки малозначительно. В правильно организованном проекте приоритеты заметны с первого взгляда. Добавить или скорректировать ресурсы, приписанные к задаче, можно на вкладке Resources. На ранних стадиях планирования проекта ресурсов у вас может и не быть. Как только набросок «структуры декомпозиции работ» (Work Breakdown Structure, WBS) будет готов, можно вернуться и распределить ресурсы по задачам.

В планировании проекта очень важна вкладка Predecessors – Предшественники, или зависимости; это связи, соединяющие задачи или группы задач между собой. В правильно составленной структуре WBS задачи соединяются в длинную цепь. Некоторые задачи можно выполнять параллельно, некоторые – последовательно. Параллельные задачи лучше сгруппировать, чтобы встроить их в единую последовательную цепь. Теоретически у каждой задачи или группы должна быть как минимум одна зависимая задача. Проще говоря, предшественником (или зависимостью) задачи номер три должна быть задача номер два, а её зависимостью будет первая задача.

LXF133 64 1.jpg Определение задач-предшественников позволяет соединить задачи в цепочку действий и установить связи между ними.

Чтобы задать предшественника задачи, нажмите кнопку Add [Добавить]. Появится новое всплывающее окно. Названием задачи (поле Name) должно быть WBS-имя задачи-предшественника. В выпадающем списке выберите задачу для связывания. В простых проектах сцепить задачи между собой нетрудно, но для более сложных работ может понадобиться усложнение зависимости. Например, данная задача должна начаться не раньше, чем завершится предыдущая. Или несколько задач должны стартовать одновременно, после завершения предшествующей задачи. Установить все эти параметры можно в выпадающем списке Relation Type [Тип связывания].

Чтобы зрительно проследить связи задач, можно переключиться в представление Ганта, где, как в блок-схеме, от задач-предшественников к задачам-преемникам проведены стрелки.

Скорая помощь

Запас или допуск по проекту – время, на которое задача может быть задержана без смещения даты окончания проекта или этапа.

Для более тонкой настройки связей можно установить для задач время допустимой задержки [Lag]. Это время добавляется к началу задачи. Если задача номер два должна стартовать по завершении задачи номер один, но необходимо оставить «слабину» в пару дней, добавьте к началу второй задачи время допустимой задержки. Если сперва начало второй задачи намечалось на 2 августа, то после этой операции начало сдвинется на 4 августа.

Определив структуру WBS и выделив под проект ресурсы, распределите последние по задачам. Переключитесь в представление Resources и определите роли всех участников проекта (включая заказчика), как мы описывали для раздела Project View. Если вы отслеживаете для проекта прибыли и убытки, то придётся указать часовую или дневную стоимость каждого ресурса.

Кто есть кто?

LXF133 64 2.jpg Чтобы сотрудники не надорвались, равномерно распределяйте загрузку в пределах проекта.

В большой проектной группе может понадобиться групповое распределение ресурсов. Удобнее всего функциональная группировка – например, On-Site Team [Персонал рабочей площадки], Back Office [Вспомогательный офис], Design [Проектировщики] и пр. При таком подходе заинтересованным лицам, не знакомым с сотрудниками, проще понять назначения, и облегчается управление ресурсами и перераспределение нагрузки. Если один участник группы перегружен, можно перевести часть нагрузки на другого.

Чтобы создать группу ресурсов, нажмите кнопку Edit Resource Groups [Редактировать группы ресурсов] или выберите аналогичную команду в меню Actions [Действия]. В появившемся окне можно указать имя, телефон и электронный адрес руководителя группы. Для выбора стандартной группы нажмите кнопку дополнительных параметров.

Снабдить группу ресурсами можно, дважды щёлкнув в колонке группы, в сетке ресурсов, и выбрав название группы в ниспадающем списке.

Добавив в проект все ресурсы, распределите их по отдельным задачам. Для этого вернитесь в представление Tasks. Каждой задаче в структуре WBS необходимо назначить владельца. Двойным щелчком в колонке Assigned To [Ответственный] вызовите всплывающее окно свойств. Перейдите на вкладку ресурсов. Выберите ресурсы в списке, установив соответствующие флажки. Если в выполнении задачи участвует несколько человек, можно добавить больше одного ресурса. Можно также скорректировать распределение рабочих единиц [Units]. Рабочие единицы – это процент времени, в течение которого человек будет работать над выполнением данной задачи в пределах заданного периода. Выполнение задачи может быть запланировано на четыре дня, в течение которых Билл будет занят только один день (25 единиц), а Мэри отработает все четыре дня (100 единиц). В большинстве случаев единицы менять не приходится: всем достанется по 100. Повторите процесс для каждой задачи в структуре WBS.

Скорая помощь

Термин «выравнивание ресурсов» означает перераспределение нагрузки между предварительно назначенными участниками проекта.

Чтобы убедиться в том, что ваши ресурсы не перегружены, перейдите в представление Resource Usage [Использование ресурсов]. Если чья-либо загрузка превышает 100 %, то на шкале времени отображается красный тревожный знак. Значит, придётся перераспределить задачи.

В представлении задач или Ганта задачи можно перемещать вверх-вниз или группировать с помощью кнопок на панели значков. Выделите задачу (с нажатой клавишей Ctrl – группу задач) в перечне и нажмите кнопку со стрелкой вверх или вниз. Задачи переместятся в новое положение группой.

Чтобы создать группу задач, начните с создания новой задачи. Создавать её следует над теми задачами, которые предстоит сгруппировать. Новая задача станет «заголовком» новой группы. Затем выделите группируемые задачи и нажмите на панели значков правую стрелку. Группа будет выделена отступом под «заглавной» задачей. Группой можно управлять как единым блоком. Вместо создания отдельных зависимостей для каждой задачи, установите одну зависимость – для «заглавия». Теперь к выполнению следующей задачи можно будет приступать после завершения всех задач в группе.

Календари

Нерабочие дни редко совпадают даже в разных компаниях, не говоря уже о разных странах. Понятия о нерабочих днях недели или нерабочих часах дня тоже варьируются. Чтобы обеспечить действующее расписание ресурсов, нужен собственный календарь.

Чтобы создать или изменить свой календарь, выберите в меню Projects команду Manage Calendars [Управление календарями]. Можно изменить готовый календарь или создать новый.

Чтобы вычленить праздники, нажмите на дату в календаре и в ниспадающем списке Set Day Type To [Установка типа дня] выберите вариант Nonworking [Нерабочий]. Выполните эту операцию для всех праздничных и нерабочих дней в графике проекта. А если некоторые из стандартно нерабочих дней в вашем проекте на самом деле будут рабочими, выберите для них в упомянутом списке вариант Working [Рабочий]. Можно скорректировать и стандартные выходные, нажав кнопку Default Week [Стандартная неделя]. Каждый день недели в ниспадающем списке можно выбрать и сделать его либо рабочим, либо нерабочим. Для коррекции рабочего времени служит кнопка Working Time. Выберите в списке вариант Working [Рабочий] и поправьте значения в полях Working Hours [Рабочие часы]. Закончив работу, нажмите кнопку Apply [Применить]. План проекта будет автоматически обновлён в соответствии с новым календарём.

Этапы проекта

LXF133 65 1.jpg Этапы позволяют разбить крупные проекты на более управляемые мелкие части.

Крупный проект можно разбить на несколько более мелких проектов-этапов. С помощью всплывающего окна свойств в этап можно превратить любой файл проекта.

Чтобы создать перечень этапов проекта, выберите в меню Project команду Edit Project Phases [Редактирование этапов проекта]. Примерами этапов могут служить «Создание/Планирование», «Настройка», «Реализация» или «Обновление». Проекты малых и средних масштабов обычно умещаются в одном файле, а вот в проектах национального масштаба эта функция очень кстати.

Что бы мы ни думали по этому поводу, но большинство компаний пока пользуется продуктами Microsoft, включая MS Project: на сегодня это царь проектных джунглей. Если вы получаете план проекта от заказчика или партнёра, он, вероятнее всего, составлен в формате MS Project. К счастью, Planner импортирует XML-файлы проектов MS Project. В меню Файл выберите команду MS Project XML, найдите файл для импорта и сохраните его с расширением .planner. Всё, можно редактировать. Проекты Planner экспортируются в формат HTML, в виде трёх разделов: «Представление Ганта», «Задачи» и «Ресурсы». Данные экспортируются в единый HTML-файл, поэтому их можно размещать на сайтах или рассылать по электронной почте заинтересованным лицам.

К сожалению, Planner не экспортирует работу в формат MS Project или CSV. Но есть обходной путь в виде Perl-скрипта, написанного Эндрю Рутвеном [Andrew Ruthven]. Он требует для работы установленных Perl-модулей CSV_XS и LibXML. По умолчанию скрипт выводит следующие данные: идентификатор, имя, владелец (задачи), даты начала и завершения, процент завершённости – попробуйте его, например, взяв с LXFDVD этого номера.

Представление Ганта

LXF133 65 2.jpg

Если вы предпочитаете заниматься планированием в графической форме, представление Ганта – для вас.

Работая в этом представлении, связи можно перетаскивать подобно тому, как это делается в редакторах диаграмм типа DIA, тем самым определяя зависимости. Задачи тоже можно перемещать перетаскиванием. Длительность задач меняется выбором задачи и перетаскиванием границ влево или вправо. В представлении Ганта можно также выделить в проекте «критический путь».

Этот термин часто употребляют неправильно. Критический путь для проекта важно знать при оценке риска и учете непредвиденных обстоятельств. Определение PMBOK для критического пути звучит так: «самый длинный путь через сетевую диаграмму, определяющий кратчайшее время для выполнения проекта». Поскольку критический путь проходит только через задачи с нулевым «допуском», он помогает выявить участки наивысшего риска.

В представлении Ганта возможно также масштабирование – неоценимое свойство для крупных работ. Стандартная шкала – понедельная. Для средних проектов это неплохо, но для многомесячных уже неэффективно. Нажав на изображение лупы со знаком минус, можно установить помесячный, поквартальный или годовой масштаб. Лупа со знаком плюс вернёт всё в прежний вид. Третья лупа нужна для автоматического размещения временной шкалы в пределах видимости.

Персональные инструменты
купить
подписаться
Яндекс.Метрика