Журнал LinuxFormat - перейти на главную

LXF133:First step

Материал из Linuxformat
Перейти к: навигация, поиск
Первые шаги Серия «Linux для новичков»

Содержание

Compiz-Fusion: Эффекты на стол!

Linux и так самая симпатичная ОС в мире, но Энди Ченнел уверен, что ее всегда можно сделать еще привлекательнее.

Хотя вращающийся куб или эффекты резиновых окон в Compiz-Fusion могут казаться бессмысленным украшательством (а честно говоря, иногда им и являются), многие из них приносят реальную пользу. На данном уроке мы рассмотрим разные уровни эффектов и выполним их настройку.

Для запуска Compiz необходима довольно современная графическая карта от ATI, Nvidia или Intel и свежий драйвер к ней. Хотя драйверы с открытым кодом постоянно улучшаются, все-таки лучший результат даст драйвер производителя видеокарты. Это особенно верно в случае Nvidia.

Мы работаем в Ubuntu, и последние версии поставляются с уже установленным и готовым к использованию Compiz. Если в меню Настройки [Preferences] вы не видите менеджер настроек CompizConfig, установите его – это делается через стандартный менеджер пакетов. Просто поищите ‘Compiz’ и установите приложение и модули расширения, имена которых содержат это слово. После этого в меню Системные > Параметры [System > Preferences] вы увидите новый пункт, обеспечивающий доступ к настройкам Внешнего вида [Appearance]. Выберите вкладку Визуальные эффекты [Visual Effects].

Здесь присутствует три опции: первая – Без эффектов [No Effects], ее следует выбрать, если у вас маломощная система или Linux стоит на виртуальной машине; вторая – Стандартные [Normal] – добавит некоторую визуальную экстравагантность, но не чрезмерную; третья называется Дополнительно [Extra] и предоставляет все эффекты, а часть их включает по умолчанию.

Настройка параметров

LXF133 58 1.jpg Большинство опций настройки Compiz работают одинаково. В главное окно вернет кнопка Назад [Back].

LXF133 58 2.jpg Простой способ определить свои эффекты — через диалог Настройки > Внешний вид [Preferences > Appearance].

Чтобы углубиться в систему, запустите пакет настройки, выбрав Система > Настройки > CompizConfig Settings Manager. Приложение выглядит пугающе сложно, но все имеющиеся опции сгруппированы по различным разделам, и метод работы для каждой из них одинаков.

Давайте заглянем в первый набор опций, щелкнув на кнопке Общие [General Options]. Окно изменится. Вдоль верхней кромки нового раздела располагаются вкладки для работы с каждым элементом, затем, в центре, сами опции с ползунками и окнами ввода чисел (для переменных) и радио-кнопки (опции Вкл/Выкл).

Каждая имеет иконку-«метлу» для быстрого сброса любой опции в исходное состояние.

Перейдите в Настройки отображения [Display Settings], измените Фильтр текстур [Texture Filter] на Наилучший [Best] и убедитесь, что выбрана Подсветка [Lighting]. Это даст наиболее привлекательное оформление рабочего стола. Раздел Вывод [Outputs] должен содержать пункты, соответствующие всем мониторам, подключенным к вашему компьютеру.

Теперь перейдем в раздел Рабочий стол [Desktop] и ознакомимся с переключателем вращающегося куба. Включается он установкой флажков для опций Куб рабочего стола [Desktop Cube] и Вращать куб [Rotate Cube]. Появится предупреждение об отключении границ рабочего стола [Desktop Wall], дублирующих некоторые функции куба. Убедитесь, что выбрали Включить куб рабочего стола [Enable Desktop Cube], отключив границы рабочего стола.

LXF133 59 1.jpg На мощных хороших машинах вращающийся куб весьма зрели щен, и даже работает на нескольких мониторах.

LXF133 59 2.jpg Некоторые приложения требуют назначения клавиатурных комбинаций для активирования или управления анимацией. Процедура очень проста.

Далее нажмите кнопку Вращающийся куб [Rotate Cube] и выберите вкладку Горячие клавиши [Bindings], чтобы определить комбинации для ручного вращения куба. Наиболее разумно использовать комбинацию клавиш (например, Ctrl+Alt) и кнопку мыши. Нажмите на кнопку рядом с опцией, которую желаете изменить, и воспользуйтесь диалоговым окном для ее настройки.

Вернемся и нажмем саму кнопку Куб рабочего стола [Desktop Cube]. Здесь следует рассмотреть несколько опций, включая цвет фона вверху и внизу и опцию добавления собственного изображения в ‘Skydome’ (фоновая картинка при включенном кубе). Для выбора изображения, щелкните на иконке файла укажите, где находится ваш файл, в обозревателе.

Опция Animate Skydome будет перемещать фоновое изображение вместе с кубом, а если ее не включать, изображение останется статическим. Если у вас нет картинки, всегда можно настроить цветовой градиент, выбрав два цвета в нижней части окна.

На вкладке Прозрачный куб [Transparent Cube] можно сделать грани куба прозрачными и легко видеть, что творится на каждом рабочем столе. Более зрелищный эффект куба включается опцией 3D окно [3D Windows] под заголовком Эффекты [Effects]. Каждое окно будет возвышаться на уровне своего слоя рабочего стола. Другая приятная опция, достойная добавления, особенно если вы позавидовали своим друзьям с Windows 7 – Предпросмотр окон [Window Previews] в разделе Дополнительно [Extras]. Она покажет миниатюру каждого окна на панели задач при наведении на него курсора мыши.

Окна по группам и закладкам

LXF133 59 3.jpg Когда несколько приложений собрано вместе, их окна окружает зеленое свечение.

Просмотр с закладками великолепен, так как в одном окне можно открывать несколько мест, и Compiz позволяет делать то же самое с любым приложением. Скажем, можно объединить во вкладки интернет-приложения или приложения для работы с фото, уменьшив тесноту на рабочем столе. Для этого в разделе Управление окнами [Window Management] включите опцию Группировать и объединять окна [Group and Tab Windows] и на вкладке Выбор [Selection] выберите опцию Горячая клавиша [Key Binding] рядом с меткой Выбор [Select]. Нам показалось удобным использовать Shift+Super/Windows+Левая кнопка мыши для выбора коллекции окон и Super/Windows+s – для выбора отдельных окон.

Вернитесь на рабочий стол и сделайте стопку из окон – так, чтобы они перекрывались. Теперь нажмите и удерживайте клавиши Super+Shift и «обведите» окна, которые желаете сгруппировать, удерживая левую кнопку мыши нажатой. Все выбранные окна станут прозрачными. Теперь есть два варианта действий. Super+G сгруппирует все выбранные окна вместе (обозначается темным свечением вокруг сгруппированных объектов), чтобы они перемещались, минимизировались и разворачивались все разом.

Super+t сгруппирует выбранное в одно окно (обозначается зеленым свечением вокруг окна). Поднеся курсор мыши к заголовку окна, вы увидите миниатюры всего содержимого группы, а выбор одного из них делает его активным. Перемещаться между вкладками можно при помощи Super+стрелки  курсора Вправо/Влево.

Для удаления настроек группы/вкладки из коллекции окон, выберите ее и нажмите Super+R. Свечение исчезнет, и окна вернутся в прежние, независимые состояния.

Impress: Будем анимировать

Анимация поднимет ваши презентации на новый уровень.
Скорая помощь

Не перегружайте свои слайды информацией или эффектами. Это вызывает раздражение аудитории.

Умеренное добавление анимации к вашим слайдам в OpenOffice.org Impress реально преобразит простую статичную презентацию. Хотя многие докладчики презирают анимацию – увлекшись, с ней легко переборщить – немного движения способно прояснить ваши идеи. Ну, а раз мы все стоим за ясность, это дело хорошее.

На данном уроке мы рассмотрим основы переходов между слайдами, появление на слайде и движение по траектории. У нас последняя версия OpenOffice.org — 3.2, доступная для загрузки с сайта проекта. Но в старых версиях, по крайней мере в серии 3.х, все описываемые опции тоже будут работать.

Для начала создайте новую презентацию и добавьте как минимум еще два слайда, используя меню Вставка > Слайд, а затем какое-нибудь содержимое. Добавьте несколько элементов маркированного списка в содержимое второго слайда и, может быть, картинку и краткий текст на третий слайд, чтобы мы могли с ними порезвиться.

Impress предлагает три типа анимации. Первый и простейший – это переходы между слайдами, определяющие, как в презентации один слайд сменяет другой. Второй – анимации «вход» и «выход», определяющие, как информация на слайде будет появляться и исчезать. Третий тип (тема нашего пошагового руководства) – движение по траектории; его можно использовать для управления перемещением объектов по слайду.

Переходы

LXF133 60 1.jpg Большинство людей ненавидят звуки при переходах, но их можно и добавить. Несколько звуков (на пробу) уже включено.

LXF133 60 2.jpg Используйте опции Эффекты, чтобы пункты вашего списка появлялись поочередно.

Переходы – самая простая анимация, и опций у нее немного. Одако и их лучше применять экономно. Хорошей идеей будет вообще отказаться от переходов для большинства ваших слайдов, а вместо этого вроде как растворять их, намекая аудитории, что вы намерены сменить тему или область.

Для добавления перехода к слайду, зайдите на него, затем выберите раздел Смена слайда в прикрепленной области справа. Выберите любой из представленных переходов и ознакомьтесь с предпросмотром в основной части окна.

Под основным списком выбора находится несколько опций, для определения скорости, сопутствующих переходу звуков и того, как слайд будет появляться. По умолчанию, для последнего требуется щелчок мыши, но вы можете также определить конкретное время в секундах. Нажмите Воспроизвести, чтобы увидеть переход в основном окне, или Показ слайдов – для просмотра, начиная с этого слайда.

Построения

Как и с переходами, здесь также следует быть тактичным и не переусердствовать. Чтобы элементы маркированного списка на втором слайде медленно появлялись, выберите весь текст мышью, а затем, справа, перейдите в раздел Эффекты. Нажмите кнопку Добавить и убедитесь, что выбрана вкладка Вступление. Вы увидите список доступных стилей; выбор любого из них вызовет предпросмотр.

Когда вариант выбран – например, Наплыв — появляются до полнительные элементы управления, и сам маркированный список. Выберите один или несколько пунктов списка, а затем в выпадающем меню Начать выберите спусковой механизм появления каждой из строк. Напрашивается вариант По щелчку, поскольку у вас будет ручное управление. Можно также сделать, чтобы элементы списка появлялись вместе с остальными – например, чтобы появлялся целый блок. В самом низу этого раздела имеется пара стрелочек, которые можно использовать для изменения порядка появления элементов списка. Однако предупреждаем: изменение этого порядка может повлиять на доходчивость вашего сообщения, поскольку аудитория не уловит смысл сопутствующих пояснений.

Вариант Построение можно применить и для появления, и для исчезновения объектов, а также для любых других элементов, размещаемых на слайде, включая рисунки, фотографии и диаграммы.

Шаг за шагом: Добавим движение по траектории

Шаг 1

  • 1 Создаем путь
Для добавления простого движения по прямой, выберите объект, а затем Эффекты. Нажмите кнопку Добавить и выберите вкладку Пути движения. Выберите строку Полилиния и нажмите OK. Курсор изменится, и вы сможете добавить траекторию, проведя ее от начальной до конечной точки. Ознакомьтесь с предпросмотром.

Шаг 2

  • 2 Редактируем контрольные точки
Дважды щелкните на траектории; вы увидите контрольные узлы для каждой ее части. Кроме того, появится окно Изменение геометрии. Для создания абсолютно прямой линии, выберите последовательно все узлы и удалите их кнопкой Удалить узлы. Можно также добавить узлы или изменить их позицию для создания более интересного движения.

Шаг 3

  • 3 Определение пути по кривой
Также можно создавать траектории анимации в виде кривых, выбрав опорный узел и щелкнув на кнопке Плавный переход на панели Изменение геометрии. Это создаст в опорном узле рукоятку подлиннее; она используется для придания кривизны. Для преобразования обратно в прямую, по очереди выберите оба конечных узла и нажмите кнопку Угловой узел.

Шаг 4

  • 4 Редактируем анимацию
Для получения чуть большего контроля над эффектом, выберите анимированный объект на слайде и дважды щелкните на его записи в области Эффекты справа. Запустится окно Настройки эффекта. В нем можно добавить к анимации звук и определить, что произойдет с объектом по завершении анимации: затемнение, изменение цвета или просто исчезновение.

Шаг 5

  • 5 Выставляем время
Используйте вкладку Хронометраж для изменения способа запуска анимации. По умолчанию, она начинается по щелчку, но можно настроить ее на автоматический запуск вместе с другим элементом слайда, например, с появлением текста. Параметром Задержка настройте интервал между появлением объекта и запуском его анимации. Кроме того, можно установить скорость и опции повтора.

Шаг 6

  • 6 Выходные форматы
Если вы желаете сделать переходы, сборки и анимацию доступными другим пользователям, то лучшим выбором будет родной для OOo формат ODP. Он сохранит все, что вы поместили в презентацию. Следующими по привлекательности будут форматы PowerPoint от Microsoft (но прежде чем выполнять нечто критичное, сделайте тестовый прогон презентации) и, наконец, Flash. Последний не поддерживает анимацию по траектории.
Персональные инструменты
купить
подписаться
Яндекс.Метрика