Журнал LinuxFormat - перейти на главную

LXF119:Первые шаги

Материал из Linuxformat
Перейти к: навигация, поиск
Первые шаги Серия «Linux для новичков»

Содержание

Smile: Создаем слайдшоу

Энди Ченнел выхватывает указку и разъясняет, как сделать слайд-шоу выходящим за рамки обыденного при помощи сияющей Smile.

Получив задание создать презентацию, большинство обращается к OpenOffice.org или Powerpoint. Но почему бы для разнообразия не взять Smile – GPL- альтернативу для создания слайд-шоу, оснащенную удобным встроенным медиаменеджером, потрясающими эффектами и парой приличных вариантов вывода?

Smile превосходен для создания автономного слайд-шоу, вот мы и наберем изображений, добавим заголовки, применим кое- какие эффекты, а затем выведем все в формате, готовом для удаленного просмотра или выгрузки в Интернет. Наконец, мы опишем, как добавлять видео и включать звуковую дорожку.

LXF119 52 1.jpg При первом запуске Smile предупредит об отсутствующих зависимостях

Установка Smile проста. По сути, надо всего лишь загрузить и распаковать архив с http://smile.tuxfamily.org, разместить полученный каталог в вашей файловой системе и дважды щелкнуть по значку Smile. Однако необходимо удовлетворить пару- тройку зависимостей: Sox, MPlayer и Mencoder, да еще поддержку OGG и MP3 в Sox – но они устанавливаются через менеджер пакетов. Если их пока нет, приложение-то запустится, но выдаст сообщение о нехватке элементов.

Приступим

Запустите Smile, и увидите окно, разбитое на четыре различные части: слева – инструменты, в центре – рабочая область, а справа панель редактирования с временной шкалой по нижнему краю.

Для начала выберите Проект > Создать [Project > New]. После этого можно определить место сохранения проекта и настроить формат вывода. Для ТВ имеются три варианта: PAL 4:3, PAL 16:9 и NTSC 4:3. Мы возьмем PAL 16:9, и наш проект подойдет для воспроизведения на широкоформатном телевизоре. После нажатия OK в центре экрана появится черная область, где вы впоследствии разместите изображения.

Прежде чем добавлять слайды, перейдите в Правка > Параметры импорта [Edit > Import Parameters], чтобы определить характеристики импортируемых изображений. Завершив эти операции, нажмите OK. Теперь выполните Правка > Добавить новые слайды [Edit > Add New Slides]. Верхний раздел окна содержит браузер файлов, его можно использовать для поиска изображений. Иконка двунаправленной стрелки у правого края окна переместит вас вверх по дереву каталогов.

LXF119 52 2.jpg Изучите несколько продвинутых вариантов в меню шкалы времени

Найдя изображение для импорта, либо дважды щелкните на нем, либо перенесите на шкалу времени, либо щелкните правой кнопкой и выберите Импортировать выбранные изображения [Import Selected Images]. Картинки можно в любой момент удалить с временной шкалы правым щелчком и выбором пункта Удалить выбранные слайды [Remove Selected Slide] в меню. Нажмите Закрыть [Close] для выхода из обозревателя.

В нашем примере, мы импортировали на шкалу времени пять замечательных изображений работы Джона Райта [John Wright] (во Flickr – Dryfish), распространяющихся по лицензии CC. Вы можете просмотреть набросок слайд-шоу, нажав кнопку Воспроизвести [Play] над шкалой времени. Предварительный просмотр дает вам представление о конечном результате и дополняется анимацией, заголовками и интересными переходами.

Настройки по умолчанию неплохие, но вам, вероятно, захочется что-нибудь изменить. Выберите изображение и посмотрите вправо от основного окна. В разделе Параметры [Parameters] – масса опций, включая длительность отображения, переходы и цвет фона.

Проблема окна 16:9 и фотографий стандартного размера в том, что по краям каждого изображения появляются черные полосы. Решить ее можно, сдвинув ползунок Масштабирование [Scale] вправо. Размер изображения увеличится, но при этом обрежется часть картинки. Если исчезло то, что представляет интерес, выберите инструмент Перемещение [Movement] (вверху левой панели инструментов) и подвигайте изображение для перемещения в желаемую позицию.

Инструментов перемещения на панели пять, сверху вниз: передвижение изображения по горизонтали и по вертикали, вращение в трех плоскостях, а также масштабирование. Иконка в виде крестика в круге – это инструмент 3D-перемещений, который мы пока трогать не будем. А вот эксперименты с Вращением [Rotate] и Масштабированием [Zoom] помогут вам освоить некоторые полезные операции.

Щелкните по изображению на шкале времени правой кнопкой мыши и выберите Редактировать слайд [Edit Slide] – откроется окно редактирования. Слева находится набор встроенных эффектов, среди которых эффекты цвета, отражения и размывания, справа – инструменты Яркость, Контраст и Цвет. Через нижнюю часть панели инструментов справа можно добавить виньетки. Если вы недовольны результатом, просто нажмите Восстановить [Restore] в верхней части экрана.

По завершении редактирования нажмите или Отмена [Cancel], или OK для применения изменений и возврата в главное окно.

Эффекты, заголовки и отрисовка

Эффекты Smile вызываются при помощи инструментов вкладки Эффекты [Effects] на панели инструментов справа. Среди них статические и анимированные «стикеры», затуманивание, размывание движением и выпадающий список Другие эффекты [Other Effects]: там есть анимированный снег, капли дождя и сердечки, ниспадающие по вашим слайдам. Скорость, размер и количество этих объектов регулируются ползунками.

Скорая помощь

Заголовки большинства слайдов лучше смотрятся, если они белые и расположены в нижней трети экрана.

В завершение работы над этим простым слайд-шоу добавим заголовок. Выберите первое изображение в последовательности и щелкните на вкладке Заголовок [Title] справа. В панели этого инструмента имеется место для ввода текста, а также опции для определения шрифта, цвета, размера и выравнивания. По мере ввода текст будет появляться на слайде.

На той же панели вы найдете инструменты для настройки проявления и исчезновения заголовка, длительности его показа, а также задания начального и конечного положений, что очень полезно для прокручивающегося заголовка. Если заголовок необходимо разместить в некой конкретной области экрана, перенесите текст в соответствующее место с помощью мыши, затем воспользуйтесь флагами Перемещение подписи [Legend Movement] в нижней части панели для определения стартовой и конечной точки движения (если они будут одинаковыми, текст никуда не сдвинется).

LXF119 53 1.jpg Выберите формат, подходящий для вашего выходного медиа-носителя

Теперь пора отрисовать файл, подготовив его для распространения. Для этого выберите Отрисовка > Отрисовать слайд-шоу [Rendering > Render Slideshow]. Появившийся диалог предложит вести имя файла, определить его тип и некоторые опции. По соображениям кроссплатформенности, для воспроизведения мы выбрали вывод в высококачественный MPEG-файл. После нажатия OK большая часть интерфейса Smile «замерзнет», поскольку приложение начинает отрисовку. Каждое изображение показывается друг за другом, что дает представление о ходе выполнения, по крайней мере, пока вы не упретесь в последнюю картинку. В конце появится прогресс-индикатор, отображающий процесс кодирования, а затем перед вами предстанет файл для просмотра.

Учтите также, что следствием выбора высокого качества является большой размер файла. При необходимости уменьшить размер файла с целью выгрузки или экономии места на жестком диске, уменьшите качество на пару делений. LXF

Копаем глубже

Здесь мы описали только основы. Smile способенна большее, включая слайд-шоу, содержащие видео (Правка > Добавить видео как слайд [Edit > Add A Video Like Slide]), продвинутую анимацию (щелкните на изображении правой кнопкой, выберите опцию Анимированный флаг [Animated Flag] и запустите предпросмотр – щелкните правой кнопкой и отметьте Простой [Plain] для удаления эффекта) или звук (щелкните правой кнопкой по шкале времени и выберите Добавить звуковую дорожку [Add Audio Track]). Можно даже создать примитивный многотрековый звук: добавить звуковую дорожку, а затем щелчком правой кнопкой мыши и выбором Добавить звуковой комментарий [Add Audio Commentary] наложить второй трек.

YouTube: Шлём туда видео

Создав прекрасное слайд-шоу, грех не порадовать им весь мир.

Худо ли, хорошо ли, но YouTube изменил просмотр видео в Интернете – можно даже сказать, изменил способ восприятия мира. Вместо пассивного глотания программ телевидения, мы теперь изготовляем собственные ролики и предлагаем их другим. На данном уроке мы создадим учетную запись на этом сервисе, настроим канал и загрузим короткий фильм. Затем мы изменим для ролика настройки приватности и добавим несколько заметок по ходу воспроизведения.

Одна из причин нашего выбора именно YouTube (кроме того факта, что это лидер рынка) – ПО на другом конце линии связи берет приличную долю ваших забот на себя. Однако многие наши шаги приложимы и к Vimeo, Blip.tv или другим сервисам видеохостинга.

Просматривать файлы на YouTube можно, просто посетив сайт, а для выгрузки чего-либо туда уже надо создать учетную запись. Это процесс несложный (начните с http://www.youtube.com/signup): введите имя пользователя и пароль, а также электронный адрес, и примите политики приватности и правил сервиса. Последние включают запрет на выгрузку материалов, не принадлежащих вам, так что читайте внимательно. Ближе к концу формы находится опция, позволяющая предоставить ваш канал YouTube для любого, знающего ваш электронный адрес. Если вы намерены устроить личное хранилище видео, лучше будет снять эту галочку.

Создав учетную запись, вы переместитесь в окно управления ею. В верхней его части находится ссылка с вашим именем пользователя. Пошарьте около нее, чтобы увидеть пункты меню, связанные с вашими роликами, списками воспроизведения, подписками и ящиком входящей почты. Рядом с ней находится ссылка Аккаунт [Account], она перенесет вас в точку настройки учетной записи YouTube. Там выставляются настройки приватности, какая- либо личная информация, предъявляемая другим пользователям, и настройки качества. Эти последние позволят воспроизводить видео с максимальным качеством, поддерживаемым вашим соединением. В Настройках блога [Blog] можно связать вашу деятельность в YouTube с блогом, размещенном на одном из поддерживаемых сервисов. Список включает Blogger, WordPress, LiveJournal и некоторые другие. В разделе Параметры электронной почты [Email] можно изменить электронный адрес, связанный с вашей учетной записью, а также определить, при каких условиях сервис должен контактировать с вами. Например, можно подписаться на уведомления о подключении людей к вашему каналу или появлении комментария к одному из ваших роликов.

Остался один пункт меню Учетная запись [Account]: это сервис Insight. Перейдите к нему, наведя курсор на ссылку Мой аккаунт [My Account] в основном меню YouTube. Insight – это урезанная для YouTube версия системы Google Analytics. Она показывает, сколько народу просмотрело ваше творение, откуда они и даже их пол. Для обычных пользователей это «мило-но-непрактично». Для бизнеса, однако, это предоставит прекрасную сводку, кого интересует демонстрируемое видео.

Меню Моя учетная запись содержит также ссылку на контакт-лист YouTube. Его можно использовать для настройки списка друзей, получающих извещение о том, что вы выгрузили что-то новое, им можно отправлять письма и даже блокировать отдельным – не в меру назойливым – посетителям доступ к вашим файлам.

Некогда записывать?..

А если у вас пока нет готовых фильмов, зато есть желание поведать нечто миру? Что же, вас спасет инструментарий Quick Capture от YouTube. Он использует Flash для захвата материалов с web- камеры, а затем размещает его в вашем канале. Для этого, очевидно, нужна web-камера, корректно настраиваемая в Linux. В последних версиях Ubuntu и SUSE у нас не было проблем с доступом к web-камере на нашем ноутбуке Dell 1720. При первом запуске Quick Capture, расположенном у правого края экрана под кнопкой Выгрузить [Upload], посреди экрана возникнет сообщение Flash с запросом доступа к web-камере и микрофону. Выберите Разрешить [Allow] для настройки приложения; затем должно появиться то, на что в настоящее время направлена web- камера. Прямо над изображением с камеры сидит пара выпадающих меню, позволяющих выбирать из всех доступных в системе web-камер и аудио- устройств.

Созрев для проповеди или, э-э, шоу, нажмите большую кнопку записи в центре экрана – и вперед!

Шаг за шагом: Размещение контента

Шаг 1

  • 1 Выгрузим фильм
    Для начала щелкните на кнопке Добавить видео [Upload] у правого края экрана и выберите видеофайл. При появлении браузера файлов перейдите к ролику и отметьте его для выгрузки. После загрузки файла на сервер добавьте имя, описание и категорию. Особое внимание уделите Конфиденциальности [Privacy], если не желаете допускать к просмотру кого попало.

Шаг 2

  • 2 Публикуем для других
    Пусть вы и выбрали приватное хранение ваше­го фильма – вы все равно можете предоставить к нему доступ, вплоть до 25 человек. Перейдите в раздел Мое видео [My Videos] и нажмите Прав­ка [Edit] рядом с файлом, который хотите опубли­ковать. Далее прокрутите страницу вниз до пункта Совместный доступ [Share] и выберите себе зрите­лей. Если контактов еще нет, выберите Редактиро­вать контакты [Edit Contacts] и добавьте парочку!

Шаг 3

  • 3 Добавим аннотации
    Вернитесь в раздел Мое видео и нажмите кноп­ку Аннотации [Annotations]. Прокрутите фильм до требуемого места, выберите один из четырех вариантов (Речевой пузырь [Speech Bubble], Над­пись [Note], Прожектор [Spotlight] и Аннотация­ пауза [Pause Annotation]) и добавьте текст для отображения. Укажите точки, откуда аннотация будет появляться и куда исчезать, используя оп­ции справа.

Шаг 4

  • 4 Правим аннотации
    Теперь жмите кнопку Сохранить [Save] или Опуб­ликовать [Publish]. В режиме просмотра файла найдите над самим видео кнопку Редактор аннотаций [Annotations Editor]. На жмите ее и используйте три кнопки слева внизу для навигации по аннота­циям или добавления новой. Для более продвину­тых возможностей выберите пункт Редактировать аннотации [Edit Annotations] справа.

Шаг 5

  • 5 Ссылка на время
    Одним из последних новшеств YouTube является возможность вставить ссылку на какой­-либо мо­мент в фильме. То есть, для направления зрителя к конкретной части вашего ролика, вы можете до­бавить к URL текст #t=2m10s, что приведет к пере­ходу проигрывателя на момент 2 минуты и 10 се­кунд в фильме. Время, указанное в комментариях, автоматически преобразуется в гиперссылку.

Шаг 6

  • 6 Удаление фильма
    Вы можете решить убрать фильм из Ин­тернета. В этом слу чае перейдите в раздел Мое ви­део [My Videos], прокрутите страницу до удаляе­мого и нажмите кнопку Удалить [Delete]. Хотим отметить, что это несколько импульсивно; в каче­стве альтернативы, переведите фильм в катего­рию Приватный [Private], используя кнопку Прав­ка [Edit]. LXF
Персональные инструменты
купить
подписаться
Яндекс.Метрика