Журнал LinuxFormat - перейти на главную

LXF117:Первые шаги

Материал из Linuxformat
Перейти к: навигация, поиск
Первые шаги Серия «Linux для новичков»

Содержание

Gramps: Строим родословную

Вы знаете, откуда пришли, куда направляетесь и частицей чего являетесь. Энди Ченнел изучает магию генеалогии.

Генеалогия – вид тихого помешательства, способного капитально повлиять на вашу жизнь. Кто-то собирает марки, игрушечные машинки или монеты; а генеалоги коллекционируют предков и связанные с ними события, соединяя себя с историей своего рода и осознавая, кто они есть. Любое фамильное древо, понятно, есть способ организации информации – если хотите, база данных; а потому ПК – идеальный помощник для тех, кого укусила муха генеалогии и кто решил упорядочить свои сведения.

Для подобной деятельности имеется несколько пакетов; их патриарх в мире Linux – Genealogical Research and Analysis Management Programming SystemGramps [Программная система управление генеалогическими исследованиями и анализом], свободное приложение, созданное на основе Python, GTK и собственной системы управления базами данных и поддерживаемое активным сообществом разработчиков.

В менеджере пакетов нашей системы была доступна только версия 2, но мы скачали с сайта проекта (http://www.gramps-project.org) релиз 3.0.4 установили его всего лишь двойным щелчком на загруженном файле. На сайте есть версии для Ubuntu и Fedora, но приложение доступно в менеджерах пакетов большинства дистрибутивов. Одно из главных отличий новой версии от старой в том, что при первом запуске последней версии перед вами предстает грамплет, помогающий настроить начальную базу данных (в старых версиях было необходимо выполнить File > Create [Файл > Создать] и создать новую базу данных в вашей файловой системе). Выберите Создать, затем Rename [Переименовать] чтобы присвоить вашему фамильному древу имя получше, затем нажмите кнопку Close Window [Закрыть окно].

Главный интерфейс вполне обычен для графического приложения, с панелью меню наверху, сопровождаемой панелью инструментов и рабочей областью, с вертикальным списком опций по ее левому краю. Выберите здесь пункт Люди [People] (в старых версиях Gramps она отмечена по умолчанию), которая – после ввода данных – будет отображать список всех людей в вашем фамильном древе. К другим представлениям мы вернемся позднее, а сейчас начнем с добавления в базу данных самих себя.

Добавляем людей

LXF117 55 1.jpg Диалоговое окно «Новое лицо» выспросит у вас все про вашего родственника; со временем данные можно будет еще расширить.

В представлении Люди, нажмите на панели инструментов Add [Добавить] или щелкните правой кнопкой мыши в главном окне и выберите Добавить. Появится окно редактирования сведений о неком лице, с полями для всевозможной информации, включая фамилию [Surname], имя [Given name], имя, имеющее хождение [Call name] (мы сочли, что имеется в виду прозвище), и другие данные. Если вы оставите поле ID пустым, что и рекомендуется сделать, Gramps присвоит элементу уникальный идентификатор. В нижней части окна находится список событий, который мало-помалу накопит все важные происшествия в жизни лица. Это данные поступают с течением времени, но сперва опишем обстоятельства рождения интересующего нас человека. Щелкните на иконке + у правого края окна для открытия соответствующего диалога. В нем вы найдете опции для названия события, ID события – вновь оставьте его пустым, чтобы ему было присвоено нечто уникальное – и поле описания. Эта последняя опция важна, поскольку она будет главным ориентиром, когда впоследствии вы начнете просматривать все события в вашей базе.

Еще одна опция окна – Place [Место]. Выберите кнопку Добавить рядом с ней, чтобы определить, где имело место данное событие. В простейшем случае указывается город, но есть также опции для задания полного адреса или широты и долготы. Последние можно добыть из любой онлайн-карты, типа Yandex Maps или Google Maps. В процессе добавления персоны мы создали важное событие и многократно используемое местоположение.

Используя ту же схему, добавьте еще несколько человек: возможно, вашего супруга, детей, братьев/сестер и родителей (и даже семью супруга). Если вы что-то пропустите, например, дату или место рождения, знайте, что к любому элементу можно вернуться позднее, а для начала построения вашего древа достаточно любых данных. По мере добавления записей они будут сортироваться по фамилии в окне Люди, и при каждой фамилии будет стрелочка, разворачивающая данные обо всех нисходящих ветвях.

Скорая помощь

Вкладка Associations [Связи] поможет определить связи между так называемыми «не кровными» родственниками, например, крестными.

На экранном снимке выше профиль включает еще и изображение (созданное при помощи web-камеры и Cheese). Чтобы добавить его, просто выберите вкладку Gallery [Галерея], нажмите иконку + у правого края экрана и укажите подходящее. Можно использовать верхнюю половину окна для обрезки изображения, например, с целью изъять чей-то портрет из групповой фотографии. Дайте снимку имя и нажмите OK. Первое добавленное в профиль изображение станет иконкой данного лица во всех частях приложения, но каждому можно добавить и коллекцию изображений.

Создаем связи

Населив свою базу людьми, вы захотите задать их родственные связи. Для этого выберите Families [Семьи] в опциях слева. Нажмите на панели инструментов кнопку Добавить, открыв окно определения семьи. В его верхней части задаются отец и мать семейства, при помощи или иконки + (для создания нового лица), или иконки Выбор (листок и ладонь над ним) для указания введенной ранее персоны. Выполните последнее и выберите своих маму и папу, а затем, в случае необходимости, определите их связь, используя выпадающий список Type [Тип]. Теперь можно добавить в список детей, используя нижнюю половину окна. Новое нажатие иконки + откроет окно следующего лица, а иконка Selection [Выбор] предоставит список имеющихся. По мере добавления каждого ребенка в перечень они будут появляться внизу экрана; как и для любых таблиц баз данных, можно изменить их порядок, используя заголовки столбцов.

Когда в древе накопятся данные, вы начнете изучать другие части приложения. Чтобы увидеть свои истоки, выберите свое имя в списке Люди, а затем нажмите кнопку Pedigree [Родословная]; ваше имя появится в левой части окна, а все ваши предки будут упорядочены справа, вместе с добавленными вами изображениями. Вы также можете нажать стрелку у левого края вашего раздела, чтобы увидеть ссылки на своих потомков, а справа вы найдете две стрелочки, позволяющие перемещаться по различным линиям, сходящимся к вам.

Скорая помощь

Используйте Отчеты > Текстовые отчеты > Отчет годовщин и дней рождения для создания HTML-списка всех важных дат вашей семьи. Посмотрите и другие отчеты.

Использование грамплетов

Грамплеты – это небольшие приложения, способные сообщить нечто интересное о ваших данных. Выберите пункт Gramplets [Грамплеты] слева и, по умолчанию, увидите небольшой текст-описание. Удалите или минимизируйте его, используя соответствующую иконку, а затем щелкните правой кнопкой мыши в пустом месте левой колонки. Выберите Add a Gramplet [Добавить грамплет], а затем элемент списка. Например, Age On Date принимает в качестве аргумента дату, а затем сообщает возраст каждого ныне здравствующего лица из базы данных на этот момент.

Pedigree Gramplet выдаст быстрый обзор вашего семейного древа, а Relatives Gramplet покажет все связи для выделенного лица. Однако они обрабатывают не только ваши данные. News Gramplet подключается к RSS-ленте новостной части web-сайта Gramps, так что вы можете оставаться в курсе развития приложения, а Python Gramplet сообщит вам, какую версию скриптового языка вы используете.

FreeMind: Мысли по полочкам

Организуйте свои мысли в нечто жутко связное при помощи карт разума.


Скорая помощь

Чтобы добавить гиперссылку к части текста, выделите его и нажмите Insert > Hyperlink [Вставка > Установить ссылку], а затем добавьте URL.

Карты разума (mind maps; в русском языке часто применяются термины «диаграммы связей» или «интеллект-карты») пригодятся в любых ситуациях, от планирования новелл и создания структуры программного проекта до продумывания очередности песнопений на свадьбе. Их реальная мощь в том, что они могут вынуть вагон информации из вашей головы и предоставить средства для ее связывания воедино. На данном уроке мы применим FreeMind, свободный инструмент создания карт разума на базе Java, работающий под Windows, Linux и OS X, к выполнению одной из наиболее распространенных задач для этих инструментов: созданию карты web-сайта.

При наличии Java (найдите ее в своем менеджере пакетов), инсталляция означает лишь скачивание двоичного файла с сайта проекта (http://freemind.sourceforge.net) и запуск установщика. На сайте имеются версии для различных дистрибутивов, а также платформо-независимый бинарник, который должен подойти ко всему.

LXF117 57 1.jpg Карты разума пригодятся для структурирования идей, например, научного проекта.

При первом запуске почти весь интерфейс безжизненно-сер, и карту необходимо создать через File > New [Файл > Новый]. В центре экрана появится корневой узел. По умолчанию, ваша карта, скорее всего, будет разрастаться в горизонтальной плоскости. Область вверху заполнена набором знакомых иконок, охватывающих действия типа открытия и сохранения документов. Иконка в виде лампочки означает создание нового дочернего узла для текущего выбранного: именно так мы и будем строить карту.

Справа от «лампочки» находятся две кнопки форматирования текста, одна для добавления к узлу иконок и еще одна для создания Облаков [Clouds]. Наконец, на панели инструментов имеется пара иконок + и -, используемых для раскрытия и закрытия узлов (см. ниже) и выпадающий список для выбора шрифта. Слева от основной рабочей области – вертикальный набор кнопок, которые пригодятся для добавления к узлу иконки, чтобы карта лучше читалась. В верхней части набора помещен крестик, удаляющий из узла последнюю добавленную иконку, и корзина – она удаляет все.

Поскольку мы создаем карту сайта, сперва переименуем корневой узел в Home. Для этого просто дважды щелкните на нем и введите новую метку. После щелчка вне редактируемого текста вы заметите, что овал вокруг надписи изменил свои размеры. Можно, конечно, ввести и длинную строку, но это будет именно одна строка, поскольку нажатие клавиши Enter равноценно выходу из узла. Для ввода многострочного текста, щелкните правой кнопкой мыши на невыделенном узле и выберите Edit Long Node [Длинный текст].

Потомки для корневого узла создаются щелчком на иконке лампочки на панели инструментов или клавишей Insert. После создания, потомку можно присвоить метку, точно так же, как и корню, а повторное нажатие Insert создаст «внука» корневого узла, тогда как нажатие Enter приведет к рождению собрата. По умолчанию FreeMind создает новые узлы, используя стиль Fork [Ответвление], но если вы желаете иметь их в виде овалов – заключенными в прямоугольники со скругленными углами – не изменяя каждый из элементов вручную, перейдите в Tools > Preferences [Дополнительно > Установки] и посмотрите на вкладке Defaults [Стандарты]. Измените опцию Standard Node Type [Тип узлов] на Bubble [Овал]. Это потребует перезапуска, так что сохраните свою работу, закройте приложение и откройте его вновь.

Если необходим вид пошире, выполните Вид > Приблизить [View > Zoom Out] или Отдалить [Zoom Into] для выделения какой-либо области редактирования; а щелчок и удерживание кнопки в любом свободном месте страницы позволит перемещаться по листу с помощью мыши. А теперь пойдем дальше – отредактируем отдельные узлы, создав более полезную карту.

Шаг за шагом: Редактируем карту разума

Шаг 1

  • 1 Редактируем корневой узел
    Щелкаем правой кнопкой на корневом узле и выбираем из меню Format > Node Background Color [Формат > Фоновый цвет узла], затем, в появившемся окне, цвет фона узла. Имеется несколько способов выбора цвета, включая шестнадцатеричный код и визуальный захват. После нажатия OK корень остается прежнего цвета, пока вы не перейдете в другой узел. Таким же образом определяется цвет текста (Формат > Цвет узла).

Шаг 2

  • 2 Перемещаем узлы
    Если узлы слишком скучиваются, их можно передвинуть, наведя курсор мыши на соединительную линию. Появится маленький овал; по нему можно щелкнуть и перенести его в новое место на экране. Дочерние узлы также передвинутся, а все на пути узла сместится в соответствии с изменениями.

Шаг 3

  • 3 Форматируем соединители
    По умолчанию FreeMind соединяет родительский и дочерний узлы гладкой кривой Безье. Вы можете изменить это, щелкнув правой кнопкой мыши на узле и выбрав в меню Format > Edge Styles [Формат > Тип линии] один из четырех вариантов. Это повлияет на соединители данного конкретного объекта; для изменения всех соединителей выполните операцию для корневого узла. (Кривые вида Заостренные весьма привлекательны.)

Шаг 4

  • 4 Добавляем иконки
    Иконки удобны для обозначения статуса отдельных частей карты. Например, галочка может означать «закончено», а предупреждающий треугольник подскажет, что «требуется доработка». Для добавления иконки, щелкните правой кнопкой мыши на узле и выберите Icons > Name of Icon [Пиктограммы > Имя иконки]. Удаление производится выбором узла и нажатием кнопки с крестиком в верхней части панели пиктограмм по левому краю окна.

Шаг 5

  • 5 Прячем узлы
    Иногда необходимо сделать обзор карты, например, главной части сайта, закрыв часть дочерних элементов. Для этого просто щелкните на каждом узле, имеющем дочерние элементы, чтобы они спрятались в родителе. Дочерние узлы заменятся одним маленьким кружком, обозначающим, что они есть. Щелкните еще раз, и потомки появятся вновь.

Шаг 6

  • 6 Связываем потомков
    Web-сайты – это не линейная последовательность. Данный факт можно отразить, связав вместе различные узлы. Выберите узел, а затем используйте Shift+щелчок для выбора второго. Затем выполните Insert > Graphical Link [Вставка > Создать связку]. Между двумя элементами появится кривая. Ее положение можно изменить перетаскиванием, а цвет и стрелочка меняются по правому щелчку и выбору соответствующей опции. LXF
Персональные инструменты
купить
подписаться
Яндекс.Метрика