Журнал LinuxFormat - перейти на главную

LXF110:QDVDAuthor

Материал из Linuxformat
Перейти к: навигация, поиск
Сам себе режиссер Linux в основе домашней киностудии: от захвата с камеры до мастеринга DVD

Содержание

Выкатим диск

Video
ЧАСТЬ 4 От уютного семейного просмотра отснятого шедевра нас отделяет сущая мелочь – отсутствие записанного DVD-диска. Алексей Маслий сейчас это исправит.

Рис. 1 Рис. 1. Вкладка Paths позволяет указать местоположение различных сторонних инструментов.

QDVDAuthor – замечательный инструмент для мастеринга DVD-Video дисков, но и он не лишен недостатков. Часть из них была решена к версии 1.0, которой может не оказаться в вашей системе. Если версия вашего QDVDAuthor меньше 1.0, настоятельно рекомендую обновиться или хотя бы проверить, как сохраняются в проекте русские тексты, чтобы избежать неприятных сюрпризов в будущем.

Одной из особенностей QDVDAuthor можно считать наличие только одной жесткой зависимости: самого DVDAuthor (буква Q в QDVDAuthor намекает, что это Qt-интерфейс для последнего). Если уже установленная программа не обнаружит в вашей системе нужный инструмент, будет выдана ошибка при генерации DVD. Посмотреть, что у вас есть, а чего нет, можно через Tools > Setup [Инструменты > Настройка] на вкладке Paths [Пути]. Появится окно, изображенное на рис. 1. Нажмите кнопку Scan System [Сканировать систему] и программа сама поищет необходимые компоненты с использованием стандартных путей (/bin, /usr/bin и т.д.). Отсутствующие приложения будут выделены красным цветом.

Рядом с каждой программой есть кнопка Info [Сведения]. Нажав ее, вы увидите окно с объяснением, для каких именно целей необходима та или иная программа. Кнопка Search [Поиск] позволяет задать нестандартный путь к исполняемому файлу приложения. Но даже если какие-то компоненты отсутствуют – это не беда: до тех пор, пока все ваши файлы кодированы в форматах, пригодных для записи на DVD (MPEG2/MP2), никакие конверторы не понадобятся, программа будет работать и без них.

Ну и, как вы уже наверное, заметили, еще одним минусом программы можно считать отсутствие русского интерфейса, хотя учитывая весьма небольшое количество пунктов в меню, эта проблема не является существенной даже для людей, плохо знающих английский язык.

Начнем, пожалуй

Рис. 2Рис. 2. С этим интерфейсом нам предстоит работать на протяжении всего урока.

Окно программы (рис. 2) состоит из стандартных элементов: меню, панели инструментов и собственно рабочей области. В ее левой части видны два окошка: в первом отображаются файлы, добавленные в проект, во втором – дерево элементов проекта (кнопок, надписей, рисунков и т.д.). Между ними располагаются две кнопки: Add Movie [Добавить клип] и Add Slideshow [Добавить слайд-шоу]. Справа находится окно для создания DVD-меню; у него изначально три вкладки.

Прежде чем приниматься за работу, крайне рекомендую включить опцию Tools/Visible Region [Инструменты > Видимая область]. В окне DVD-меню появится красная рамка: выходящие за нее элементы могут не попасть на экран, когда вы будете просматривать диск в бытовом DVD-проигрывателе, при этом при просмотре того же DVD на компьютере картинка будет видна полностью.

Далее необходимо создать новый проект. Для этого придется ответить на три вопроса: где хранить временные файлы, как назвать проект и в каком каталоге генерировать структуру DVD-Video диска.

Итак, проект создан. Давайте добавим в него видео-файл, нажав кнопку Add Movie. Как я уже говорил, используя внешние конверторы, программа способна «понять» практически любой формат, но лучше все же взять MPEG2. Если ваши ролики хранятся в чем-то другом, проведите перекодирование вручную (например, в avidemux), указав в качестве контейнера MPEG-PS, иначе генерация DVD может сильно затянуться, и самое главное - это будет повторяться при каждой генерации DVD, в притивном же случае вся орперация занимает считанные минуты.

Как узнать время

Отдельный вопрос: а где, собственно, взять значения времени для глав? Искать их в видео-потоке проблематично (поверьте мне, я пробовал). Конечно, надо обратиться к проекту Kino, из которого генерировался фильм! В нем указаны все моменты с точностью до сотых долей секунды: нужно просто скопировать их и вставить в проект QDVDAuthor. Но есть вариант лучше: при кодировании фильма просите программу сразу создать XML для QDVDAuthor, и разбивка на главы уже будет включена в него. Следует только помнить, что Kino вставляет каждую сцену в виде отдельной главы, поэтому рекомендуется сперва объединить в Kino все сцены, относящиеся к одному DVD-сюжету.

Добавленный файл нужно разбить на главы (chapters), чтобы можно было получить доступ к любому сюжету из DVD-меню. Для этого щелкните на нем правой кнопкой мыши и в появившемся контекстном меню выберите пункт Properties [Свойства] а затем откройте вкладку Chapters (рис. 3). По умолчанию есть только одна глава, совпадающая с началом фильма. Вы можете произвести разбиение автоматически (кнопка Autochapters), указав временной диапазон и длительность каждой главы в соответствующих полях. Но для любительского фильма иметь равные по продолжительности главы практически нереально, поэтому нам подойдет кнопка Add chapter [Добавить главу], позволяющая указать время начала каждого сюжета вручную, в формате чч:мм:сс.ддд (т.е. часы, минуты, секунды и доли секунды). Просто введите нужные значения и щелкните Add chapter; проделайте эту операцию для каждой главы. Если какой-либо пункт был введен ошибочно, его можно удалить, выделив главу в списке и нажав кнопку Del chapter [Удалить главу]. Достигнув желаемого результата, нажмите кнопку Accept [Принять].

Рис. 3Рис. 3. Добавленный файл нужно разбить на главы.

Добавим меню

При создании нового проекта автоматически генерируется главное меню DVD-диска. Оно называется Main Menu VMGM. При необходимости можно создавать дополнительные меню, как это делается на всех коммерческих DVD-Video дисках с фильмами (я не имею в виду пиратские копии с 6–12 наименованиями на диск). Давайте создадим в главном меню заголовок (допустим, «Тестовый проект») и два пункта: «Просмотреть все» и «Выбрать сюжет», причем второй будет ссылаться на новое меню (рис. 2).

В первую очередь добавим фоновый рисунок. Это может быть однотонный фон, градиент или фотография: программа понимает все популярные форматы графических файлов. Нажмите кнопку Add background [Добавить фон], расположенную на панели инструментов, выберите файл. Как правило, он оказывается неподходящего размера, и программа предложит скорректировать его: откроется окно, в котором можно указать необходимое разрешение и метод кадрирования. Покончив с этим, нажмите OK.

Делать выбор под фоновую музыку гораздо интереснее, чем в молчании, поэтому нажмите кнопку Add audio [Добавить звук] и укажите аудиофайл. Для более быстрой сборки рекомендую добавлять короткие композиции или сразу же подготавливать их в формате MP2.

Теперь можно добавить статическую надпись с заголовком фильма или фразой «Демо-проект. ГЛАВНОЕ МЕНЮ». Нажмите в области заставки правой кнопкой мыши: появится меню с различными действиями. Можно добавить рамку (frame), текст (text), картинку (image), фильм (movie) или элемент из библиотеки (from library); обратите внимание, что по умолчанию библиотека пуста и ее наполнение следует проводить из Интернета. Выберите Add text [Добавить текст]; курсор мыши превратится в крестик. Очертите им область для надписи, после чего откроется окно редактора, содержащее стандартные средства форматирования, выбор начертания, размера, цвета, расположения и т.д., а также координаты левого верхнего угла рамки и ее размеры. Если впоследствии вам потребуется изменить размеры текстовой рамки, это следует делать именно здесь, но сейчас нам нужно лишь ввести текст надписи и нажать OK. Надпись будет добавлена на экран меню, но не там, где нам надо. Перетащите ее, предварительно щелкнув по ней левой кнопкой мыши. Кстати, двойной клик вызывает уже виденное нами окно редактора.

Рис. 4 Рис. 4. Создать кнопку в DVD-меню можно в прямом смысле слова в два счета.

Теперь пришла пора делать кнопки. Кнопкой может быть что угодно: надпись, картинка или даже фильм-вставка. Для этого надо лишь щелкнуть на объекте правой кнопкой мыши и в появившемся меню выбрать пункт Define as button [Сделать кнопкой]. Появится диалог определения кнопки с четырьмя вкладками.

Предлагаемое имя можно оставить как есть: важно изменить действие, происходящее по нажатию на кнопку. По умолчанию здесь выбрано jump (т.е. переход к...), а справа находится выпадающее меню, в котором отмечен пункт vmgm (главное меню, т.е. вариант, гарантированно присутствующий в любом проекте). Помимо него, здесь будут перечислены все меню и видеофайлы, добавленные вами в проект. При выборе видеофайла активируется третье выпадающее меню, в котором указывается глава (по времени). Значение по умолчанию – 00:00:00.000, т.е. начало файла. Таким образом, желая создать кнопку «Смотреть фильм» или «Смотреть все», нужно добавить надпись с соответствующим текстом и преобразовать его в кнопку с действием jump видеофайл 00:00:00.000 (рис.4). Оставшиеся три вкладки позволяют назначить цвет по умолчанию (это будет цвет надписи или рамки), цвет выделенного объекта, и цвет выбранного объекта (он будет использоваться, когда вы нажмете кнопку Play на пульте ДУ).

Уровнем ниже

Теперь, когда «фасад» уже готов, давайте создадим дополнительное меню, в котором будут выбираться сюжеты. Допустим, их у нас восемь, включая начальный (он, конечно, будет эквивалентен пункту «Смотреть все», но таковы традиции). В этом случае логично сделать два подменю по четыре сюжета в каждом, а также кнопки «вперед», «назад» и «возврат в меню». Ради наглядности, кнопки для сюжетов будут картинками.

Выберите в меню пункт DVDAuthor > Add Menu [DVDAuthor > Добавить меню]. В окне QDVDAuthor появится новая вкладка – SubMenu1. Повторите эту операцию столько раз, сколько требуется (в нашем примере – два). Покончив с этим, переключитесь на вкладку SubMenu1. Я рекомендую сразу же переименовать ее (и все остальные вкладки) во что-то более осмысленное – названия, которые вы сейчас видите, отображаются и в выпадающем меню действий; лучше, если его пункты будут «говорящими». В названиях подменю можно использовать русские буквы: я выбрал «Сюжет1-4» и «Сюжет5-8». Имя главного меню следует оставить без изменения.

Рис. 5Рис. 5. Желающим сделать подменю красивым и удобным не обойтись без толики дизайнерского таланта.

Переключаемся в меню «Сюжет1-4». В первую очередь, как и раньше, выбираем фоновую картинку и музыку, а также подбираем заголовок, скажем, «Выбор сюжетов 1-4». Теперь надо решить, как расположить на оставшемся свободном месте четыре кнопки-картинки с подписями и еще две кнопки перехода; мой вариант представлен на рис. 5.

Внешний вид меню готов – теперь нужно определить кнопки. Учтите, что порядок, в котором вы это сделаете, задает очередность перехода по ним при воспроизведении DVD-диска, так что будьте внимательны. Кстати, порядок, в котором следуют уже определенные кнопки, можно посмотреть в главном окне программы на вкладке Structure [Структура]: здесь строится полное дерево всех объектов и приводится детальнейшее описание их свойств.

Итак, выбираем картинку первого сюжета, щелкаем правой клавишей и открываем уже известный нам диалог под пунктом Define as Button. В меню действий указываем jump видеофайл и время 00:00:00.000, а все остальное оставляем без изменения. Для кнопок второго, третьего и четвертого сюжетов действия будут такими же, только в поле время следует указать момент начала соответствующей главы.

Теперь определим кнопки для переходов в порядке «Далее», «В главное меню». Действием для первой из них будет jump «Сюжет5-8», а для второй – jump vmgm. Второе подменю, Сюжет5-8, создается полностью аналогично.

Структурный генератор

Наш проект почти завершен – остается сгенерировать структуру будущего DVD-диска. Для этого выбираем пункт меню DVDAuthor > Create DVD [DVDAuthor > Создать DVD] или нажимаем соответствующую кнопку на панели инструментов. Далее возможно появление окна с предупреждением, что некоторые элементы меню перекрываются (такое часто случается, когда у вас много текстовых кнопок, а размеры фрейма подобраны не слишком аккуратно) – сейчас его можно проигнорировать, но если оно вас беспокоит, проверьте DVD перед прожигом. Программа также может выразить свое недоумение по поводу отсутствия фоновых рисунков, но будем считать, что вы знаете, что делаете.

После этого откроется окно Command Queue Dialog [Диалог очереди команд]. В нем определяется очередь внешних команд, которые будут запущены программой с целью создания итогового DVD. Наборы команд объединяются в блоки, которых насчитывается четыре: конвертирование (если исходные материалы представлены не в MPEG2), генерация меню, генерация DVD-Video и запись на диск. Каждый из блоков может быть отключен (например, блок записи DVD по умолчанию не активен). Кроме того, блоки могут быть дублированы. Так, преобразование видео будет содержать отдельный блок на каждый видеофайл (если их несколько); свой блок имеет и каждое подменю. Возможность отключать те или иные блоки крайне удобна: например, если удались все меню, кроме одного, можно перестроить только дефектный экземпляр; точно так же, нет смысла дважды перекодировать видео.

Все команды внутри блока могут быть модифицированы пользователем. Мне особенно нравится, что практически для каждого действия предлагается выбор из нескольких вариантов: нажмите на иконку с треугольником возле команды, выберите наиболее подходящий вариант и отредактируйте его (кнопка e рядом) по своему вкусу. Наконец, если вам нужна подсказка, на помощь придет кнопка man.

Когда все будет проверено и настроено, нажмите кнопку OK, чтобы запустить очередь команд на выполнение. Этот процесс не столь длительный, как кодирование видео, но все равно может занять десяток минут. Вся информация отображается о окне Execution Dualog [Диалог выполнения], и я крайне рекомендую включить галочку Keep open [Держать открытым], иначе окно будет закрыто по истечении 15 секунд даже в случае возникновения ошибки, оставив вас гадать, что же, собственно, произошло (конечно, файл журнала остается в указанной вами временной папке, но к чему в ней копаться?). Если перекодирование видео производить не требуется, то скорость генерации DVD будет в основном зависеть от быстродействия дисковой подсистемы и вряд ли займет больше 15 минут. После этого в указанном каталоге появится структура DVD-Video диска, т.е. директории AUDIO_TS и VIDEO_TS. Остается только записать их на DVD.

Запишем сериал

Рис. 6Рис. 6. Каждому файлу – собственный раздел до 2000 года? Похвально, но нам-то нужна «коммуналка».

Все это, конечно, замечательно, но что если исходных файлов-сюжетов у вас несколько? В принципе, изменится не так уж много: каждая кнопка теперь будет ссылаться на свой файл, но вот незадача – после проигрывания любого сюжета будет появляться главное меню, да и кнопка «Смотреть все» потеряет смысл. Возможно, это и было вашей целью, если, например, вы делали сборник мультфильмов. Во всех других случаях, пожалуй, вам захочется посмотреть фильм от начала и до конца.

Причина такого «ненормального» поведения в том, что по умолчанию для каждого нового файла программа создает отдельный раздел (titleset), и, согласно спецификациям DVD, каждый раздел просматривается независимо от остальных. Значит, нужно просто поместить все маленькие файлы в один раздел, и тогда каждый из них станет в нем самостоятельной главой.

Понравилось? Тогда приступаем. Добавляем в наш проект все файлы подряд: пока можно не обращать внимания на порядок. Каждый из них попадет в свой раздел, нумеруемый числами 01, 02 и т.д. (рис. 6). Перенос из раздела в раздел осуществляется баналь- ным перетаскиванием мышью; кстати, точно так же можно перемещать файлы и внутри одного раздела. Потратьте немного времени, чтобы перенести все сюжеты в один раздел и установить требуемый порядок следования. Вот, собственно, и все.

Теперь, когда мы будем определять действие для кнопки и выберем переход на наш большой раздел, появится дополнительное выпадающее меню, в котором можно будет указать конкретный файл. Кстати, если сюжет кажется вам слишком длинным, его, как и раньше, можно разбить на главы – тогда на данном этапе добавится еще и меню с выбором главы.

Обратите внимание на то, что после того как вы объедините видеофайлы в один раздел, его меню Properties изменится, и с определением глав в отдельно взятом файле возникнут некоторые проблемы. Дело в том, что кнопка Add Chapter есть, а поля, куда вводить значение времени, нет. Возможно, к тому моменту, когда вы будете читать эти строки, ошибку уже исправят, но пока наиболее простым решением будет снова выделить нужный файл в самостоятельный раздел, разбить там на главы и вернуть обратно.

Огонь!

Мы вплотную подошли к финальной стадии – прожигу DVD-диска. Но прежде чем доставать из коробки чистую матрицу, я бы крайне рекомендовал проверить, соответствует ли действительное (т.е. сгенерированный программой DVD) желаемому. Откройте терминал и выполните команду:

xine dvd://путь_к_каталогу_со_структурой_DVD

Xine будет работать точно так же, как если бы вы вставили DVD-Video диск в привод.

Все в порядке? Тогда приступаем к прожигу. Используйте любую подходящую программу. Обратите внимание, что необходимо создать новый проект DVD-Video, а не DVD с данными. Внешне оба диска выглядят одинаково, но различие кроется внутри, и второй не будет проигрываться DVD-плейерами. LXF

И напоследок... Как удивить зрителя?

Хотите, чтобы меню выглядело профессионально? Добавьте объектам тени. Для этого щелкните по выбранной надписи правой кнопкой мыши и выберите в меню пункт Add Shadow [Добавить тень]. В появившемся диалоге можно указать цвет, степень размывания, положение в пространстве, расстояние до букв и даже прозрачность. Результат сразу же виден в окне предпросмотра. Не правда ли, стало гораздо симпатичнее? Но помните, что тени надо создавать до того, как объект будет превращен в кнопку. Чтобы не бежать сразу к компьютеру можете глянуть еще раз на рисунок 5 - можно сразу отличить надписи с тенью и без нее.

Вам этого мало? Добавьте intro- и extra-файлы. Эта та самая надоедливая реклама, которая обязательно проигрывается при входе и выходе из меню в коммерческих DVD, но, я уверен, вы сможете найти для них применение и получше. Здесь вам потребуется пункт DVDMenu > Add intro(extra).

Персональные инструменты
купить
подписаться
Яндекс.Метрика