Журнал LinuxFormat - перейти на главную

LXF110:Интернет

Материал из Linuxformat
Перейти к: навигация, поиск
Первые шаги. Серия «Linux для новичков»

Содержание

Браузеры: Синхронизируем данные

Энди Ченнел расскажет, как сохранить всю информацию в одном месте – пардон, во множестве мест – с помощью двух инструментов синхронизации закладок.

Компьютеры становятся все дешевле, и стало уже обычным делом играть или работать на нескольких машинах. Например, у многих сотрудников LXF один компьютер на работе, как минимум один настольный ПК дома, да еще ноутбук – чтобы можно было поработать (или посмотреть YouTube), находясь в пути. Тут-то и возникает проблема: в таких условиях не очень легко упомнить, где находятся закладки, а результат – время и нервы, потерянные в поисках утраченного сайта. К счастью, web – это гигантская система клиент/сервер, а значит, можно хранить сетевые настройки – в том числе и закладки – в одном месте и загружать их с помощью браузера. И эта проблема считается настолько важной, что все основные разработчики web-браузеров предлагают (или намерены предложить) способы синхронизации данных нескольких машин.

Мы расскажем вам о двух методах синхронизации. Первый основан на сервисе, недавно добавленном в web-браузер Opera, а второй использует модуль расширения под названием Foxmarks для… угадали – Firefox, с тем же результатом. Сделаем также небольшое отступление, чтобы обсудить проблемы безопасности. Но – хватит предисловий, давайте ощутим дух синхронизации.

Часть 1 Opera Link

Новейшая версия web-браузера Opera имеет функцию под названием Opera Link: ее можно использовать для синхронизации данных между компьютерами и, используя Opera Mini, вашим мобильным телефоном. Давайте создадим учетную запись, войдем и синхронизируем данные между двумя копиями программы.

Первая задача – установить Opera, если вы этого еще не сделали. Мы обнаружили самую свежую версию в OpenSUSE 11 с помощью менеджера пакетов Yast, но у Opera имеются файлы для множества дистрибутивов, от Mepis до разных Ubuntu. Есть также универсальные RPM и Deb-пакеты, а на случай, если вообще ничего не сработает, статически скомпонованный двоичный файл для установки вручную. Добавив приложение, запустите его из стартового меню, или открыв консоль и набрав ‘Opera’.

После загрузки первой страницы выполните Файл > Синхронизировать Opera; откроется диалоговое окно аутентификации. Если вы уже создали учетную запись в Opera – например, когда обращались в web-сообщество этого проекта – можете просто ввести свое имя и пароль и продолжить. Если же нет – нажмите на кнопку Регистрация, чтобы создать ее. Надо будет указать свое имя пользователя, пароль и адрес электронной почты, и принять условия соглашения.

Внизу экрана учетной записи имеется стрелка, подписанная Параметры Opera Link. Нажмите на нее, и вы увидите, что можно отправить на серверы Opera. По умолчанию программа предложит вам синхронизировать Закладки [Bookmarks], Быстрый набор [Speed Dial] (супербыстрые закладки Opera), Личную панель [Personal Bar] (панель инструментов закладок) и Заметки [Notes]. Чтобы убрать из списка синхронизации какой-либо пункт, просто снимите с него выделение.

Нажмите кнопку OK, и обратите внимание на новый значок Sync в строке состояния внизу окна. Некоторое время он будет отображать недавно использованное имя пользователя; анимация является признаком, что между вами и сервером происходит обмен информацией. Чтобы проверить синхронизацию, добавьте в браузер несколько новых закладок, а пару любимых сайтов – в раздел Speed Dial. Для этого откройте новую вкладку с помощью значка + на текущей, выберите слот и введите туда URL. Страница Speed Dial будет появляться при открытии новой вкладки.

Opera Link также синхронизирует заметки, добавленные к приложению – это, возможно, даже полезнее, чем синхронизация закладок. Вы можете просмотреть заметки с помощью меню Вид > Панели, выбрав вкладку Заметки, а затем создать новую с помощью кнопки Добавить.

Все закладки и заметки будут отправлены на серверы Opera, но синхронизацию можно выключить через меню Файл > Прекратить синхронизацию Opera. Однако помните, что если вы добавляете много новых закладок и снова включаете синхронизацию, они автоматически отправятся на сервер: это может оказаться очень полезным для тех, у кого нет постоянного доступа в сеть. Настройте синхронизацию для всех своих компьютеров, войдите под своим именем и ждите, когда загрузятся данные.

Часть 2 Foxmarks

Скорая помощь

Где бы вы ни сохраняли свою информацию в режиме онлайн, используйте действительно сильный пароль. Никаких глупостей типа «Скажи пароль – “пароль”». И не пытайтесь отделаться добавкой пары букв: пароль от этого сильнее не станет!

Opera – отличный браузер, но вдруг вы хотите синхронизировать данные в Firefox? Mozilla трудится над инструментом синхронизации под названием Weave, но пока он слишком ненадежен, чтобы на него полагаться. По этой причине мы воспользуемся Foxmarks. Foxmarks работает только с закладками, и это означает возможность получения виртуального доступа к ним практически отовсюду!

Для начала зайдите на http://www.foxmarks.com (естественно, через Firefox) и нажмите на кнопку Install Now [Установить сейчас] – заодно стоит просмотреть условия пользовательского соглашения Foxmarks;

вас перенаправят на страницу Foxmarks сайта Mozilla. Нажмите на кнопку Добавить в Firefox, потом OK, и перезапустите браузер.

Если вы используете Firefox 3, программа спросит вас, следует ли запомнить все открытые вкладки и выйти, и после перезапуска автоматически запустится инструмент настройки Foxmarks. Нажмите на Далее, чтобы начать процесс. Если у вас уже есть учетная запись, выберите в диалоговом окне Да, в противном случае – Нет, а затем опять нажмите Далее, чтобы создать учетную запись. После небольшой паузы вам предложат задать имя пользователя, пароль и указать действующий адрес электронной почты. Помните, что это – личные данные, которые будут храниться – хотя и зашифрованными – на чужом сервере, так что выбирайте сильный пароль, состоящий из букв обоих регистров и цифр, и никогда не называйте его никому другому.

Нажав кнопку Создать учетную запись, вы выражаете свое согласие с условиями соглашения Foxmarks, так что неплохо бы сначала внимательно его прочесть. Прощелкайте следующее диалоговое окно, затем выберите Далее для запуска начальной синхронизации. Длительность этого процесса зависит от количества ваших закладок. В отличие от Opera Link (см. выше), Foxmarks размещает справа внизу маленький значок, который отображает статус. Если он действует вам на неpвы, просто уберите его в настройках.

Тихий сервер

Закладка, добавленная в Firefox, незаметно отправится на вашу учетную запись в Foxmarks, и если вы настроите другой браузер, они будут автоматически синхронизированы при следующем входе. Доступ к самим настройкам можно получить через Инструменты > Foxmarks > Настройки, или нажав на значок уведомления. Во вкладке Общие есть функция смены пользователя, принудительного запуска синхронизации или выполнения ее при выходе из браузера – логичный момент.

Давайте добавим в систему новый профиль, чтобы отделить рабочие закладки от домашних. Нажмите на кнопку My.Foxmarks.com во вкладке Профили – вы попадете на сайт Foxmarks, где вам предложат войти под своим именем пользователя. Между прочим, именно здесь можно получить доступ ко всем своим закладкам через web-интерфейс с любого компьютера (только не забудьте выйти из него, если находитесь в интернет-кафе). В меню Инструменты выберите Управление профилями и нажмите кнопку Добавить, чтобы дать новому профилю имя. Заодно взгляните на правую панель интерфейса и снимите выделение с тех пунктов, которые не надо добавлять к новому профилю. И, наконец, нажмите Сохранить и закрыть, чтобы изменения были зафиксированы на сервере. Вернувшись в настройки Foxmarks, выберите вкладку Профили и нажмите на кнопку Изменить. Теперь просто щелкните по новому профилю, чтобы синхронизировать и загрузить все связанные с ним закладки. Чудеса!

Vuze: Качаем по-умному

Энди Ченнел прикипел к попыткам ускорить скачивание с BitTorrent, ведь это больше, чем протокол для кражи голливудских фильмов.

Пусть пресса кудахчет про пиратскую музыку и фильмы; BitTorrent остается весьма полезной технологией, особенно для пользователей Linux, которым надо регулярно знакомиться с новыми дистрибутивами. В данном руководстве мы настроим Vuze (клиент BitTorrent, ранее известный как Azureus), а затем пройдем весь процесс скачивания файла с BitTorrent, чтобы сделать его как можно эффективнее.

BitTorrent – это способ обмена файлами, который, в отличие от традиционных методов скачивания, ускоряется по мере увеличения числа пользователей, пытающихся получить доступ к файлу, поскольку данные делятся на мелкие части и распределяются между множеством людей.

Файл, который мы скачаем чуть позже, просто содержит ссылку на программу-трекер (tracker), которая, в свою очередь, отслеживает, кто с кем соединяется и какой объем имеется у каждого пользователя в группе. По мере присоединения к группе новых пользователей программа приобретает больше возможностей для закачки каждой части файла, и процесс загрузки ускоряется. И это просто превосходно для получения массивных файлов, таких, например, как дистрибутивы Linux и – к ужасу Голливуда – пиратские фильмы. Поскольку скорость закачки напрямую зависит от количества пользователей – чем их больше, тем выше у них всех скорость закачки – то вполне вероятно, что самая высокая скорость будет у вас в первые часы или дни после выхода нового дистрибутива, а не спустя некоторое время после релиза.

Не спеши, торопыга

Стоит также помнить, что в начале процесса скорость закачки может быть ну очень медленной. Пусть загрузка идет своим чередом; скоро все изменится. А если нет, посмотрите, что там у вас с брандмауэром: перейдите в Инструменты > Проверка NAT [Tools > NAT/Firewall test] и нажмите на кнопку Проверка [Test]. BitTorrent требует и входящего, и исходящего соединения, и из-за брандмауэра может несколько подтормаживать. Если вам понадобится открыть порт (обычно это 31683), чтобы работа шла лучше, гляньте документацию на межсетевой экран.

Vuze – приложение с открытым кодом на базе Java, а значит, оно будет работать на чем угодно, лишь бы там был Java-клиент. Предлагаемая версия – 3.1.1.0, это архив размером 13 MБ, и его мож- но скачать с http://azureus.sourceforge.net. По завершении скачивания распакуйте его в папку Документы или Приложения, используя Nautilus или Konqueror. Поскольку Vuze написан на Java, то для его работы нужно установить среду времени выполнения – Java Runtime Environment (JRE). Она должна быть в вашем обычном менеджере пакетов.

Иконка на рабочем столе

LXF110 64 1.jpg Функция Swarm отображает количество узлов сети, с которыми вы соединены, и статус закачки.


Процедуры установки как таковой нет, вы просто остаетесь с папкой, полной файлов. Чтобы немного упростить ее использование в будущем, создадим ярлык приложения на рабочем столе (мы используем Gnome, но в KDE процесс такой же). Щелкните правой кнопкой мыши на любом месте на рабочем столе и выберите пункт Создать ярлык [Create New Launcher]. В диалоговом окне введите имя (Vuze) и комментарий (Клиент BitTorrent), затем нажмите на кнопку Обзор и найдите место, куда изначально был распакован архив. Выделите значок Azureus (не Vuze) и нажмите Открыть. В папке имеется также и значок Vuze (голубая лягушка), так что щелкните по иконке и опять нажмите на кнопку Обзор, чтобы выбрать его. Наконец, нажмите ОК – и новый значок появится на рабочем столе.

Vuze имеет открытую архитектуру и потому обзавелся множеством дополнительных функций, доступных как модули расширения. Как и само приложение, их можно скачать с сайта проекта, и они позволят вам сделать массу интересного: например, найти torrent-файлы в локальной сети, работать с приложением из Firefox, настраивать закачку из RSS и получать SMS-уведомления о завершении загрузки. Прямая ссылка на модули расширения есть в Инструменты > Плагины > Получить плагины [Tools > Plugins > Get Plugins]; закачав нужные модули, жмите Инструменты > Плагины > Мастер установки [Tools > Plugins > Installation Wizard], чтобы добавить их в программу.

Шаг за шагом: первый запуск Vuze

Шаг 1

  • 1 Запуск Vuze
    Для старта приложения дважды щелкните по созданному ярлыку или найдите файл с именем Azureus (он находится в той же директории, куда был распакован пакет) и выделите его. Перед вами откроется титульная страница Vuze со ссылками на популярные легальные ресурсы. Нажмите на Advanced (вверху справа), чтобы войти в основной интерфейс пользователя.

Шаг 2

  • 2 Проблемы брандмауэра
    Поскольку BitTorrent требует наличия открытых портов, возможно, вам придется настроить брандмауэр вашего компьютера. Жмите Tools > NAT/Firewall test, чтобы проверить статус, и затем, при необходимости, зайдите в настройки брандмауэра и убедитесь, что порт, через который соединяется Vuze, открыт. Как это сделать, описано в инструкциях брандмауэра.

Шаг 3

  • 3 Загрузка torrent-файла
    Есть сотни сайтов, с которых можно скачать исходный torrent-файл для загрузки самых свежих дистрибутивов. Мы частенько заходим на http://linuxtracker.org, поскольку там обычно находятся самые последние релизы. Загрузите нужный torrent-файл на жесткий диск. Числа, которыми отмечены torrent-файлы, содержат буквы S или L. S=seed (т.е. полная версия), L=leech (неполная версия). Чем больше «сидов», тем быстрее процесс.

Шаг 4

  • 4 Закачка
    В Vuze, жмите File > Open Torrent File. Нажмите на кнопку Add, затем поищите, где находится torrent-файл, и выделите его. Вверху вы увидите имя Torrent’а; в центре – каталог для сохранения скачанных файлов (убедитесь, что у вас хватит места для дистрибутива); внизу – список всех файлов закачки. Чтобы начать, нажмите ОК.

Шаг 5

  • 5 Проверьте скорость
    В основании окна Vuze отображается информация о скорости отправки и получения данных. Щелкните правой кнопкой по любой из них, и вы увидите список скоростей. Выделенная вами скорость будет поддерживаться для данной операции. Помните, что при выборе большой скорости отправки у вас будет выше и скорость закачки – это ведь обмен информацией.

Шаг 6

  • 6 Удаление torrent-файла
    По мере загрузки файла его состояние будет отображаться в пользовательском интерфейсе. Щелкните дважды, чтобы найти другие способы просмотра данных. Когда закачка будет завершена, и вы передадите достаточно, чтобы улучшить свою карму, можете удалить torrent, щелкнув правой кнопкой и выбрав Remove или Remove > Delete Torrent File. LXF
Персональные инструменты
купить
подписаться
Яндекс.Метрика