Журнал LinuxFormat - перейти на главную

LXF100-101:Меняем прописку

Материал из Linuxformat
Перейти к: навигация, поиск
Мигрируем из Windows на Linux Меняем «прописку» без лишних проблем

Содержание

Экспорт: календарь, почта и контакты

Миграция из Windows
ЧАСТЬ 1: Экспорт ваших контактов из Outlook или Outlook Express может стать настоящей головной болью. Джо Касселc объяснит, как ее избежать.

Сейчас на свете полно простых в использовании дистрибутивов Linux, и мигрировать из Windows не так уж и сложно. Перенести данные также легко. Если у вас конфигурация с двойной загрузкой, создайте общий раздел для данных; в противном случае проще всего скопировать данные из одной системы в другую с помощью USB-брелка, так как не придется иметь дело с сетевыми правами доступа.

Если вы какое-то время пользовались Windows-версиями популярных приложений с открытым исходным кодом, то, начав работать в KDE или Gnome, культурного шока не испытаете. Обе среды ближe к Windows, чем Mac OS. Зато пользователей Outlook ожидает реальная головная боль. Перенос персональных данных из файлов закрытого Microsoft формата PST – дело, мягко говоря, непростое. Нельзя просто скопировать PST-файл в Linux и импортировать его в Kontact, Evolution или Thunderbird: он не будет работать. Этот файл запутан покруче иного морского узла – классический пример «иглы одного поставщика».

Если этот файл нельзя открыть нигде, кроме Outlook, а Outlook нельзя запустить нигде, кроме Windows – считай, при переходе мы хорошо завязли. Предстоит сделать выбор: похоронить свои данные, убедиться, что Outlook запускается на виртуальной машине Windows, или продолжать использовать раздел Windows. Любому, кто собрался послать Windows прощальный поцелуй, придется крепко подумать.

Экспорт из Windows

Осознаем ключевой момент: переезд требует планирования. Пока вы в Windows, нужно предпринять шаги, обеспечивающие экспорт данных в формат, с которым сможет работать новая программа.

Решить эту проблему можно несколькими способами. Outlook может экспортировать данные в файлы разных форматов, но для нас действительно полезен только один из них – CSV (‘comma-separated values’ – «значения, разделенные запятыми»). Внутренность папки преобразуется в простой текст, содержащий поля, разделенные запятыми. Это хороший вариант для списка контактов и других небольших баз данных, но он провалится, если попытаться экспортировать архив электронной почты. Если вы пользуетесь почтовым сервером IMAP вместо POP, то сможете считать оттуда все сообщения, так как не храните их локально, но проблема с сообщениями в архиве останется.

Календарь

События календаря можно экспортировать из Outlook в файл формата CSV, но в данном случае это не лучший выбор. Гораздо практичнее конвертировать календарь в стандартный формат ICS, используемый web-календарями.

Ресурсы
  • Outlook2iCal Утилита экспорта для ранних версий Outlook, не поддерживающих экспорт в формат iCal. http://outlook2ical.sourceforge.net
  • Mozilla Thunderbird Версия для Windows. Нужна для экспорта почтовых архивов Outlook в формат, который могут обрабатывать программы для электронной почты в Linux. http://www.mozilla-russia.org/products/thunderbird/


В Outlook 2007 есть возможность выслать календарь по электронной почте в файле формата ICS. ICS-файл легко импортируется в Evolution или любую другую программу-календарь. Чтобы сделать это, откройте Outlook и переключитесь на календарь. На панели навигации выберите Отправить Календарь По Почте [Send Calendar Via Email]. Задайте диапазон дат, который нужно экспортировать, и другие необходимые настройки. После завершения работы мастера будет создано электронное сообщение с прикрепленным к нему файлом ICS. Теперь сохраните вложение на жесткий диск или другой носитель, с помощью которого вы будете передавать данные в Linux.

В более ранних версиях Outlook экспортировать данные непосредственно в ICS нельзя, поэтому нам понадобится макрос, который сделает эту работу. Загрузить макрос Outlook2iCal можно с сайта http://outlook2ical.sourceforge.net, причем на ваш ПК с Windows, поскольку файл надо будет распаковать и установить в Outlook. Но сперва позаботьтесь, чтобы Outlook был не против принять макросы. Для этого откройте Сервис > Макросы > Безопасность [Tools > Macro > Security] и измените уровень безопасности на Средний [Medium] или более низкий.

Для установки макроса откройте редактор Visual Basic. Выберите Сервис > Макросы > Редактор Visual Basic [Tools > Macro > Visual Basic Editor]. В окне проекта слева кликните правой кнопкой мыши на иконке проекта в верхней части дерева и выберите «Импорт файла» (Import File). Найдите каталог, куда вы распаковали Outlook2iCal, и выберите файл frmSaveiCalStep1.frm. Сделайте то же самое с другими файлами в этом же каталоге: frmSaveiCalStep2.frm, frmSaveiCalStep3.frm, clsFTP.cls и icalendar.bas. Закройте редактор Visual Basic.

LXF100 71 1.jpg Импортируйте почтовые сообщения с помощью Mozilla Thunderbird для Windows.

Теперь можете запустить макрос, выбрав Tools > Macro > Macros > export_icalendar > Run. Макрос запустит несложного Мастера. Выберите календарь, который хотите экспортировать, и нажмите Далее [Next]. Если календарь у вас большой, придется немного подождать. При наличии в календаре категорий, на этой стадии вы сможете отобрать из них только нужные, либо выбрать Export All Appointments In Calendar [Выбрать все]. Сохраните календарь на диске, задав ему имя и местоположение. Нажмите Завершить [Finish]. Теперь календарь можно скопировать на носитель, предназначенный для переноса данных.

Почта

Сложнее всего экспортировать почтовый архив, особенно если он рассортирован по папкам, а некоторых сообщений нет ни в одной папке Outlook. Прежде чем начать, создайте каталог для таких сообщений и перенесите их туда. Вы также обнаружите, что чем больше файл PST, тем выше вероятность возникновения проблем с его экспортом, и лучше уменьшить количество сообщений до начала процесса. Сейчас самое время найти сообщения, которые вряд ли понадобятся снова и просто занимают место, и удалить их. Небольшое «обезжиривание» повысит шансы на успех.

Outlook не экспортирует данные в какой-либо из открытых почтовых форматов, и нам потребуется программа-посредник. Другие программы, запущенные в той же системе, что и Outlook, могут импортировать почту непосредственно из Outlook, так как у них есть доступ к библиотекам для декодирования PST-файлов. Это означает, что данные из Outlook можно перенести в Windows-версию Thunderbird, конвертируя их в открытый формат.

Загрузить Thunderbird для Windows можно с сайта http://www.mozilla-russia.org/products/thunderbird/. Установите ее в Windows обычным образом. При первом запуске Thunderbird будет предложено импортировать данные и настройки. Выберите «Не импортировать ничего на этом этапе [Don’t Import Anything At This Stage]. Также не нужно делать Thunderbird почтовой программой по умолчанию. Потом можно будет импортировать сообщения поэтапно, если потребуется.

LXF100 71 2.jpg Если Thunderbird импортировал почтовые папки, значит, они пригодны для переноса в Linux.

В Thunderbird выберите пункт меню Сервис > Импорт [Tools > Import] и затем Почта [Mail]. Нажмите Далее [Next] и выберите импорт данных из Outlook. Снова нажмите Далее, чтобы начать импорт. Thunderbird сконвертирует почтовые папки Outlook и после завершения импорта покажет результат. Полюбопытствуйте в какой-нибудь из папок, правильно ли были импортированы сообщения или нет. Если все хорошо, закройте Thunderbird, так как теперь можно просто скопировать почтовые папки, которые он использует. Обычно они находятся в каталоге C:\Documents and Settings\имя_пользователя\Application Data\Thunderbird\Profiles\идентификатор_профиля\Mail\Local Folders в Windows XP и в каталоге C:\Users\имя_пользователя\AppData\Local\Thunderbird\Profiles\идентификатор_профиля\Mail\Local Folders в Vista. Чтобы увидеть каталог AppData, нужно включить отображение скрытых файлов и каталогов. Для этого в XP откройте папку и выберите Сервис > Свойства папки > Вид > Показывать скрытые файлы и папки [Tools > Folder Options > View > Show hidden files and folders]. В Vista быстрее всего это можно сделать, напечатав Folder Options в строке поиска меню «Пуск». Скопируйте содержимое папки Mail целиком на диск для переноса данных в Linux.

При импорте большого объема писем в Thunderbird могут возникнуть проблемы. В этом случае полезно попробовать экспортировать данные порциями, каждый раз сохраняя копию файла PST и удаляя все сообщения, которые не входят в заданный диапазон дат. Оставшиеся сообщения затем можно импортировать в Thunderbird и скопировать файлы таким же образом, как и раньше. После этого нужно вернуться в Outlook, импортировать PST-файл из резервной копии и повторить эти операции с другим диапазоном дат. Воспользуйтесь этим подходом, если импортировать архив целиком не удается.

Контакты

Скорая помощь

При экспорте данных из файла ICS диапазон дат ограничен десятью годами. Для повторяющихся событий, вроде дней рождения, которые выпадают из этого диапазона, может потребоваться изменение их повторяемости при импорте в Evolution.

Самый простой способ перенести контакты – экспортировать их в CSV-файл из Outlook. Выберите пункт меню Файл > Импорт и Экспорт > Экспорт в файл > Разделенные запятыми значения (DOS) > Контакты [File > Import and Export > Export to a file > Comma Separated Values (DOS) > Contacts] и укажите имя файла и каталог, в который он будет сохранен. После создания файла скопируйте его на диск для переноса данных.

Альтернатива – импортировать контакты Outlook в Windows-версию Thunderbird и затем экспортировать их оттуда. Этот подход удобен, когда файл CSV не импортируется должным образом в новую почтовую программу. В Thunderbird выберите Сервис > Импорт > Адресные книги > Outlook [Tools > Import > Address Books > Outlook] и подождите, пока импортируются контакты. Затем нажмите кнопку Адресная книга [Address Book] на панели инструментов и выберите адресную книгу, предназначенную для экспорта. Выберите пункт меню Сервис > Экспорт [Tools > Export] и укажите имя файла. Оставьте тип адресной книги по умолчанию (LDIF) и нажмите кнопку Сохранить [Save]. Теперь можно скопировать этот файл на диск с остальными файлами.

Задачи

С задачами будет посложнее, потому что, в отличие от календарей, единого формата файлов для них нет. Как и список контактов, задачи можно экспортировать в файл формата CSV. К несчастью, этот файл не получится импортировать ни в Evolution, ни в Kontact, что немного раздражает. Впрочем, можно распечатать список контактов из Outlook, чтобы потом было проще снова вводить их вручную.

Импорт в Linux

Экспортировав календарь, сообщения электронной почты, контакты и задачи в лучших возможных для Outlook форматах, можете переносить их в Linux и импортировать в подходящую программу. Подключите диск для переноса данных или смонтируйте CD или DVD с ними и скопируйте данные в ваш домашний каталог. Можно этого и не делать, но гарантия того, что данные сохранены локально, поможет существенно упростить все, что мы будем делать дальше.

Контакты

Скорая помощь

Воспользуйтесь утилитой экспорта Outlook для сохранения резервной копии PST-файла. Это поможет восстановить данные, если вы случайно удалите не те сообщения или угробите данные в процессе переноса. Записав эту копию на DVD, вы будете уверены, что данные в сохранности, пусть и в закрытом формате. В чрезвычайной ситуации вы можете воспользоваться компьютером друга с ОС Windows.

Начнем с самого простого. Откройте Evolution и нажмите на кнопку Контакты [Contacts]. Выберите Файл > Импорт [File > Import]; запустится Мастер Импорта Evolution [Evolution Import Assistant]. Нажмите Вперед [Forward] и выберите Импорт из файла [Import a single file]. Нажмите Вперед [Forward], затем кнопку Имя файла [Filename]. Выберите CSV-файл, содержащий данные о контактах. Нажмите Вперед [Forward] и укажите каталог, куда будут импортированы данные (скорее всего, персональные папки). Нажмите Вперед [Forward], затем Импорт – и дело сделано. Просмотрите некоторые контакты, чтобы убедиться в правильности импорта. Если в CSV-файле есть ошибки сдвига строки или поля, не распознаваемые Evolution, могут возникнуть проблемы.

Если импорт не удался, откройте CSV-файл с контактами в редакторе электронных таблиц и сравните содержимое полей с контактами, чтобы понять причину ошибки. Попробуйте отредактировать файл таким образом, чтобы поля в нем появлялись в том же порядке, в котором они импортируются Evolution. Сохраните копию файла под другим именем и удалите все контакты в Evolution. Импортируйте измененную версию CSV-файла. Если счастья все нет, попробуйте сгенерировать адресную книгу в формате LDIF с помощью Windows-версии Thunderbird и импортируйте в Evolution ее.

LXF100 73 1.jpg Импортируйте свой список контактов в формате CSV в Evolution, чтобы создать адресную книгу под Linux.

Если вы используете Kontact, запустите программу и нажмите на кнопку Контакты [Contacts]. Выберите Файл > Импорт > Импорт файла CSV [File > Import > Import CSV list] и укажите файл с контактами. Здесь можно столкнуться с теми же проблемами, что и в случае с Evolution, и если импорт данных из CSV не получается, решением опять будет импорт из LDIF-файла. Если вы предпочитаете Thunderbird, то там импортировать контакты очень просто. Запустите программу и выберите Сервис > Импорт > Адресные книги [Tools > Import > Address Books] и укажите файл, который хотите импортировать. Для лучшей совместимости можно пропустить контакты Outlook через Thunderbird для Windows, а уж потом переносить их в Linux.

Календарь

LXF100 73 2.jpg Можно импортировать календарь в формате ICS в Evolution или связать его с web-календарем.

Теперь импортируем ваши встречи. В Evolution переключитесь на календарь и выберите Файл > Импорт [File > Import]. Запустится мастер импорта. Нажмите Вперед [Forward] и выберите Импорт из файла [Import a single file]. Нажмите кнопку рядом с именем файла и выберите свой файл формата ICS. Нажмите Открыть [Open], затем Вперед [Forward] и выберите календарь, который хотите импортировать. Нажмите Импортировать [Import] для выполнения импорта.

В Kontact переключитесь на календарь и выберите пункт меню Файл > Импорт > Импортировать календарь [File > Import > Import Calendar]. Найдите ICS-файл и нажмите Открыть [Open]. Выберите Объединить с текущим календарем [Merge Into Existing Calendar] и нажмите OK.

Если вы хотите работать с почтой и контактами в Thunderbird, то знайте, что календаря в нем нет. Поэтому вам может пригодиться программа Mozilla Sunbird, найти которую можно на странице http://www.mozilla-russia.org/projects/calendar/sunbird/. Загрузите версию под Linux и распакуйте содержимое архива в свой домашний каталог. В окне терминала перейдите в каталог Sunbird и введите команду sh sunbird для запуска программы. Выберите Файл > Импорт [File > Import], найдите ICS-файл, содержащий календарь, и выберите Открыть [Open], чтобы импортировать его.

Почта

Экспортировав почтовые папки с помощью Thunderbird для Windows, импортировать их в Linux на удивление просто: нужно всего лишь скопировать файлы в правильное место. Откройте свой домашний каталог и выберите Вид > Отображать скрытые файлы [View > Show hidden files]. Откройте каталог .evolution, а затем – почтовый каталог и локальный каталог. Туда-то и нужно скопировать файлы почтовых папок. Откройте новое окно для просмотра экспортированных файлов. Скорее всего, вы найдете их в папке Local Folders, куда бы вы их ни копировали. С каждой почтовой папкой связано два файла; оба они называются так же, как и папка, но у одного есть расширение MSF.

Например, для папки Входящие [Inbox] есть файлы inbox и inbox.msf. Скопируйте эти файлы в локальный каталог в .evolution/mail. Сделайте то же самое для остальных каталогов, которые нужно импортировать. Откройте Evolution и нажмите на кнопку Почта [Mail], и вы увидите импортированные папки и электронные сообщения.

В Kontact все примерно так же. Нужно найти каталог ~/.kde/share/apps/kmail/mail, где ~/ – ваш домашний каталог. Как и для Evolution, скопируйте туда почтовые папки. Запустите Kontact и переключитесь на вкладку Почта [Mail]. Там вы увидите свои почтовые папки и сообщения. В Thunderbird процедура практически аналогична. Откройте каталог ~/.mozilla-Thunderbird/идентификатор_профиля/Mail/Local Folders, скопируйте туда почтовые папки и запустите Thunderbird, чтобы проверить, что все в порядке. Помните, что папки, имена которых начинаются с точки, вы увидите, только включив показ скрытых файлов. Если все подготовительные действия в Windows были правильными, то импорт почтовых папок в Linux – это всего лишь копирование файлов в правильное место.

Задачи

Скорая помощь

Проверить содержимое CSV-файла можно в редакторе электронных таблиц OpenOffice.org. Это поможет вам определить, не сбились ли в файле границы полей, из-за чего данные могут распознаваться неправильно. Если вы решили произвести изменения в файле, сохраните его под другим именем и убедитесь, что также сохранили его в CSV.


К сожалению, список задач, он же To Do list, похоже, придется создавать заново. И это очень обидно, потому что теории он должен быть небольшим, но я еще не придумал, как надежно перенести данные из Outlook в другую программу. Экспортировав список задач в CSV-файл, можно открыть его в редакторе электронных таблиц и скопировать и вставить содержимое каждой записи, но это не очень удобно, так как каждое поле нужно копировать и вставлять отдельно. Может, проще просто распечатать этот список и потратить некоторое время на его ручной ввод.

И в Evolution, и в Kontact есть возможность импортировать список задач. В Evolution переключитесь на список задач и выберите Файл > Импорт [File > Import]. Откроется мастер импорта. В Kontact выберите Список задач > Файл > Импортировать в Kontact [Todo list > File > Import in Kontact]. Evolution импортирует список нормально, но всегда перемешивает его со списком контактов, и от этого мало толку. Обе программы импортируют список задач из ICS-файлов, но для этого нужно иметь возможность экспортировать его из Outlook в этом формате. С календарем все более или менее просто, но для задач нет соответствующего фильтра. Некоторые web-календари выполняют импорт CSV-файлов, после чего теоретически возможно подключиться к соответствующему web-календарю или списку задач при помощи обоих приложений, но так как стандартного способа записи задач в ICS-файл нет, то от этого тоже мало проку: вы можете только зря потерять время, экспортируя и импортируя файлы из приложения в приложение.

Единственный выход в том случае, если вы не хотите вводить данные вручную в Evolution, Kontact или Sunbird – воспользоваться web-ориентированным списком задач. Проект Remember The Milk (http://www.rememberthemilk.com) предоставляет список задач, в который можно очень просто импортировать свои задачи. Зайдите на сайт и создайте учетную запись (бесплатно). После заполнения необходимых полей и подтверждения регистрации можно отправить список задач по электронной почте. Зайдите в свой профиль и кликните на ссылке Settings в правом верхнем углу. Затем выберите вкладку Info. На ней вы найдете электронный адрес для импорта сообщений (Import Email Address). Скопируйте его и создайте новое письмо на этот адрес. В теме письма введите имя файла списка, в котором будет отправлен список задач. Откройте свой CSV-файл в редакторе электронных таблиц и скопируйте столбец, содержащий названия задач. Вставьте этот столбец в текст письма и отправьте его. Список задач будет импортирован на сайт, но даты и времена все-таки будут отсутствовать. LXF

Outlook Express

Хотя Outlook Express и не использует файлы формата PST, проблем с ним не меньше. Выбрав Файл > Экспорт > Сообщения [File > Export > Messages], можно экспортировать сообщения электронной почты, но только в Outlook или Microsoft Exchange – ни то, ни другое вас не спасет. Но можно воспользоваться тем же приемом, что и с Outlook. В Thunderbird выберите Сервис > Импорт [Tools > Import] и затем Почта [Mail]. Затем кликните Дальше [Next] и выберите Импорт данных из Outlook Express [Import from Outlook Express]. Почтовые папки будут преобразованы в формат Thunderbird: скопируйте их на диск для переноса данных. Адресную книгу Outlook Express можно экспортировать, выбрав пункт меню Файл > Экспорт > Адресная книга > Текстовый файл (Разделенные запятыми значения) > Экспорт [File > Export > Address Book > Text File (Comma Separated Values) > Export]. Укажите имя файла и каталог и завершите работу мастера.

Персональные инструменты
купить
подписаться
Яндекс.Метрика