Журнал LinuxFormat - перейти на главную

LXF151:LibreOffice: Путь к MS Word

Материал из Linuxformat
(перенаправлено с «LXF151:tut2»)
Перейти к: навигация, поиск

Как заставить открытое ПО работать с MS

Наш эксперт Бен Эверард

Бросил работу ИТ-консультанта, чтобы провести два года в Танзании за установкой в школах систем на базе Ubuntu. Теперь он проводит свое время в писательстве про свободное ПО и свои путешествия.

Оставьте неполные шрифты и странные раскладки страниц в прошлом – по советам мастера Слова Бена Эверарда создайте гармонию в документах.

Как бы вы ни относились к проприетарному ПО, факт остается фактом: почти каждый пользователь Linux рано или поздно сталкивается с теми, кто использует Microsoft Office. Но бояться не стоит: хотя совместимость между LibreOffice и его проприетарным эквивалентом не совершенна, она уже неплоха и становится лучше. Используя Writer, вы запросто откроете файлы Word (и DOC, и DOCX) и внесете правки. Однако в нескольких областях совместимость между двумя приложениями не проходит гладко, и мы рассмотрим их здесь. При работе с форматами Microsoft важно использовать самую последнюю версию LibreOffice, так как совместимость возрастает с каждой новой версией.

Содержание

Форматирование

Большинство дистрибутивов Linux предлагают ряд открытых шрифтов, примерно эквивалентных шрифтам Windows. Чаще всего можно переключаться между двумя наборами шрифтов без проблем, но если важно сохранить макет страницы, учтите, что мелкие различия символов накапливаются, обуславливая несхожесть.

В 1996 году Microsoft выпустила набор бесплатных шрифтов, чтобы web-пользователи могли просматривать страницы в одинаковом формате, независимо от платформы, на которой они работают. В их числе – Arial, Times New Roman и несколько других распространенных шрифтов, известных под общим названием Основные шрифты для Web.

По условиям лицензии, они могут распространяться только в своих оригинальных файлах (EXE для ОС Windows или HQX для Apple), но лицензия не накладывает условий на системы, в которых можно их использовать, так что их можно установить в Linux; но это надо сделать из файлов Windows. В одних дистрибутивах есть пакеты, делающие это за вас (ttf-mscorefonts-installer на Debian и производных и fetchmsttfonts на SUSE), но в других придется делать это вручную под руководством на http://corefonts.sourceforge.net.

Если макет страницы имеет решающее значение, используйте эти шрифты, а не открытые. Последние версии Microsoft Office и Windows по умолчанию имеют другой набор шрифтов, выпущенных на иных условиях, чем Основные. Переход с этих новых шрифтов на старые создаст согласованность между операционными системами.

(thumbnail)
Онлайн-версии приложений Microsoft Office уменьшили функционал, особенно по части безопасности и сотрудничества.

Даже при одинаковых шрифтах, форматирование остается одним из камней преткновения для взаимодействия между двумя приложениями. Различие между разметкой документа в Writer и Word не сильно заметно, но если дизайн страницы важен, много мелких ошибок создают большую разницу. Чтобы обеспечить ожидаемый вид на обеих системах, можно предпринять несколько действий:

  • Сохранить как файл PDF Если вы создаете документ и хотите, чтобы пользователь Windows видел его определенным образом – например, чтобы это была одна страница – но не вносил каких-либо изменений, сохраните его в формате PDF. Это обеспечит одинаковую раскладку во всех операционных системах, но затруднит получателю внесение изменений. Чтобы экспортировать документ в формате PDF, в Writer выберите Файл > Экспорт в PDF.
  • Просмотрщики документов Microsoft Если вы получаете документ в формате DOC или DOCX, который вам нужно просмотреть или распечатать именно так, как задумал автор, можно использовать просмотрщик документов от Microsoft. Просмотрщики доступны для Word, Excel и PowerPoint из http://www.microsoft.com/download/en/compatibility.aspx?q=compatibility (выберите в категории продукта). Они будут работать в последних версиях Wine. Обзаведясь просмотрщиком, установите также Microsoft Office Compatibility Pack For Word, Excel And PowerPoint File Formats, что позволит просматривать самые последние форматы файлов (доступны на том же сайте; выберите инструмент в Тип загрузки). Также можно использовать их, чтобы убедиться, что документы, созданные в LibreOffice, будут правильно отображаться в Microsoft Office.
  • Microsoft Office Web Apps Чтобы внести незначительные изменения в документ без изменения форматирования, как он отображается в Word, можно использовать Microsoft Office Web. Это онлайн-версии Word, Excel, PowerPoint и OneNote, доступные на http://office.microsoft.com/en-gb/web-apps. Доступ к ним бесплатный, хотя придется подписаться на Microsoft Live ID, если у вас его еще нет. Хотя они не обладают всеми функциями, имеющимися в LibreOffice или его оффлайн-конкурентах, они позволяют загрузить файл, созданный в LibreOffice, и исправить возможные ошибки форматирования, так что он будет правильно отображаться у пользователей Windows. Мы выяснили, что web-приложения Office Web Apps работают под Chrome и Firefox, но не Konqueror или Epiphany. Если у вас установлено расширение Moonlight, вам может понадобиться отключить его перед открытием Office Web Apps.

Чтобы сохранить форматирование в целом ряде документов, многие организации используют шаблоны. И Word, и Writer их используют, однако используют по-разному. В Word шаблоны представляют собой набор стилей и макетов страниц, а в Writer это просто набор стилей. Это означает, что если вы используете шаблоны Word в Writer, всю функциональность вам не получить.

Стилистический совет

(thumbnail)
Про­смотр­щи­ки фай­лов Microsoft Office, запускаемые под Wine, дос­туп­ны на сай­те MS.

Чтобы создать новый документ в Writer из шаблона Word, перейдите в меню Файл > Создать > Шаблоны и Документы, затем к Шаблон файла. Так вы перейдете в стили из шаблона, и они будут появляться в окне Стили и форматирование (нажмите клавишу F11, чтобы открыть). Если у вас есть доступ к копии Word, вы можете преобразовать шаблон для обычного файла. Это позволит вам редактировать файлы в LibreOffice с сохранением макета шаблона. Откройте файл в Word, и везде, где есть Нажмите для ввода текста, введите текст, а затем сохраните файл. При открытии файла в LibreOffice теперь есть стили и макет шаблона. Пользователи, не имеющие доступа к Word, могут использовать web-приложения Office Web Apps, чтобы открыть шаблон и просмотреть расположение (без добавления содержимого). Затем вручную создайте макет в Writer. LXF151.tut_libreoffice.4.jpg

Макросы

(thumbnail)
238569.png Secure Online Desktop дает доступ к приложениям Microsoft за помесячную оплату — плюс скидка в 50% для преподавателей и студентов.

Макросы – одна из самых больших проблем при уходе с Microsoft Office на LibreOffice. Проще говоря, макрос Word не будет работать под Writer. Однако языки, используемые двумя системами, похожи, и любой, кто умеет писать макросы на VBA, сочтет переход на LibreOffice Basic довольно безболезненным.

Если вы используете документ Word, содержащий макросы, которые вам не нужны, велите Writer сохранять документы, не трогая макросов: зайдите в меню Инструменты > Настройки в Загрузка/Сохранение > Свойства VBA и отметьте Save Original Basic Code. Это не поможет запустить макросы в Writer, но сохранит их работоспособность при открытии документа в Word.

Если вам не обойтись без макроса VBA, придется запустить Word, и есть несколько способов это сделать. Можно запустить Windows с помощью либо VirtualBox, либо двойной загрузки, или запустить Word на Linux через Wine или CrossOver Office (не все версии Word работают одинаково хорошо: проверьте http://appdb.winehq.org или http://www.codeweavers.com).

Если Word нужно запускать лишь изредка, вы можете сделать это, не тратясь на покупку этой программы. Нет, мы говорим не о пиратском программном обеспечении, а об использовании удаленных рабочих столов. Есть компания, которая запускает сервер Windows и за определенную плату выдает удаленный доступ к программному обеспечению Windows.

В настоящее время большинство размещенных предложений рабочего стола направлены на коммерческое использование, с пакетами для большого числа узлов и длительным периодом подписки. Secure Online Desktop (http://secure-od.com), однако частным пользователям позволяется использовать систему на основе помесячной платы.

Чтобы получить доступ, купите подписку, затем установите 2XClient (доступно в файлах Deb, RPM и BZIP2 с сайта). После установки запускайте клиента, набрав /opt/2X/Client/bin/2XClient в командной строке. Это не предоставит вам полный рабочий стол, но позволит запускать различные офисные приложения удаленно, а также получить доступ к вашим документам со смартфона. К сожалению, такая установка не позволяет открывать документы с ограничением по правам.

Совместная работа

Скорая помощь

При запуске приложений Windows под Linux всегда старайтесь использовать последнюю версию Wine, поскольку она постоянно развивается.

Работа с пользователями других систем заключается не только в том, чтобы создаваемые документы выглядели одинаково, но и чтобы несколько авторов эффективно работали вместе. Одним из основных инструментов сотрудничества является возможность добавлять комментарии, полезные, когда много людей работает над одним документом или когда кто-то делает отзыв на документ, созданный другими.

Единственное важное различие работы двух систем с комментариями заключается в том, что Word добавляет их в раздел текста, а Writer добавляет их в определенную позицию в тексте. Блоки комментариев, созданные в Word, в Writer отображаются в конце. Для вставки комментариев в Writer, поместите курсор в нужное место и перейдите на Вставить > Комментарий. Так же и в Word, кроме того, что вы можете выделить фрагмент текста для создания комментариев к нему.

Оба приложения позволяют также выделить цветом участки текста, но хотя Writer может удалить выделение, добавленное в Word, выделение, созданное в Writer, в Word не отображается, и инструмент выделения не может удалить его; вместо этого вам придется применить форматирование. В ранних версиях Word, до 2007, выберите Формат > Стили И Форматирование, затем выберите Очистить Формат в списке Выбора формата. В Word 2007 и 2010, выберите выделенный текст, щелкните на нем правой кнопкой мыши, а затем перейдите в Стили > Очистить Форматирование. Если вы работаете в Linux и хотите добавить выделение, видимое в Word, используйте Office Web Apps.

Оба текстовых процессора позволяют отслеживать изменения, внесенные в документ. Применять это лучше всего, когда документ почти закончен и остаются только мелкие правки: иначе он может получиться громоздким. В Writer работа с файлами DOCX немного нестабильна, поэтому рекомендуем сохранять почаще. Для включения этого в Writer, перейдите в Правка > Изменения > Запись. В Word 2003 и более ранних версиях это можно найти в меню Сервис > Исправления, а в более поздних – на вкладке Рецензирование. После включения изменения будут отображаться цветом и подчеркиванием. При отправке файла другим пользователям те смогут решить, что применить в документе, щелкнув правой кнопкой на цветном тексте и выбрав Принять исправление или Отменить исправление в контекстном меню. Иногда эти параметры не появляются в контекстном меню. Если это так, поместите курсор внутри выделенного текста, прежде чем щелкнуть правой кнопкой мыши. Некоторые пользователи сообщают, что сохранение документов с изменениями в DOCX ведет к краху LibreOffice. Если вы с этим столкнулись, сохраните документ в формате RTF.

(thumbnail)
Уч­ти­те, что Writer по­ме­ща­ет ком­мен­та­рии в оп­ре­де­лен­ном мес­те тек­ста, а не ко все­му тек­сто­во­му бло­ку.
(thumbnail)
Учтите, что Writer помещает комментарии в определенном месте текста, а не ко всему текстовому блоку.

Сравнение и слияние документов

Вместо отслеживания изменений, вы можете сделать их в новом документе и использовать функцию Сравнение Документов. Это позволит отобразить изменения в оригинале с возможностью принять или отменить каждое из них. В наших тестах, LibreOffice упал, когда мы делали это с файлами DOCX, поэтому, прежде чем начать, вам, возможно, потребуется преобразовать все файлы в другой формат (для форматов DOC, ODT и RTF все работало нормально). При необходимости можно конвертировать финальную версию файла обратно в DOCX после слияния.

Откройте измененный документ и перейдите в Правка > Сравнить документы; появится окно, где можно выбрать оригинал, который вы хотите объединить. LibreOffice затем выделит все изменения и отобразит их, так что вы можете принять или отклонить их так же, как и раньше. Обратите внимание, что вы начинаете с документа с правками, а не с оригинала – это означает согласие с добавлением изменений. Если вы начнете с оригинала, вы должны выбрать Отклонить, чтобы добавить изменения, а это слегка неинтуитивно. Мы также обнаружили, что начав с документа с правками, мы получили меньше ошибок форматирования. Правка > Изменения > Объединить Документы должна бы выполнять это автоматически, но все наши попытки кончились провалом.

Для выполнения той же операции в Word, начните с оригинала документа (то есть документ, противоположный Writer) и выберите Сервис > Сравнить И Объединить.

Writer позволяет сохранить несколько версий документа в одном файле: создавайте и сохраняте версии, перейдя в Файл > Версии. Увы, поддерживается эта функция только в формате ODT, но не в RTF, DOC и DOCX. Если вы получили файл DOC с версиями в нем и внесли в него изменения, при сохранении Writer сотрет предыдущие версии. Word поддерживает эту функцию в файлах DOC, но не DOCX. Единственный способ обойти проблему – использовать различные файлы для каждой версии. Microsoft выпустила Version Extraction Tool как часть Office Migration Planning Manager, который преобразует один файл, содержащий много версий, в множество файлов с отдельными версиями. Однако это работает только в Windows, а не через Wine или CrossOver Office.

Другие приложения Microsoft Office

Скорая помощь

Перенос из Writer в Word иногда приводит к повреждению документов, поэтому хорошей идеей является создание резервной копии.

Менее популярные офисные приложения работают под Linux хуже.

С помощью MDBTools можно заставить Base открыть более старые (до 2007) файлы Access только на чтение, но поддержка нестабильна.

В рамках Лета за кодом 2011, Эйлид Макадам [Eilidh McAdam] работает над фильтром импорта, чтобы позволить пользователям LibreOffice Draw открывать файлы Visio. Когда вы будете читать эти строки, функция может появиться в последнем релизе LibreOffice. Если нет, вы сможете получить доступ к нему путем компиляции кода из Git.

Есть несколько альтернатив с открытым кодом в Project, способных читать файлы MPP и MPX, такие как OpenProj и Planner.

Файлы PUB от Publisher – самые сложные из всех проприетарных файловых форматов Microsoft при открытии в Linux. По нашим данным, приложений Linux, способных открыть эти файлы, нет, а Publisher не запускается под Wine и получает только бронзовую медаль по совместимости в CrossOver Office. Существуют онлайн-нструменты преобразования, которые могут конвертировать эти файлы в PDF-файлы под Linux. Вы можете получить доступ к Publisher через Secure Online Desktop.

Calc и Impress

Наряду с Writer, Calc и Impress входят в базовые приложения LibreOffice. Как и Writer, эти два тоже умеют читать и писать в последние версии файлов (XLSX и PPTX), но лучше работают с более ранними версиями (XLS и PPT).

В LibreOffice версии 3.4, функция DataPlot была улучшена и переименована в PivotTable, ради соответствия с Excel. Два камня преткновения в Writer также имеются и в Calc: макросы и права собственности. Расположение является еще одним источником проблем, особенно при использовании диаграмм или графиков, так что перед отправкой пользователю Excel хорошей идеей будет проверить ваши файлы в Excel Viewer или Office Web Apps.

Форматирование и расположение часто более важны при использовании файлов PowerPoint. PowerPoint Viewer работает под Wine только c возможностью просмотра PPT, в то время как Office Web Apps может открывать как эти, так и PPTX-файлы. Если ваш web-браузер поддерживает полноэкранный режим, можете использовать Office Web Apps для создания презентаций из PPTX-файлов, если расположение под Impress несовершенно.

Безопасность

Скорая помощь

При работе с Writer и Word по возможности используйте файлы DOC, а не DOCX.

Помогать многим пользователям работать над документом – это прекрасно, но иногда нужно ограничить, какие пользователи что могут делать. Word имеет более широкий набор функций безопасности, чем Writer, и совместимость между двумя системами хороша, но не идеальна. В общем, в LibreOffice лучше поддерживается безопасность DOC-файлов, чем DOCX. Простейший метод защиты файла реализуется путем добавления пароля для его открытия. Это прекрасно работает с файлами DOC, но не с новым форматом. LibreOffice откроет защищенные паролем файлы DOCX, но не сможет сохранить в них изменения. Если вы сохраните файл DOCX, защищенный паролем в Writer, он останется без пароля.

И Writer, и Word работают с файлами DOC только-для-чтения одинаково, то есть позволяют открыть файл и читать его, а если вы сохраните его под другим названием, то сможете его редактировать. Writer, однако, не распознает флаг «только для чтения» у файлов DOCX и позволяет редактировать их и сохранять изменения в исходном файле. В Word этот файл будет по-прежнему только для чтения.

(thumbnail)
DOC-файлы с паролем позволят разделять информацию довольно безопасно, но для лучшей защиты зашифруйте их.

Кроме того, в Word можно сохранить файл с Паролем На Изменение. Это означает, что любой пользователь может читать файл, о вносить в него изменения могут только пользователи, знающие пароль. Поведение LibreOffice с этими файлами меняется. DOC-файлы, сохраненные таким образом, будут открыты только для чтения, и вы можете редактировать их, сохраняя как новый файл. DOCX-файлы, однако, будут редактироваться без ограничений. Writer может установить пароль для изменения (при сохранении отметьте флажок Сохранить с паролем, затем нажмите кнопку Сохранить и в поле пароля нажмите кнопку Дополнительно), но мы обнаружили, что это не работает – как в Writer, так и в Word файл открыт только для чтения. В Writer это не проблема, потому что можно использовать Сохранить как. Однако Word открывает эти файлы таким образом, что даже не позволяет копировать и вставлять текст в новый файл.

Word также позволяет ограничить диапазон стилей, применяемых пользователями. Файлы, сохраненные таким образом, работают по-другому в зависимости от формата файла. DOC-файлы открываются только для чтения, и вы должны сохранить их под другим названием, прежде чем приступить к их редактированию, а DOCX-файлы открываются нормально, но без ограничений. Writer не имеет средств для сохранения файлов с этим типом безопасности.

Одним из аспектов безопасности документов, который не работает в Linux, было управление правами. Word позволяет автору установить так, чтобы только определенные люди (по имени пользователя Windows Live) могут открывать и редактировать документ. С этой настройкой, мы обнаружили, что файл не удалось открыть в LibreOffice, AbiWord, Office Web Apps, Microsoft или ПО, работающем в Wine или CrossOver Office. Это одна из областей, где единственным вариантом является использование Windows – или попросите человека, который отправляет вам файл, снять эти ограничения.

Форматы файлов

С момента выпуска первых открытых текстовых процессоров, их разработчикам приходилось играть в догонялки с Microsoft по поводу форматов файлов. Стоило разработчикам открытого исходного кода наконец придумать, как читать и записывать DOC-файлы, как Microsoft немедленно закрыла формат. Циничные читатели могут предположить, что то же самое произойдет и с DOCX. Тем не менее, DOCX основана на Office Open XML, а это опубликованный стандарт. Проблемой для LibreOffice является то, что текущая реализация отклоняется от стандарта. Microsoft объявила о своем намерении полностью поддерживать стандарт в следующей версии Office – что не во благо для свободы, поскольку она покрыта патентами Microsoft – но они согласились не подавать в суд на фирмы, которые используют его, так что это должно привести к лучшему взаимодействию между двумя офисными пакетами.

Персональные инструменты
купить
подписаться
Яндекс.Метрика